summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-28 16:14:22 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-28 16:24:08 -0600
commite248f9bbf5563be7d6185fd146db364df83a9988 (patch)
tree0438fa10c58526bfcb34bebbb9887eadd925c464 /app-editors
parentmedia-gfx/geeqie: add live ebuild (diff)
downloadgentoo-e248f9bbf5563be7d6185fd146db364df83a9988.tar.gz
gentoo-e248f9bbf5563be7d6185fd146db364df83a9988.tar.bz2
gentoo-e248f9bbf5563be7d6185fd146db364df83a9988.zip
app-editors/vim-core: avoid icon file collision with gvim
And update icon cache. Closes: https://bugs.gentoo.org/673926 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/vim-core-8.1.0648.ebuild12
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild12
2 files changed, 20 insertions, 4 deletions
diff --git a/app-editors/vim-core/vim-core-8.1.0648.ebuild b/app-editors/vim-core/vim-core-8.1.0648.ebuild
index 3c18feca9036..1aeb3a66d543 100644
--- a/app-editors/vim-core/vim-core-8.1.0648.ebuild
+++ b/app-editors/vim-core/vim-core-8.1.0648.ebuild
@@ -3,7 +3,7 @@
EAPI=6
VIM_VERSION="8.1"
-inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop
+inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop gnome2-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -23,6 +23,8 @@ LICENSE="vim"
IUSE="nls acl minimal"
DEPEND="sys-devel/autoconf"
+# avoid icon file collision bug #673880
+RDEPEND="!!<app-editors/gvim-8.1.0648"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
S=${WORKDIR}/vim-${PV}
@@ -207,11 +209,17 @@ src_install() {
}
pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
+ # update documentation tags (from vim-doc.eclass)
update_vim_helptags
+
+ # update icon cache
+ gnome2_icon_cache_update
}
pkg_postrm() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
+
+ # update icon cache
+ gnome2_icon_cache_update
}
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 3c18feca9036..1aeb3a66d543 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
VIM_VERSION="8.1"
-inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop
+inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop gnome2-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -23,6 +23,8 @@ LICENSE="vim"
IUSE="nls acl minimal"
DEPEND="sys-devel/autoconf"
+# avoid icon file collision bug #673880
+RDEPEND="!!<app-editors/gvim-8.1.0648"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
S=${WORKDIR}/vim-${PV}
@@ -207,11 +209,17 @@ src_install() {
}
pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
+ # update documentation tags (from vim-doc.eclass)
update_vim_helptags
+
+ # update icon cache
+ gnome2_icon_cache_update
}
pkg_postrm() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
+
+ # update icon cache
+ gnome2_icon_cache_update
}