summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-01-24 13:40:22 +0900
committerPatrice Clement <monsieurp@gentoo.org>2017-01-24 10:32:14 +0100
commite380ffe8d135faa24a151dbd8efc6777d6599b75 (patch)
treeb70ba49c3927f9f1af5ee687371de46e06f06fb8 /app-editors
parentsys-devel/llvm: Revert "Force x86 CHOST to i386-* [...]" (diff)
downloadgentoo-e380ffe8d135faa24a151dbd8efc6777d6599b75.tar.gz
gentoo-e380ffe8d135faa24a151dbd8efc6777d6599b75.tar.bz2
gentoo-e380ffe8d135faa24a151dbd8efc6777d6599b75.zip
app-editors/{g,}vim: remove vulnerable versions.
Gentoo-Bug: https://bugs.gentoo.org/600650 Closes: https://github.com/gentoo/gentoo/pull/3615
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/Manifest5
-rw-r--r--app-editors/gvim/gvim-7.4.2102.ebuild390
-rw-r--r--app-editors/gvim/gvim-7.4.769.ebuild414
-rw-r--r--app-editors/gvim/gvim-8.0.0005.ebuild408
-rw-r--r--app-editors/vim/Manifest5
-rw-r--r--app-editors/vim/vim-7.4.2102.ebuild349
-rw-r--r--app-editors/vim/vim-7.4.769.ebuild384
-rw-r--r--app-editors/vim/vim-8.0.0005.ebuild349
8 files changed, 0 insertions, 2304 deletions
diff --git a/app-editors/gvim/Manifest b/app-editors/gvim/Manifest
index 8c67463e4501..e8b3c1f39e96 100644
--- a/app-editors/gvim/Manifest
+++ b/app-editors/gvim/Manifest
@@ -1,7 +1,2 @@
-DIST vim-7.4.2102-gentoo-patches.tar.bz2 2308 SHA256 1928059fe173b3abf66a96a8205c2e46b5320639d62385aeeae760e99820da67 SHA512 4e678b214fc7b1be89728b8151335ca8af332e8b0c0e25c27287a38ad5ccf14d5dcf82d5dd86af9aa502df4fae986aba98104f150b49a880e34f8283e8e63574 WHIRLPOOL 8a53a8980418f16f8c7883409dea49cfc758fc29dcfaab36f1bd6ae53b32211870a95361c8b63cdfe50795ea11958b113c9909ed6d29de5cb3696efc6ff7888b
-DIST vim-7.4.2102.tar.gz 12838026 SHA256 19c059b2d0e61effcd288e2a18969017cbbc031cf19fe775b3f4b4c42bda2578 SHA512 9cf80b1c9e2dd8713b9ba33c39917a8771c7378ae59c2dc1809bf0cabc4545547ad0a5b9f0b87cef2b34f6d1f72b135d1217495716fc482a70a16e1097bd88a2 WHIRLPOOL 301d41e9bf9a6a220776d6e32ab2918c6a8aaf33862725fba9c738e0c99921e631d8c2fdfd9bc2dc9a214a9124ecfa113081a86addf79b023e8421471843f869
-DIST vim-7.4.542-gentoo-patches.tar.bz2 3307 SHA256 0eb635f13e199de77846e0d363a473882f2186f138158271fabf0975747a2f3d SHA512 446c66764dac2533cc2f2b3d50481971d4c63a4e81d94c545862a1be620179fdcd81a79f2d81737d1188812a6ad41d90e2a752a05acf6913e7a71464f7cecdd9 WHIRLPOOL cfca8feef0eb8096897ef751afb0427acddd008530ded6cf908fcff51be9713da4ea3e5e613d544c5caba400d664ae19ca70925df3a218bec5c8be6f69aadda2
-DIST vim-7.4.769.tar.gz 12189043 SHA256 c89568f3dfcefd773bfbb0958c1cf58a0b0ceedb9d0c264250b379a77ad02e9e SHA512 00048c1d579c409767308c991e5de4ed54e9e50db7e97b0d148f0667742d5e46047c702bee693a5caf13a1603548ab783f7fa846574841d807ffbaa97d7f611e WHIRLPOOL 28ada4763250bbed6f9a1768e81a79b75db64f0ef25296c5d4825f21d21d6e88ff24d488e841e6ba492e363da6d3a3e75e9ec2f2881a731e7ed261c7d21ffd3c
-DIST vim-8.0.0005.tar.gz 12909267 SHA256 4ad6b4e8fad6412724a665d974e1be3138a9562a5f4f4aab17debf709c1d3ad3 SHA512 3d62557c6929e554c50f8043658665b907b235f180d8917288fc1434237856df7fa098ecb1823e6edea9e5735564cb55869e535350e52fd8c22423480a49438d WHIRLPOOL a80eec04afb2a797837874ec4b035268a20be7cefa487e44e8e441fb518d46cd7e16a263a6256f49e23e60e737b14dc6a7d93d7c3e579d3da13ccee48536b41b
DIST vim-8.0.0106-gentoo-patches.tar.bz2 2281 SHA256 9823a91b050eb4b001cc50f508d2ad03c7c256ed49183c1af7582318667f48d4 SHA512 39edd9f518c230d2b0486b18aa155572a9eada4a5e21108573d6e66e2eef1276f23b77d766648f018c9cf973a7d03712d8861be6ea13255d7b389912d554a47a WHIRLPOOL d6d01e3944d56762a2a999ee631f89e212360aa030ddd16ea96e32d518ec171e04d8565dcb89e804248d53e4c6e06b19be239ad2316ea88bb57364815b85d26b
DIST vim-8.0.0106.tar.gz 12945768 SHA256 cbace3e7a2db3df73720c4181fa4cdbf7df94310522b1c7a4fd7d6afeaa1e145 SHA512 4e40d9ba8ba694d951be78c653d8fcfebe2b3cc460986ef8e3478f81f2dfd5e4b3c2bc5d22082536b9c275e41beeac343cee0aa1e4de125b71fe95c772e26c20 WHIRLPOOL 569a8f50ebdb7f380f675ed0a4b4aa5e7e226303a8e92db2a8e81f5d8acc0e466620c60c160e2204f3af615b91ca2481eb9716f9c2e6dbdb416050d758a49f09
diff --git a/app-editors/gvim/gvim-7.4.2102.ebuild b/app-editors/gvim/gvim-7.4.2102.ebuild
deleted file mode 100644
index 3b11e6a147f2..000000000000
--- a/app-editors/gvim/gvim-7.4.2102.ebuild
+++ /dev/null
@@ -1,390 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE=threads
-inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vim/vim.git"
- EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
-else
- SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.2102-gentoo-patches.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-fi
-
-DESCRIPTION="GUI version of the Vim text editor"
-HOMEPAGE="http://www.vim.org/ https://github.com/vim/vim"
-
-SLOT="0"
-LICENSE="vim"
-IUSE="acl aqua cscope debug gnome gtk lua luajit motif neXt netbeans nls perl python racket ruby selinux session tcl"
-REQUIRED_USE="
- luajit? ( lua )
- python? (
- || ( $(python_gen_useflags '*') )
- ?? ( $(python_gen_useflags 'python2*') )
- ?? ( $(python_gen_useflags 'python3*') )
- )
-"
-
-RDEPEND="
- ~app-editors/vim-core-${PV}
- >=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2:0=
- x11-libs/libXext
- x11-libs/libXt
- acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- gtk? (
- >=x11-libs/gtk+-2.6:2
- x11-libs/libXft
- gnome? ( >=gnome-base/libgnomeui-2.6 )
- )
- !gtk? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? ( x11-libs/libXaw )
- )
- )
- )
- cscope? ( dev-util/cscope )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
- )
- nls? ( virtual/libintl )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.3 dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
- selinux? ( sys-libs/libselinux )
- session? ( x11-libs/libSM )
- tcl? ( dev-lang/tcl:0= )
-"
-DEPEND="${RDEPEND}
- dev-util/ctags
- sys-devel/autoconf
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-S=${WORKDIR}/vim-${PV}
-
-pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
- unset LANG LC_ALL
- export LC_COLLATE="C"
-
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
- export HOME="${T}"/home
-}
-
-src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/patches/
- fi
-
- # Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
-
- # Read vimrc and gvimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
- echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
-
- # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
- # Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
- sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
- "${S}"/runtime/doc/syntax.txt \
- "${S}"/runtime/doc/tagsrch.txt \
- "${S}"/runtime/doc/usr_29.txt \
- "${S}"/runtime/menu.vim \
- "${S}"/src/configure.in || die 'sed failed'
-
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i 's/ libc\.h / /' "${S}"/src/configure.in || die 'sed failed'
-
- # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
- # correctly. To avoid some really entertaining error messages about stuff
- # which isn't even in the source file being invalid, we'll do some trickery
- # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
-
- # Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
- sed -i '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
- fi
-
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
- fi
-
- # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
- if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
- fi
-
- default
-}
-
-src_configure() {
- local myconf=()
-
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
- filter-flags -funroll-all-loops
-
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
- # everyone since previous flag filtering bugs have turned out to affect
- # multiple archs...
- replace-flags -O3 -O2
-
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.in is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
- emake -j1 -C src autoconf
-
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
- done
-
- use debug && append-flags "-DDEBUG"
-
- myconf=(
- --with-features=huge
- --disable-gpm
- --enable-multibyte
- $(use_enable acl)
- $(use_enable cscope)
- $(use_enable lua luainterp)
- $(use_with luajit)
- $(use_enable netbeans)
- $(use_enable nls)
- $(use_enable perl perlinterp)
- $(use_enable racket mzschemeinterp)
- $(use_enable ruby rubyinterp)
- $(use_enable selinux)
- $(use_enable session xsmp)
- $(use_enable tcl tclinterp)
- )
-
- if use python ; then
- py_add_interp() {
- local v
-
- [[ ${EPYTHON} == python3* ]] && v=3
- myconf+=(
- --enable-python${v}interp
- vi_cv_path_python${v}="${PYTHON}"
- )
- }
-
- python_foreach_impl py_add_interp
- else
- myconf+=(
- --disable-pythoninterp
- --disable-python3interp
- )
- fi
-
- # --with-features=huge forces on cscope even if we --disable it. We need
- # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
- if ! use cscope ; then
- sed -i '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
-
- # gvim's GUI preference order is as follows:
- # aqua CARBON (not tested)
- # -aqua gtk gnome GNOME2
- # -aqua gtk -gnome GTK2
- # -aqua -gtk motif MOTIF
- # -aqua -gtk -motif neXt NEXTAW
- # -aqua -gtk -motif -neXt ATHENA
- echo ; echo
- if use aqua ; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use gtk ; then
- myconf+=( --enable-gtk2-check )
- if use gnome ; then
- einfo "Building gvim with the Gnome 2 GUI"
- myconf+=( --enable-gui=gnome2 )
- else
- einfo "Building gvim with the gtk+-2 GUI"
- myconf+=( --enable-gui=gtk2 )
- fi
- elif use motif ; then
- einfo "Building gvim with the MOTIF GUI"
- myconf+=( --enable-gui=motif )
- elif use neXt ; then
- einfo "Building gvim with the neXtaw GUI"
- myconf+=( --enable-gui=nextaw )
- else
- einfo "Building gvim with the Athena GUI"
- myconf+=( --enable-gui=athena )
- fi
- echo ; echo
-
- # Let Portage do the stripping. Some people like that.
- export ac_cv_prog_STRIP="$(type -P true ) faking strip"
-
- # Keep Gentoo Prefix env contained within the EPREFIX
- use prefix && myconf+=( --without-local-dir )
-
- if [[ ${CHOST} == *-interix* ]]; then
- # avoid finding of this function, to avoid having to patch either
- # configure or the source, which would be much more hackish.
- # after all vim does it right, only interix is badly broken (again)
- export ac_cv_func_sigaction=no
- fi
-
- econf \
- --with-modified-by=Gentoo-${PVR} \
- --with-vim-name=gvim \
- --with-x \
- "${myconf[@]}"
-}
-
-src_compile() {
- # The following allows emake to be used
- emake -j1 -C src auto/osdef.h objects
-
- emake
-}
-
-src_test() {
- echo
- einfo "Starting vim tests. Several error messages will be shown"
- einfo "while the tests run. This is normal behaviour and does not"
- einfo "indicate a fault."
- echo
- ewarn "If the tests fail, your terminal may be left in a strange"
- ewarn "state. Usually, running 'reset' will fix this."
- echo
-
- # Don't let vim talk to X
- unset DISPLAY
-
- # Make gvim not try to connect to X. See :help gui-x11-start in vim for how
- # this evil trickery works.
- ln -s "${S}"/src/gvim "${S}"/src/testvim || die
-
- # Make sure our VIMPROG is used.
- sed -i 's:\.\./vim:../testvim:' src/testdir/test49.vim || die
-
- # Don't do additional GUI tests.
- emake -j1 VIMPROG=../testvim -C src/testdir nongui
-}
-
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
- einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
- eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm -f "${EROOT}"/usr/bin/${f}
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
-}
-
-src_install() {
- local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
-
- dobin src/gvim
- dosym gvim /usr/bin/gvimdiff
- dosym gvim /usr/bin/evim
- dosym gvim /usr/bin/eview
- dosym gvim /usr/bin/gview
- dosym gvim /usr/bin/rgvim
- dosym gvim /usr/bin/rgview
-
- dodir /usr/share/man/man1
- echo ".so vim.1" > "${ED}"/usr/share/man/man1/gvim.1
- echo ".so vim.1" > "${ED}"/usr/share/man/man1/gview.1
- echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/gvimdiff.1
-
- insinto /etc/vim
- newins "${FILESDIR}"/gvimrc-r1 gvimrc
- eprefixify "${ED}"/etc/vim/gvimrc
-
- newmenu "${FILESDIR}"/gvim.desktop-r2 gvim.desktop
- doicon "${FILESDIR}"/gvim.xpm
- doicon -s scalable "${FILESDIR}"/gvim.svg
-
- # bash completion script, bug #79018.
- newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
-
- # We shouldn't be installing the ex or view man page symlinks, as they
- # are managed by eselect-vi
- rm -f "${ED}"/usr/share/man/man1/{ex,view}.1
-}
-
-pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Update fdo mime stuff, bug #78394
- fdo-mime_mime_database_update
-
- # Make convenience symlinks
- update_vim_symlinks
-}
-
-pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Update fdo mime stuff, bug #78394
- fdo-mime_mime_database_update
-
- # Make convenience symlinks
- update_vim_symlinks
-}
diff --git a/app-editors/gvim/gvim-7.4.769.ebuild b/app-editors/gvim/gvim-7.4.769.ebuild
deleted file mode 100644
index 9cd936cef76d..000000000000
--- a/app-editors/gvim/gvim-7.4.769.ebuild
+++ /dev/null
@@ -1,414 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE=threads
-inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vim/vim.git"
- EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
-else
- SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.542-gentoo-patches.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-fi
-
-DESCRIPTION="GUI version of the Vim text editor"
-HOMEPAGE="http://www.vim.org/"
-
-SLOT="0"
-LICENSE="vim"
-IUSE="acl aqua cscope debug gnome gtk lua luajit motif neXt netbeans nls perl python racket ruby selinux session tcl"
-REQUIRED_USE="
- luajit? ( lua )
- python? (
- || ( $(python_gen_useflags '*') )
- ?? ( $(python_gen_useflags 'python2*') )
- ?? ( $(python_gen_useflags 'python3*') )
- )
-"
-
-RDEPEND="
- ~app-editors/vim-core-${PV}
- >=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2
- x11-libs/libXext
- x11-libs/libXt
- acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- gtk? (
- >=x11-libs/gtk+-2.6:2
- x11-libs/libXft
- gnome? ( >=gnome-base/libgnomeui-2.6 )
- )
- !gtk? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? ( x11-libs/libXaw )
- )
- )
- )
- cscope? ( dev-util/cscope )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
- )
- nls? ( virtual/libintl )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
- selinux? ( sys-libs/libselinux )
- session? ( x11-libs/libSM )
- tcl? ( dev-lang/tcl:0= )
-"
-DEPEND="${RDEPEND}
- dev-util/ctags
- sys-devel/autoconf
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-S=${WORKDIR}/vim-${PV}
-
-pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
- unset LANG LC_ALL
- export LC_COLLATE="C"
-
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
- export HOME="${T}"/home
-}
-
-src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- if [[ -d "${WORKDIR}"/patches/ ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches/
- fi
- fi
-
- # Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
-
- # Read vimrc and gvimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
- echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
-
- # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
- # Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
- sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
- "${S}"/runtime/doc/syntax.txt \
- "${S}"/runtime/doc/tagsrch.txt \
- "${S}"/runtime/doc/usr_29.txt \
- "${S}"/runtime/menu.vim \
- "${S}"/src/configure.in || die 'sed failed'
-
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i 's/ libc\.h / /' "${S}"/src/configure.in || die 'sed failed'
-
- # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
- # correctly. To avoid some really entertaining error messages about stuff
- # which isn't even in the source file being invalid, we'll do some trickery
- # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
-
- # Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
- sed -i '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
- fi
-
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
- fi
-
- # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
- if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
- fi
-
- epatch_user
-}
-
-src_configure() {
- local myconf=()
-
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
- filter-flags -funroll-all-loops
-
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
- # everyone since previous flag filtering bugs have turned out to affect
- # multiple archs...
- replace-flags -O3 -O2
-
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.in is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
- emake -j1 -C src autoconf
-
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
- done
-
- use debug && append-flags "-DDEBUG"
-
- myconf=(
- --with-features=huge
- --disable-gpm
- --enable-multibyte
- $(use_enable acl)
- $(use_enable cscope)
- $(use_enable lua luainterp)
- $(use_with luajit)
- $(use_enable netbeans)
- $(use_enable nls)
- $(use_enable perl perlinterp)
- $(use_enable racket mzschemeinterp)
- $(use_enable ruby rubyinterp)
- $(use_enable selinux)
- $(use_enable session xsmp)
- $(use_enable tcl tclinterp)
- )
-
- if use python ; then
- py_add_interp() {
- local v
-
- [[ ${EPYTHON} == python3* ]] && v=3
- myconf+=(
- --enable-python${v}interp
- vi_cv_path_python${v}="${PYTHON}"
- )
- }
-
- python_foreach_impl py_add_interp
- else
- myconf+=(
- --disable-pythoninterp
- --disable-python3interp
- )
- fi
-
- # --with-features=huge forces on cscope even if we --disable it. We need
- # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
- if ! use cscope ; then
- sed -i '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
-
- # gvim's GUI preference order is as follows:
- # aqua CARBON (not tested)
- # -aqua gtk gnome GNOME2
- # -aqua gtk -gnome GTK2
- # -aqua -gtk motif MOTIF
- # -aqua -gtk -motif neXt NEXTAW
- # -aqua -gtk -motif -neXt ATHENA
- echo ; echo
- if use aqua ; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use gtk ; then
- myconf+=( --enable-gtk2-check )
- if use gnome ; then
- einfo "Building gvim with the Gnome 2 GUI"
- myconf+=( --enable-gui=gnome2 )
- else
- einfo "Building gvim with the gtk+-2 GUI"
- myconf+=( --enable-gui=gtk2 )
- fi
- elif use motif ; then
- einfo "Building gvim with the MOTIF GUI"
- myconf+=( --enable-gui=motif )
- elif use neXt ; then
- einfo "Building gvim with the neXtaw GUI"
- myconf+=( --enable-gui=nextaw )
- else
- einfo "Building gvim with the Athena GUI"
- myconf+=( --enable-gui=athena )
- fi
- echo ; echo
-
- # Let Portage do the stripping. Some people like that.
- export ac_cv_prog_STRIP="$(type -P true ) faking strip"
-
- # Keep Gentoo Prefix env contained within the EPREFIX
- use prefix && myconf+=( --without-local-dir )
-
- if [[ ${CHOST} == *-interix* ]]; then
- # avoid finding of this function, to avoid having to patch either
- # configure or the source, which would be much more hackish.
- # after all vim does it right, only interix is badly broken (again)
- export ac_cv_func_sigaction=no
- fi
-
- econf \
- --with-modified-by=Gentoo-${PVR} \
- --with-vim-name=gvim \
- --with-x \
- "${myconf[@]}"
-}
-
-src_compile() {
- # The following allows emake to be used
- emake -j1 -C src auto/osdef.h objects
-
- emake
-}
-
-src_test() {
- echo
- einfo "Starting vim tests. Several error messages will be shown"
- einfo "while the tests run. This is normal behaviour and does not"
- einfo "indicate a fault."
- echo
- ewarn "If the tests fail, your terminal may be left in a strange"
- ewarn "state. Usually, running 'reset' will fix this."
- echo
-
- # Don't let vim talk to X
- unset DISPLAY
-
- # We've got to call make test from within testdir, since the Makefiles
- # don't pass through our VIMPROG argument
- cd "${S}"/src/testdir
-
- # Test 49 won't work inside a portage environment
- einfo "Test 49 isn't sandbox-friendly, so it will be skipped."
- sed -i 's~test49.out~~g' Makefile
-
- # We don't want to rebuild vim before running the tests
- sed -i 's,: \$(VIMPROG),: ,' Makefile
-
- # Make gvim not try to connect to X. See :help gui-x11-start
- # in vim for how this evil trickery works.
- ln -s "${S}"/src/gvim "${S}"/src/testvim
-
- # Don't try to do the additional GUI test
- emake -j1 VIMPROG=../testvim nongui
-}
-
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
- einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
- eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm -f "${EROOT}"/usr/bin/${f}
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
-}
-
-src_install() {
- local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
-
- dobin src/gvim
- dosym gvim /usr/bin/gvimdiff
- dosym gvim /usr/bin/evim
- dosym gvim /usr/bin/eview
- dosym gvim /usr/bin/gview
- dosym gvim /usr/bin/rgvim
- dosym gvim /usr/bin/rgview
-
- dodir /usr/share/man/man1
- echo ".so vim.1" > "${ED}"/usr/share/man/man1/gvim.1
- echo ".so vim.1" > "${ED}"/usr/share/man/man1/gview.1
- echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/gvimdiff.1
-
- insinto /etc/vim
- newins "${FILESDIR}"/gvimrc-r1 gvimrc
- eprefixify "${ED}"/etc/vim/gvimrc
-
- newmenu "${FILESDIR}"/gvim.desktop-r2 gvim.desktop
- doicon "${FILESDIR}"/gvim.xpm
- doicon -s scalable "${FILESDIR}"/gvim.svg
-
- # bash completion script, bug #79018.
- newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
-
- # We shouldn't be installing the ex or view man page symlinks, as they
- # are managed by eselect-vi
- rm -f "${ED}"/usr/share/man/man1/{ex,view}.1
-}
-
-pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Update fdo mime stuff, bug #78394
- fdo-mime_mime_database_update
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- echo
- elog "Vim 7 includes an integrated spell checker. You need to install"
- elog "word list files before you can use it. There are ebuilds for"
- elog "some of these named app-vim/vim-spell-*. If your language of"
- elog "choice is not included, please consult vim-spell.eclass for"
- elog "instructions on how to make a package."
- echo
- ewarn "Note that the English word lists are no longer installed by"
- ewarn "default."
- echo
- fi
-
- # Make convenience symlinks
- update_vim_symlinks
-}
-
-pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Update fdo mime stuff, bug #78394
- fdo-mime_mime_database_update
-
- # Make convenience symlinks
- update_vim_symlinks
-}
diff --git a/app-editors/gvim/gvim-8.0.0005.ebuild b/app-editors/gvim/gvim-8.0.0005.ebuild
deleted file mode 100644
index 8dd474d3fde8..000000000000
--- a/app-editors/gvim/gvim-8.0.0005.ebuild
+++ /dev/null
@@ -1,408 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-VIM_VERSION="8.0"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE=threads
-inherit eutils vim-doc flag-o-matic fdo-mime gnome2-utils versionator bash-completion-r1 prefix python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vim/vim.git"
- EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
-else
- SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.2102-gentoo-patches.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-fi
-
-DESCRIPTION="GUI version of the Vim text editor"
-HOMEPAGE="http://www.vim.org/ https://github.com/vim/vim"
-
-SLOT="0"
-LICENSE="vim"
-IUSE="acl aqua cscope debug gnome gtk gtk3 lua luajit motif neXt netbeans nls perl python racket ruby selinux session tcl"
-REQUIRED_USE="
- luajit? ( lua )
- python? (
- || ( $(python_gen_useflags '*') )
- ?? ( $(python_gen_useflags 'python2*') )
- ?? ( $(python_gen_useflags 'python3*') )
- )
-"
-
-RDEPEND="
- ~app-editors/vim-core-${PV}
- >=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2:0=
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXext
- x11-libs/libXt
- acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- gtk3? (
- x11-libs/gtk+:3
- x11-libs/libXft
- )
- !gtk3? (
- gtk? (
- >=x11-libs/gtk+-2.6:2
- x11-libs/libXft
- gnome? ( >=gnome-base/libgnomeui-2.6 )
- )
- !gtk? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? ( x11-libs/libXaw )
- )
- )
- )
- )
- cscope? ( dev-util/cscope )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
- )
- nls? ( virtual/libintl )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.3 dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
- selinux? ( sys-libs/libselinux )
- session? ( x11-libs/libSM )
- tcl? ( dev-lang/tcl:0= )
-"
-DEPEND="${RDEPEND}
- dev-util/ctags
- sys-devel/autoconf
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-S=${WORKDIR}/vim-${PV}
-
-pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
- unset LANG LC_ALL
- export LC_COLLATE="C"
-
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
- export HOME="${T}"/home
-}
-
-src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/patches/
- fi
-
- # Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
-
- # Read vimrc and gvimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
- echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
-
- # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
- # Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
- sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
- "${S}"/runtime/doc/syntax.txt \
- "${S}"/runtime/doc/tagsrch.txt \
- "${S}"/runtime/doc/usr_29.txt \
- "${S}"/runtime/menu.vim \
- "${S}"/src/configure.in || die 'sed failed'
-
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i 's/ libc\.h / /' "${S}"/src/configure.in || die 'sed failed'
-
- # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
- # correctly. To avoid some really entertaining error messages about stuff
- # which isn't even in the source file being invalid, we'll do some trickery
- # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
-
- # Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
- sed -i '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
- fi
-
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
- fi
-
- # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
- if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
- fi
-
- eapply_user
-}
-
-src_configure() {
- local myconf=()
-
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
- filter-flags -funroll-all-loops
-
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
- # everyone since previous flag filtering bugs have turned out to affect
- # multiple archs...
- replace-flags -O3 -O2
-
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.in is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
- emake -j1 -C src autoconf
-
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
- done
-
- use debug && append-flags "-DDEBUG"
-
- myconf=(
- --with-features=huge
- --disable-gpm
- --enable-multibyte
- $(use_enable acl)
- $(use_enable cscope)
- $(use_enable lua luainterp)
- $(use_with luajit)
- $(use_enable netbeans)
- $(use_enable nls)
- $(use_enable perl perlinterp)
- $(use_enable racket mzschemeinterp)
- $(use_enable ruby rubyinterp)
- $(use_enable selinux)
- $(use_enable session xsmp)
- $(use_enable tcl tclinterp)
- )
-
- if use python ; then
- py_add_interp() {
- local v
-
- [[ ${EPYTHON} == python3* ]] && v=3
- myconf+=(
- --enable-python${v}interp
- vi_cv_path_python${v}="${PYTHON}"
- )
- }
-
- python_foreach_impl py_add_interp
- else
- myconf+=(
- --disable-pythoninterp
- --disable-python3interp
- )
- fi
-
- # --with-features=huge forces on cscope even if we --disable it. We need
- # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
- if ! use cscope ; then
- sed -i '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
-
- # gvim's GUI preference order is as follows:
- # aqua CARBON (not tested)
- # -aqua gtk3 GTK3
- # -aqua -gtk3 gnome GNOME2
- # -aqua -gtk3 -gnome gtk GTK2
- # -aqua -gtk -gtk3 motif MOTIF
- # -aqua -gtk -gtk3 -motif neXt NEXTAW
- # -aqua -gtk -gtk3 -motif -neXt ATHENA
- echo ; echo
- if use aqua ; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use gtk3 ; then
- myconf+=( --enable-gtk3-check )
- einfo "Building gvim with the gtk+-3 GUI"
- myconf+=( --enable-gui=gtk3 )
- elif use gtk ; then
- myconf+=( --enable-gtk2-check )
- if use gnome ; then
- einfo "Building gvim with the Gnome 2 GUI"
- myconf+=( --enable-gui=gnome2 )
- else
- einfo "Building gvim with the gtk+-2 GUI"
- myconf+=( --enable-gui=gtk2 )
- fi
- elif use motif ; then
- einfo "Building gvim with the MOTIF GUI"
- myconf+=( --enable-gui=motif )
- elif use neXt ; then
- einfo "Building gvim with the neXtaw GUI"
- myconf+=( --enable-gui=nextaw )
- else
- einfo "Building gvim with the Athena GUI"
- myconf+=( --enable-gui=athena )
- fi
- echo ; echo
-
- # let package manager strip binaries
- export ac_cv_prog_STRIP="$(type -P true ) faking strip"
-
- # keep prefix env contained within the EPREFIX
- use prefix && myconf+=( --without-local-dir )
-
- if [[ ${CHOST} == *-interix* ]]; then
- # avoid finding of this function, to avoid having to patch either
- # configure or the source, which would be much more hackish.
- # after all vim does it right, only interix is badly broken (again)
- export ac_cv_func_sigaction=no
- fi
-
- econf \
- --with-modified-by=Gentoo-${PVR} \
- --with-vim-name=gvim \
- --with-x \
- "${myconf[@]}"
-}
-
-src_compile() {
- # The following allows emake to be used
- emake -j1 -C src auto/osdef.h objects
-
- emake
-}
-
-src_test() {
- echo
- einfo "Starting vim tests. Several error messages will be shown"
- einfo "while the tests run. This is normal behaviour and does not"
- einfo "indicate a fault."
- echo
- ewarn "If the tests fail, your terminal may be left in a strange"
- ewarn "state. Usually, running 'reset' will fix this."
- echo
-
- # Don't let vim talk to X
- unset DISPLAY
-
- # Make gvim not try to connect to X. See :help gui-x11-start in vim for how
- # this evil trickery works.
- ln -s "${S}"/src/gvim "${S}"/src/testvim || die
-
- # Make sure our VIMPROG is used.
- sed -i 's:\.\./vim:../testvim:' src/testdir/test49.vim || die
-
- # Don't do additional GUI tests.
- emake -j1 VIMPROG=../testvim -C src/testdir nongui
-}
-
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
- einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
- eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm -f "${EROOT}"/usr/bin/${f}
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
-}
-
-src_install() {
- local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
-
- dobin src/gvim
- dosym gvim /usr/bin/gvimdiff
- dosym gvim /usr/bin/evim
- dosym gvim /usr/bin/eview
- dosym gvim /usr/bin/gview
- dosym gvim /usr/bin/rgvim
- dosym gvim /usr/bin/rgview
-
- emake -C src DESTDIR="${D}" DATADIR="${EPREFIX}"/usr/share install-icons
-
- dodir /usr/share/man/man1
- echo ".so vim.1" > "${ED}"/usr/share/man/man1/gvim.1
- echo ".so vim.1" > "${ED}"/usr/share/man/man1/gview.1
- echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/gvimdiff.1
-
- insinto /etc/vim
- newins "${FILESDIR}"/gvimrc-r1 gvimrc
- eprefixify "${ED}"/etc/vim/gvimrc
-
- doicon -s scalable "${FILESDIR}"/gvim.svg
-
- # bash completion script, bug #79018.
- newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
-
- # don't install vim desktop file
- rm "${ED}"/usr/share/applications/vim.desktop || die "failed to remove vim.desktop"
-}
-
-pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Update fdo mime stuff, bug #78394
- fdo-mime_desktop_database_update
-
- # Update icon cache
- gnome2_icon_cache_update
-
- # Make convenience symlinks
- update_vim_symlinks
-}
-
-pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Update fdo mime stuff, bug #78394
- fdo-mime_desktop_database_update
-
- # Update icon cache
- gnome2_icon_cache_update
-
- # Make convenience symlinks
- update_vim_symlinks
-}
diff --git a/app-editors/vim/Manifest b/app-editors/vim/Manifest
index 8c67463e4501..e8b3c1f39e96 100644
--- a/app-editors/vim/Manifest
+++ b/app-editors/vim/Manifest
@@ -1,7 +1,2 @@
-DIST vim-7.4.2102-gentoo-patches.tar.bz2 2308 SHA256 1928059fe173b3abf66a96a8205c2e46b5320639d62385aeeae760e99820da67 SHA512 4e678b214fc7b1be89728b8151335ca8af332e8b0c0e25c27287a38ad5ccf14d5dcf82d5dd86af9aa502df4fae986aba98104f150b49a880e34f8283e8e63574 WHIRLPOOL 8a53a8980418f16f8c7883409dea49cfc758fc29dcfaab36f1bd6ae53b32211870a95361c8b63cdfe50795ea11958b113c9909ed6d29de5cb3696efc6ff7888b
-DIST vim-7.4.2102.tar.gz 12838026 SHA256 19c059b2d0e61effcd288e2a18969017cbbc031cf19fe775b3f4b4c42bda2578 SHA512 9cf80b1c9e2dd8713b9ba33c39917a8771c7378ae59c2dc1809bf0cabc4545547ad0a5b9f0b87cef2b34f6d1f72b135d1217495716fc482a70a16e1097bd88a2 WHIRLPOOL 301d41e9bf9a6a220776d6e32ab2918c6a8aaf33862725fba9c738e0c99921e631d8c2fdfd9bc2dc9a214a9124ecfa113081a86addf79b023e8421471843f869
-DIST vim-7.4.542-gentoo-patches.tar.bz2 3307 SHA256 0eb635f13e199de77846e0d363a473882f2186f138158271fabf0975747a2f3d SHA512 446c66764dac2533cc2f2b3d50481971d4c63a4e81d94c545862a1be620179fdcd81a79f2d81737d1188812a6ad41d90e2a752a05acf6913e7a71464f7cecdd9 WHIRLPOOL cfca8feef0eb8096897ef751afb0427acddd008530ded6cf908fcff51be9713da4ea3e5e613d544c5caba400d664ae19ca70925df3a218bec5c8be6f69aadda2
-DIST vim-7.4.769.tar.gz 12189043 SHA256 c89568f3dfcefd773bfbb0958c1cf58a0b0ceedb9d0c264250b379a77ad02e9e SHA512 00048c1d579c409767308c991e5de4ed54e9e50db7e97b0d148f0667742d5e46047c702bee693a5caf13a1603548ab783f7fa846574841d807ffbaa97d7f611e WHIRLPOOL 28ada4763250bbed6f9a1768e81a79b75db64f0ef25296c5d4825f21d21d6e88ff24d488e841e6ba492e363da6d3a3e75e9ec2f2881a731e7ed261c7d21ffd3c
-DIST vim-8.0.0005.tar.gz 12909267 SHA256 4ad6b4e8fad6412724a665d974e1be3138a9562a5f4f4aab17debf709c1d3ad3 SHA512 3d62557c6929e554c50f8043658665b907b235f180d8917288fc1434237856df7fa098ecb1823e6edea9e5735564cb55869e535350e52fd8c22423480a49438d WHIRLPOOL a80eec04afb2a797837874ec4b035268a20be7cefa487e44e8e441fb518d46cd7e16a263a6256f49e23e60e737b14dc6a7d93d7c3e579d3da13ccee48536b41b
DIST vim-8.0.0106-gentoo-patches.tar.bz2 2281 SHA256 9823a91b050eb4b001cc50f508d2ad03c7c256ed49183c1af7582318667f48d4 SHA512 39edd9f518c230d2b0486b18aa155572a9eada4a5e21108573d6e66e2eef1276f23b77d766648f018c9cf973a7d03712d8861be6ea13255d7b389912d554a47a WHIRLPOOL d6d01e3944d56762a2a999ee631f89e212360aa030ddd16ea96e32d518ec171e04d8565dcb89e804248d53e4c6e06b19be239ad2316ea88bb57364815b85d26b
DIST vim-8.0.0106.tar.gz 12945768 SHA256 cbace3e7a2db3df73720c4181fa4cdbf7df94310522b1c7a4fd7d6afeaa1e145 SHA512 4e40d9ba8ba694d951be78c653d8fcfebe2b3cc460986ef8e3478f81f2dfd5e4b3c2bc5d22082536b9c275e41beeac343cee0aa1e4de125b71fe95c772e26c20 WHIRLPOOL 569a8f50ebdb7f380f675ed0a4b4aa5e7e226303a8e92db2a8e81f5d8acc0e466620c60c160e2204f3af615b91ca2481eb9716f9c2e6dbdb416050d758a49f09
diff --git a/app-editors/vim/vim-7.4.2102.ebuild b/app-editors/vim/vim-7.4.2102.ebuild
deleted file mode 100644
index 3defc6f4bc62..000000000000
--- a/app-editors/vim/vim-7.4.2102.ebuild
+++ /dev/null
@@ -1,349 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE=threads
-inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vim/vim.git"
-else
- SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.2102-gentoo-patches.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Vim, an improved vi-style text editor"
-HOMEPAGE="http://www.vim.org/ https://github.com/vim/vim"
-
-SLOT="0"
-LICENSE="vim"
-IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux tcl vim-pager"
-REQUIRED_USE="
- luajit? ( lua )
- python? (
- || ( $(python_gen_useflags '*') )
- ?? ( $(python_gen_useflags 'python2*') )
- ?? ( $(python_gen_useflags 'python3*') )
- )
-"
-
-RDEPEND="
- >=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2:0=
- nls? ( virtual/libintl )
- acl? ( kernel_linux? ( sys-apps/acl ) )
- cscope? ( dev-util/cscope )
- gpm? ( >=sys-libs/gpm-1.19.3 )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
- )
- !minimal? (
- ~app-editors/vim-core-${PV}
- dev-util/ctags
- )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.3 dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
- selinux? ( sys-libs/libselinux )
- tcl? ( dev-lang/tcl:0= )
- X? ( x11-libs/libXt )
-"
-DEPEND="${RDEPEND}
- sys-devel/autoconf
- nls? ( sys-devel/gettext )
-"
-
-pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
- unset LANG LC_ALL
- export LC_COLLATE="C"
-
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
- export HOME="${T}"/home
-}
-
-src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/patches/
- fi
-
- # Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
-
- # Read vimrc and gvimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
- echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
-
- # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
- # Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
- sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
- "${S}"/runtime/doc/syntax.txt \
- "${S}"/runtime/doc/tagsrch.txt \
- "${S}"/runtime/doc/usr_29.txt \
- "${S}"/runtime/menu.vim \
- "${S}"/src/configure.in || die 'sed failed'
-
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i 's/ libc\.h / /' "${S}"/src/configure.in || die 'sed failed'
-
- # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
- # correctly. To avoid some really entertaining error messages about stuff
- # which isn't even in the source file being invalid, we'll do some trickery
- # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
-
- # conditionally make the manpager.sh script
- if use vim-pager ; then
- cat <<-END > "${S}"/runtime/macros/manpager.sh
- #!/bin/sh
- sed -e 's/\x1B\[[[:digit:]]\+m//g' | col -b | \\
- vim \\
- -c 'let no_plugin_maps = 1' \\
- -c 'set nolist nomod ft=man ts=8' \\
- -c 'let g:showmarks_enable=0' \\
- -c 'runtime! macros/less.vim' -
- END
- fi
-
- # Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
- sed -i '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
- fi
-
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
- fi
-
- # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
- if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
- fi
-
- default
-}
-
-src_configure() {
- local myconf=()
-
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
- filter-flags -funroll-all-loops
-
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
- # everyone since previous flag filtering bugs have turned out to affect
- # multiple archs...
- replace-flags -O3 -O2
-
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.in is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
- emake -j1 -C src autoconf
-
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
- done
-
- if use minimal ; then
- myconf=(
- --with-features=tiny
- --disable-nls
- --disable-multibyte
- --disable-acl
- --enable-gui=no
- --without-x
- --disable-darwin
- --disable-luainterp
- --disable-perlinterp
- --disable-pythoninterp
- --disable-mzschemeinterp
- --disable-rubyinterp
- --disable-selinux
- --disable-tclinterp
- --disable-gpm
- )
- else
- use debug && append-flags "-DDEBUG"
-
- myconf=(
- --with-features=huge
- --enable-multibyte
- $(use_enable acl)
- $(use_enable cscope)
- $(use_enable gpm)
- $(use_enable lua luainterp)
- $(usex lua "--with-lua-prefix=${EPREFIX}/usr" "")
- $(use_with luajit)
- $(use_enable nls)
- $(use_enable perl perlinterp)
- $(use_enable racket mzschemeinterp)
- $(use_enable ruby rubyinterp)
- $(use_enable selinux)
- $(use_enable tcl tclinterp)
- )
-
- if use python ; then
- py_add_interp() {
- local v
-
- [[ ${EPYTHON} == python3* ]] && v=3
- myconf+=(
- --enable-python${v}interp
- vi_cv_path_python${v}="${PYTHON}"
- )
- }
-
- python_foreach_impl py_add_interp
- else
- myconf+=(
- --disable-pythoninterp
- --disable-python3interp
- )
- fi
-
- # --with-features=huge forces on cscope even if we --disable it. We need
- # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
- if ! use cscope ; then
- sed -i '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
-
- # don't test USE=X here ... see bug #19115
- # but need to provide a way to link against X ... see bug #20093
- myconf+=(
- --enable-gui=no
- --disable-darwin
- $(use_with X x)
- )
- fi
-
- # Let Portage do the stripping. Some people like that.
- export ac_cv_prog_STRIP="$(type -P true ) faking strip"
-
- # Keep Gentoo Prefix env contained within the EPREFIX
- use prefix && myconf+=( --without-local-dir )
-
- econf \
- --with-modified-by=Gentoo-${PVR} \
- "${myconf[@]}"
-}
-
-src_compile() {
- # The following allows emake to be used
- emake -j1 -C src auto/osdef.h objects
-
- emake
-}
-
-src_test() {
- echo
- einfo "Starting vim tests. Several error messages will be shown"
- einfo "while the tests run. This is normal behaviour and does not"
- einfo "indicate a fault."
- echo
- ewarn "If the tests fail, your terminal may be left in a strange"
- ewarn "state. Usually, running 'reset' will fix this."
- echo
-
- # Don't let vim talk to X
- unset DISPLAY
-
- emake -j1 -C src/testdir nongui
-}
-
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
- einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
- eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm -f "${EROOT}"/usr/bin/${f}
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
-}
-
-src_install() {
- local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
-
- # Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
- # managed by eselect-vi
- dobin src/vim
- dosym vim /usr/bin/vimdiff
- dosym vim /usr/bin/rvim
- dosym vim /usr/bin/rview
- if use vim-pager ; then
- dosym ${vimfiles}/macros/less.sh /usr/bin/vimpager
- dosym ${vimfiles}/macros/manpager.sh /usr/bin/vimmanpager
- insinto ${vimfiles}/macros
- doins runtime/macros/manpager.sh
- fperms a+x ${vimfiles}/macros/manpager.sh
- fi
-
- newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
- # keep in sync with 'complete ... -F' list
- bashcomp_alias vim ex vi view rvim rview vimdiff
-
- # We shouldn't be installing the ex or view man page symlinks, as they
- # are managed by eselect-vi
- rm -f "${ED}"/usr/share/man/man1/{ex,view}.1
-}
-
-pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Make convenience symlinks
- update_vim_symlinks
-}
-
-pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Make convenience symlinks
- update_vim_symlinks
-}
diff --git a/app-editors/vim/vim-7.4.769.ebuild b/app-editors/vim/vim-7.4.769.ebuild
deleted file mode 100644
index 829553f78a91..000000000000
--- a/app-editors/vim/vim-7.4.769.ebuild
+++ /dev/null
@@ -1,384 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE=threads
-inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vim/vim.git"
-else
- SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.542-gentoo-patches.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Vim, an improved vi-style text editor"
-HOMEPAGE="http://www.vim.org/"
-
-SLOT="0"
-LICENSE="vim"
-IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux tcl vim-pager"
-REQUIRED_USE="
- luajit? ( lua )
- python? (
- || ( $(python_gen_useflags '*') )
- ?? ( $(python_gen_useflags 'python2*') )
- ?? ( $(python_gen_useflags 'python3*') )
- )
-"
-
-RDEPEND="
- >=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2
- nls? ( virtual/libintl )
- acl? ( kernel_linux? ( sys-apps/acl ) )
- cscope? ( dev-util/cscope )
- gpm? ( >=sys-libs/gpm-1.19.3 )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
- )
- !minimal? (
- ~app-editors/vim-core-${PV}
- dev-util/ctags
- )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
- selinux? ( sys-libs/libselinux )
- tcl? ( dev-lang/tcl:0= )
- X? ( x11-libs/libXt )
-"
-DEPEND="${RDEPEND}
- sys-devel/autoconf
- nls? ( sys-devel/gettext )
-"
-
-pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
- unset LANG LC_ALL
- export LC_COLLATE="C"
-
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
- export HOME="${T}"/home
-}
-
-src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- if [[ -d "${WORKDIR}"/patches/ ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches/
- fi
- fi
-
- # Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
-
- # Read vimrc and gvimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
- echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
-
- # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
- # Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
- sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
- "${S}"/runtime/doc/syntax.txt \
- "${S}"/runtime/doc/tagsrch.txt \
- "${S}"/runtime/doc/usr_29.txt \
- "${S}"/runtime/menu.vim \
- "${S}"/src/configure.in || die 'sed failed'
-
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i 's/ libc\.h / /' "${S}"/src/configure.in || die 'sed failed'
-
- # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
- # correctly. To avoid some really entertaining error messages about stuff
- # which isn't even in the source file being invalid, we'll do some trickery
- # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
-
- # conditionally make the manpager.sh script
- if use vim-pager ; then
- cat <<-END > "${S}"/runtime/macros/manpager.sh
- #!/bin/sh
- sed -e 's/\x1B\[[[:digit:]]\+m//g' | col -b | \\
- vim \\
- -c 'let no_plugin_maps = 1' \\
- -c 'set nolist nomod ft=man ts=8' \\
- -c 'let g:showmarks_enable=0' \\
- -c 'runtime! macros/less.vim' -
- END
- fi
-
- # Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
- sed -i '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
- fi
-
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
- fi
-
- # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
- if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
- fi
-
- epatch_user
-}
-
-src_configure() {
- local myconf=()
-
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
- filter-flags -funroll-all-loops
-
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
- # everyone since previous flag filtering bugs have turned out to affect
- # multiple archs...
- replace-flags -O3 -O2
-
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.in is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
- emake -j1 -C src autoconf
-
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
- done
-
- if use minimal ; then
- myconf=(
- --with-features=tiny
- --disable-nls
- --disable-multibyte
- --disable-acl
- --enable-gui=no
- --without-x
- --disable-darwin
- --disable-luainterp
- --disable-perlinterp
- --disable-pythoninterp
- --disable-mzschemeinterp
- --disable-rubyinterp
- --disable-selinux
- --disable-tclinterp
- --disable-gpm
- )
- else
- use debug && append-flags "-DDEBUG"
-
- myconf=(
- --with-features=huge
- --enable-multibyte
- $(use_enable acl)
- $(use_enable cscope)
- $(use_enable gpm)
- $(use_enable lua luainterp)
- $(usex lua "--with-lua-prefix=${EPREFIX}/usr" "")
- $(use_with luajit)
- $(use_enable nls)
- $(use_enable perl perlinterp)
- $(use_enable racket mzschemeinterp)
- $(use_enable ruby rubyinterp)
- $(use_enable selinux)
- $(use_enable tcl tclinterp)
- )
-
- if use python ; then
- py_add_interp() {
- local v
-
- [[ ${EPYTHON} == python3* ]] && v=3
- myconf+=(
- --enable-python${v}interp
- vi_cv_path_python${v}="${PYTHON}"
- )
- }
-
- python_foreach_impl py_add_interp
- else
- myconf+=(
- --disable-pythoninterp
- --disable-python3interp
- )
- fi
-
- # --with-features=huge forces on cscope even if we --disable it. We need
- # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
- if ! use cscope ; then
- sed -i '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
-
- # don't test USE=X here ... see bug #19115
- # but need to provide a way to link against X ... see bug #20093
- myconf+=(
- --enable-gui=no
- --disable-darwin
- $(use_with X x)
- )
- fi
-
- # Let Portage do the stripping. Some people like that.
- export ac_cv_prog_STRIP="$(type -P true ) faking strip"
-
- # Keep Gentoo Prefix env contained within the EPREFIX
- use prefix && myconf+=( --without-local-dir )
-
- econf \
- --with-modified-by=Gentoo-${PVR} \
- "${myconf[@]}"
-}
-
-src_compile() {
- # The following allows emake to be used
- emake -j1 -C src auto/osdef.h objects
-
- emake
-}
-
-src_test() {
- echo
- einfo "Starting vim tests. Several error messages will be shown"
- einfo "while the tests run. This is normal behaviour and does not"
- einfo "indicate a fault."
- echo
- ewarn "If the tests fail, your terminal may be left in a strange"
- ewarn "state. Usually, running 'reset' will fix this."
- echo
-
- # Don't let vim talk to X
- unset DISPLAY
-
- # We've got to call make test from within testdir, since the Makefiles
- # don't pass through our VIMPROG argument
- cd "${S}"/src/testdir
-
- # Test 49 won't work inside a portage environment
- einfo "Test 49 isn't sandbox-friendly, so it will be skipped."
- sed -i 's~test49.out~~g' Makefile
-
- # We don't want to rebuild vim before running the tests
- sed -i 's,: \$(VIMPROG),: ,' Makefile
-
- # Don't try to do the additional GUI test
- emake -j1 VIMPROG=../vim nongui
-}
-
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
- einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
- eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm -f "${EROOT}"/usr/bin/${f}
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
-}
-
-src_install() {
- local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
-
- # Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
- # managed by eselect-vi
- dobin src/vim
- dosym vim /usr/bin/vimdiff
- dosym vim /usr/bin/rvim
- dosym vim /usr/bin/rview
- if use vim-pager ; then
- dosym ${vimfiles}/macros/less.sh /usr/bin/vimpager
- dosym ${vimfiles}/macros/manpager.sh /usr/bin/vimmanpager
- insinto ${vimfiles}/macros
- doins runtime/macros/manpager.sh
- fperms a+x ${vimfiles}/macros/manpager.sh
- fi
-
- newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
- # keep in sync with 'complete ... -F' list
- bashcomp_alias vim ex vi view rvim rview vimdiff
-
- # We shouldn't be installing the ex or view man page symlinks, as they
- # are managed by eselect-vi
- rm -f "${ED}"/usr/share/man/man1/{ex,view}.1
-}
-
-pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use X ; then
- echo
- elog "The 'X' USE flag enables vim <-> X communication, like"
- elog "updating the xterm titlebar. It does not install a GUI."
- fi
- echo
- elog "To install a GUI version of vim, use the app-editors/gvim"
- elog "package."
- echo
- elog "Vim 7 includes an integrated spell checker. You need to install"
- elog "word list files before you can use it. There are ebuilds for"
- elog "some of these named app-vim/vim-spell-*. If your language of"
- elog "choice is not included, please consult vim-spell.eclass for"
- elog "instructions on how to make a package."
- echo
- ewarn "Note that the English word lists are no longer installed by"
- ewarn "default."
- fi
-
- # Make convenience symlinks
- update_vim_symlinks
-}
-
-pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Make convenience symlinks
- update_vim_symlinks
-}
diff --git a/app-editors/vim/vim-8.0.0005.ebuild b/app-editors/vim/vim-8.0.0005.ebuild
deleted file mode 100644
index bc0ca8d5b824..000000000000
--- a/app-editors/vim/vim-8.0.0005.ebuild
+++ /dev/null
@@ -1,349 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-VIM_VERSION="8.0"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE=threads
-inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vim/vim.git"
-else
- SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~radhermit/vim/vim-7.4.2102-gentoo-patches.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Vim, an improved vi-style text editor"
-HOMEPAGE="http://www.vim.org/ https://github.com/vim/vim"
-
-SLOT="0"
-LICENSE="vim"
-IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux tcl vim-pager"
-REQUIRED_USE="
- luajit? ( lua )
- python? (
- || ( $(python_gen_useflags '*') )
- ?? ( $(python_gen_useflags 'python2*') )
- ?? ( $(python_gen_useflags 'python3*') )
- )
-"
-
-RDEPEND="
- >=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2:0=
- nls? ( virtual/libintl )
- acl? ( kernel_linux? ( sys-apps/acl ) )
- cscope? ( dev-util/cscope )
- gpm? ( >=sys-libs/gpm-1.19.3 )
- lua? (
- luajit? ( dev-lang/luajit:2= )
- !luajit? ( dev-lang/lua:0[deprecated] )
- )
- !minimal? (
- ~app-editors/vim-core-${PV}
- dev-util/ctags
- )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- racket? ( dev-scheme/racket )
- ruby? ( || ( dev-lang/ruby:2.3 dev-lang/ruby:2.2 dev-lang/ruby:2.1 dev-lang/ruby:2.0 ) )
- selinux? ( sys-libs/libselinux )
- tcl? ( dev-lang/tcl:0= )
- X? ( x11-libs/libXt )
-"
-DEPEND="${RDEPEND}
- sys-devel/autoconf
- nls? ( sys-devel/gettext )
-"
-
-pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
- unset LANG LC_ALL
- export LC_COLLATE="C"
-
- # Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
- export HOME="${T}"/home
-}
-
-src_prepare() {
- if [[ ${PV} != 9999* ]] ; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/patches/
- fi
-
- # Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
-
- # Read vimrc and gvimrc from /etc/vim
- echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
- echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
-
- # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
- # Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
- sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
- "${S}"/runtime/doc/syntax.txt \
- "${S}"/runtime/doc/tagsrch.txt \
- "${S}"/runtime/doc/usr_29.txt \
- "${S}"/runtime/menu.vim \
- "${S}"/src/configure.in || die 'sed failed'
-
- # Don't be fooled by /usr/include/libc.h. When found, vim thinks
- # this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
- sed -i 's/ libc\.h / /' "${S}"/src/configure.in || die 'sed failed'
-
- # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
- # correctly. To avoid some really entertaining error messages about stuff
- # which isn't even in the source file being invalid, we'll do some trickery
- # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
-
- # conditionally make the manpager.sh script
- if use vim-pager ; then
- cat <<-END > "${S}"/runtime/macros/manpager.sh
- #!/bin/sh
- sed -e 's/\x1B\[[[:digit:]]\+m//g' | col -b | \\
- vim \\
- -c 'let no_plugin_maps = 1' \\
- -c 'set nolist nomod ft=man ts=8' \\
- -c 'let g:showmarks_enable=0' \\
- -c 'runtime! macros/less.vim' -
- END
- fi
-
- # Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
- sed -i '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
- fi
-
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
- fi
-
- # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
- if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
- "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
- fi
-
- eapply_user
-}
-
-src_configure() {
- local myconf=()
-
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
- # Bug 57859 suggests that we want to do this for all archs
- filter-flags -funroll-all-loops
-
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
- # everyone since previous flag filtering bugs have turned out to affect
- # multiple archs...
- replace-flags -O3 -O2
-
- # Fix bug 18245: Prevent "make" from the following chain:
- # (1) Notice configure.in is newer than auto/configure
- # (2) Rebuild auto/configure
- # (3) Notice auto/configure is newer than auto/config.mk
- # (4) Run ./configure (with wrong args) to remake auto/config.mk
- sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
- emake -j1 -C src autoconf
-
- # This should fix a sandbox violation (see bug 24447). The hvc
- # things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
- done
-
- if use minimal ; then
- myconf=(
- --with-features=tiny
- --disable-nls
- --disable-multibyte
- --disable-acl
- --enable-gui=no
- --without-x
- --disable-darwin
- --disable-luainterp
- --disable-perlinterp
- --disable-pythoninterp
- --disable-mzschemeinterp
- --disable-rubyinterp
- --disable-selinux
- --disable-tclinterp
- --disable-gpm
- )
- else
- use debug && append-flags "-DDEBUG"
-
- myconf=(
- --with-features=huge
- --enable-multibyte
- $(use_enable acl)
- $(use_enable cscope)
- $(use_enable gpm)
- $(use_enable lua luainterp)
- $(usex lua "--with-lua-prefix=${EPREFIX}/usr" "")
- $(use_with luajit)
- $(use_enable nls)
- $(use_enable perl perlinterp)
- $(use_enable racket mzschemeinterp)
- $(use_enable ruby rubyinterp)
- $(use_enable selinux)
- $(use_enable tcl tclinterp)
- )
-
- if use python ; then
- py_add_interp() {
- local v
-
- [[ ${EPYTHON} == python3* ]] && v=3
- myconf+=(
- --enable-python${v}interp
- vi_cv_path_python${v}="${PYTHON}"
- )
- }
-
- python_foreach_impl py_add_interp
- else
- myconf+=(
- --disable-pythoninterp
- --disable-python3interp
- )
- fi
-
- # --with-features=huge forces on cscope even if we --disable it. We need
- # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
- if ! use cscope ; then
- sed -i '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
-
- # don't test USE=X here ... see bug #19115
- # but need to provide a way to link against X ... see bug #20093
- myconf+=(
- --enable-gui=no
- --disable-darwin
- $(use_with X x)
- )
- fi
-
- # let package manager strip binaries
- export ac_cv_prog_STRIP="$(type -P true ) faking strip"
-
- # keep prefix env contained within the EPREFIX
- use prefix && myconf+=( --without-local-dir )
-
- econf \
- --with-modified-by=Gentoo-${PVR} \
- "${myconf[@]}"
-}
-
-src_compile() {
- # The following allows emake to be used
- emake -j1 -C src auto/osdef.h objects
-
- emake
-}
-
-src_test() {
- echo
- einfo "Starting vim tests. Several error messages will be shown"
- einfo "while the tests run. This is normal behaviour and does not"
- einfo "indicate a fault."
- echo
- ewarn "If the tests fail, your terminal may be left in a strange"
- ewarn "state. Usually, running 'reset' will fix this."
- echo
-
- # Don't let vim talk to X
- unset DISPLAY
-
- emake -j1 -C src/testdir nongui
-}
-
-# Make convenience symlinks, hopefully without stepping on toes. Some
-# of these links are "owned" by the vim ebuild when it is installed,
-# but they might be good for gvim as well (see bug 45828)
-update_vim_symlinks() {
- local f syms
- syms="vimdiff rvim rview"
- einfo "Calling eselect vi update..."
- # Call this with --if-unset to respect user's choice (bug 187449)
- eselect vi update --if-unset
-
- # Make or remove convenience symlink, vim -> gvim
- if [[ -f "${EROOT}"/usr/bin/gvim ]]; then
- ln -s gvim "${EROOT}"/usr/bin/vim 2>/dev/null
- elif [[ -L "${EROOT}"/usr/bin/vim && ! -f "${EROOT}"/usr/bin/vim ]]; then
- rm "${EROOT}"/usr/bin/vim
- fi
-
- # Make or remove convenience symlinks to vim
- if [[ -f "${EROOT}"/usr/bin/vim ]]; then
- for f in ${syms}; do
- ln -s vim "${EROOT}"/usr/bin/${f} 2>/dev/null
- done
- else
- for f in ${syms}; do
- if [[ -L "${EROOT}"/usr/bin/${f} && ! -f "${EROOT}"/usr/bin/${f} ]]; then
- rm -f "${EROOT}"/usr/bin/${f}
- fi
- done
- fi
-
- # This will still break if you merge then remove the vi package,
- # but there's only so much you can do, eh? Unfortunately we don't
- # have triggers like are done in rpm-land.
-}
-
-src_install() {
- local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
-
- # Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
- # managed by eselect-vi
- dobin src/vim
- dosym vim /usr/bin/vimdiff
- dosym vim /usr/bin/rvim
- dosym vim /usr/bin/rview
- if use vim-pager ; then
- dosym ${vimfiles}/macros/less.sh /usr/bin/vimpager
- dosym ${vimfiles}/macros/manpager.sh /usr/bin/vimmanpager
- insinto ${vimfiles}/macros
- doins runtime/macros/manpager.sh
- fperms a+x ${vimfiles}/macros/manpager.sh
- fi
-
- newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
- # keep in sync with 'complete ... -F' list
- bashcomp_alias vim ex vi view rvim rview vimdiff
-
- # We shouldn't be installing the ex or view man page symlinks, as they
- # are managed by eselect-vi
- rm -f "${ED}"/usr/share/man/man1/{ex,view}.1
-}
-
-pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Make convenience symlinks
- update_vim_symlinks
-}
-
-pkg_postrm() {
- # Update documentation tags (from vim-doc.eclass)
- update_vim_helptags
-
- # Make convenience symlinks
- update_vim_symlinks
-}