summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/armv8-fast-model
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/armv8-fast-model')
-rw-r--r--app-emulation/armv8-fast-model/Manifest1
-rw-r--r--app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild48
-rw-r--r--app-emulation/armv8-fast-model/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/armv8-fast-model/Manifest b/app-emulation/armv8-fast-model/Manifest
new file mode 100644
index 000000000000..bf823aae7bd6
--- /dev/null
+++ b/app-emulation/armv8-fast-model/Manifest
@@ -0,0 +1 @@
+DIST FM000-KT-00035-r0p8-52rel06.tgz 9429294 SHA256 a011c7549029fe5c475f2d495b225b93317a44eb3da0f19f2825ad831c64d899 SHA512 349470432e8dba9e52eba88b577b22fdd9e3ce865288a3dc1540c58e1e10b4f2c14f084f7a4928993e4d1d3bc7cfbbf235f2575394254f09a8d845b7b2993f12 WHIRLPOOL e95ed1315f264ed82f2debd903ad69a6437798d88727e275285d1d06c5da1a5841b9955e93b6dbdc446ad652ef383a37cfe0f43a3888f23ec428a67a765e6ac7
diff --git a/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild b/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild
new file mode 100644
index 000000000000..da6bf36f74b7
--- /dev/null
+++ b/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_P="FM000-KT-00035-r${PV:0:1}p${PV:2:1}-${PV:0-4:2}rel${PV:0-2}"
+DESCRIPTION="emulator for a basic ARMv8 platform environment (for running bare metal & Linux)"
+HOMEPAGE="https://silver.arm.com/browse/FM00A"
+SRC_URI="https://silver.arm.com/download/Development_Tools/ESL:_Fast_Models/Fast_Models/${MY_P}/${MY_P}.tgz"
+
+LICENSE="ARM-FAST-MODEL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="examples"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ sys-devel/gcc"
+
+S="${WORKDIR}/Foundation_v8pkg"
+
+QA_PREBUILT="
+ opt/${PN}/bin/Foundation_v8
+ opt/${PN}/*/lib*.so*
+"
+
+pkg_nofetch() {
+ einfo "Please visit this URL to download the package:"
+ einfo " ${SRC_URI}"
+ einfo "Then stick it into ${DISTDIR}"
+}
+
+src_install() {
+ into /opt/${PN}
+ pushd models/Linux64_GCC-4.1 >/dev/null
+ dobin Foundation_v8
+ dolib.so lib*.so*
+ popd >/dev/null
+
+ dodir /opt/bin
+ make_wrapper Foundation_v8 /opt/${PN}/bin/Foundation_v8 '' /opt/${PN}/$(get_libdir) /opt/bin
+
+ dodoc doc/*.{pdf,txt}
+ use examples && dodoc -r examples
+}
diff --git a/app-emulation/armv8-fast-model/metadata.xml b/app-emulation/armv8-fast-model/metadata.xml
new file mode 100644
index 000000000000..5454528f2093
--- /dev/null
+++ b/app-emulation/armv8-fast-model/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>arm</herd>
+</pkgmetadata>