summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-12-07 20:18:39 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-12-11 09:06:43 +0100
commit4c5c99c702595f855592057ec7da23dbd1dd6496 (patch)
tree19d8218c571264f57108ce782113b0b95d02e0ae /app-emulation/containerd
parentnet-news/newsboat: version bump to 2.13 (diff)
downloadgentoo-4c5c99c702595f855592057ec7da23dbd1dd6496.tar.gz
gentoo-4c5c99c702595f855592057ec7da23dbd1dd6496.tar.bz2
gentoo-4c5c99c702595f855592057ec7da23dbd1dd6496.zip
app-emulation/containerd: Version bump to 1.2.1
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.2.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 09155d9b56ab..aa52e9843542 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -3,3 +3,4 @@ DIST containerd-1.1.1.tar.gz 5123253 BLAKE2B e3e14311f4b444531b9b5d22ad7babd3fe9
DIST containerd-1.1.2.tar.gz 5124208 BLAKE2B d989519d6bef4e12d1fa04aa00bfee223e94676a90525304d4357f4caf46326b4d2b897b885e9e137fe01ce66b93bc92fb7da7bd2b5dd5019edda5bb0bbc6d0a SHA512 fe4121a43e72a354cd87577b5227f2c2e0d54674244001e6fdb695da78873b3fd3f46b6bda6bbd0c8793b33f50e0d725cb356bb75b789a273c862bbe7d4f719c
DIST containerd-1.1.4.tar.gz 5328134 BLAKE2B cb69f9bd80bc279ae2bd85c75152dacdbdf13df9aa2efae2453c11bf6ea9b990a4e8ec3cb07778ff1b07ef2fbc05d19bb5714616fa5618f590dc8c5b5c2b2bd0 SHA512 c51b3168b8d8121b1479f75f5ba21280848bb1cbed2d2c4a7e315ec24d1805fc9c512a1fc53e8e8fc32e150c7f2becb8daca0ecab4eaf760b3274c11fbcd6ea8
DIST containerd-1.2.0.tar.gz 4605096 BLAKE2B 5bcfb252933d4f8d5ab6c7e91505cfec34137545121440cd6935e05cd3c62a4969fff8b90b628634c01cc9a4dc3901c307604ab30f45a03dd20112653da9437d SHA512 f7e1ede8db253c666dc9d68642951a427722945da60acf8631312377c84aab14c7a8b14e81f9a63ab8f909d25eb55911c0f2eef68f11380c66cd77bada8577bd
+DIST containerd-1.2.1.tar.gz 4605947 BLAKE2B 340daac847eaa653d15894fd65c190702807400dfb8293b5a2507b9a13a86752c00357cf6aeb3735c57878c34f79c35076d7087a905ee7efe7971746c792a212 SHA512 0949299afe17e269a6c551e865e500afeeaba700cf78bb12fef4af8e6d48a2f699976e81dad44d797bb13079361f5d5e05e9abe903a3b158af93f2aaa95712e5
diff --git a/app-emulation/containerd/containerd-1.2.1.ebuild b/app-emulation/containerd/containerd-1.2.1.ebuild
new file mode 100644
index 000000000000..c9791d3160db
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="9b32062dc1f5a7c2564315c269b5059754f12b9d"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND=">=app-emulation/runc-1.0.0_rc5
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dodir /var/lib/containerd
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}