summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-18 13:55:53 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-18 13:56:20 +0100
commit681cbfee60f214c2cfb719ba6f6cdf59cbab03a1 (patch)
tree5de7d2277f944b47de4b7844ba2a397829613945 /app-emulation/containerd
parentapp-text/html401: Drop old (diff)
downloadgentoo-681cbfee60f214c2cfb719ba6f6cdf59cbab03a1.tar.gz
gentoo-681cbfee60f214c2cfb719ba6f6cdf59cbab03a1.tar.bz2
gentoo-681cbfee60f214c2cfb719ba6f6cdf59cbab03a1.zip
app-emulation/containerd: Version bump to 1.0.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.0.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index fe3b2faea66b..4039b6d437b2 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,3 +1,4 @@
DIST containerd-0.2.9_p20170917.tar.gz 1140788 BLAKE2B 96effa85f9cb03c3e416d53438376af6c7965660bf9c9931fdfa7fee94cca9386f2732e70dc88ee32b83e902b7d4a3072e22a817d9970ed1e07dc1271e8b33ab SHA512 c749bda691197ec8a7603db9ad92f2800a3f065143430a660333b7862518deb4c158a1c1fd01671dff438b40988d4a64d8f06bab05496b8728c6e2f57cd7da0a
DIST containerd-1.0.0.tar.gz 3763785 BLAKE2B cd4af679c9028b616aeedd594518f796a350523899c13da5a848a5843b318394166ddfbf5e7ed1f473a3759b26d134659f928d8e15da17ebdf65a41d2fd5f914 SHA512 8c1a03de7f30976675e4482b4f18f4b87da56108de4d92f2e33b4cb4f8c188af5b3fad87971a294eac8442a0fb6ddae48cda81334c363203a8c8bdfc09176a7a
DIST containerd-1.0.0_beta2_p20171019.tar.gz 3682585 BLAKE2B a67b581e3e5ddf2e95d551a9cca3dafa14772dc6ec1f1b1226ce21b0d7f88f3f80669b21f471fede50d5dd68d3916ef8696d0551c333c57e87a8ee2db3d25488 SHA512 290dcc97c47dccc6af424f5bcdfa2b59ae29eda135f71fb68a456245017a7ce5262150088f91b9edcaa19886d8919e5b6246f2816d6947c0a9b33ec6b58185e9
+DIST containerd-1.0.1.tar.gz 3766659 BLAKE2B 36c96a9e3cba22578daff31e46d9a876095e9de7e20e1e84a41076d9936f30a5681e41187a90f9a01884fd02086fa3c9a6ee29c8261401988a1cfa2026952431 SHA512 351c0e298ba6a9a14df2f367df23049a8a833eb18238e3d41cf0066feb2e0b8f2aa7b25fb4484a1b5c95bccf5cba3a8076a5bcfe25602b5368e7cf2a20872160
diff --git a/app-emulation/containerd/containerd-1.0.1.ebuild b/app-emulation/containerd/containerd-1.0.1.ebuild
new file mode 100644
index 000000000000..f9e3a2025158
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="9b55aab"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+btrfs hardened"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ sys-libs/libseccomp"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}