summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-04-17 11:35:21 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-04-17 11:35:21 -0500
commitbf4e69347e7fce0c7a35fe4789e6c097c69d65f8 (patch)
tree3cb24124cfdab38020fb0b2f4a8ec889a0afa0ec /app-emulation/containerd
parentdev-util/ccache: version bump to 3.2.5 (diff)
downloadgentoo-bf4e69347e7fce0c7a35fe4789e6c097c69d65f8.tar.gz
gentoo-bf4e69347e7fce0c7a35fe4789e6c097c69d65f8.tar.bz2
gentoo-bf4e69347e7fce0c7a35fe4789e6c097c69d65f8.zip
app-emulation/containerd: initial import
Ebuild based on Tianon's work https://github.com/tianon/docker-overlay/tree/master/app-emulation/containerd Package-Manager: portage-2.2.27
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-0.2.0.ebuild43
-rw-r--r--app-emulation/containerd/containerd-9999.ebuild43
-rw-r--r--app-emulation/containerd/metadata.xml22
4 files changed, 109 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
new file mode 100644
index 000000000000..28726221b052
--- /dev/null
+++ b/app-emulation/containerd/Manifest
@@ -0,0 +1 @@
+DIST containerd-0.2.0.tar.gz 635248 SHA256 1462e0c233763800b91ac2a670d82994ba1988560928e153f751fb1c0a6608c0 SHA512 381c0a21733fb79e90364649b46cbdadbc32d07245bd7a320465f6619ee5895e9552b7cc4393cb8d409295a7b867b7e461c079715cf1938e6313d4b888d81518 WHIRLPOOL d4e70a8be832227be671c13b77242a790cdf8645ff294c31d72e8cf01de2b30b9d78c691a156624adb004de42af6f133cb88b46aff37a33bc94d72bf87a0ee8a
diff --git a/app-emulation/containerd/containerd-0.2.0.ebuild b/app-emulation/containerd/containerd-0.2.0.ebuild
new file mode 100644
index 000000000000..c840962b287c
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+seccomp"
+
+DEPEND=""
+RDEPEND="app-emulation/runc
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ eapply_user
+}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS= emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}
diff --git a/app-emulation/containerd/containerd-9999.ebuild b/app-emulation/containerd/containerd-9999.ebuild
new file mode 100644
index 000000000000..c840962b287c
--- /dev/null
+++ b/app-emulation/containerd/containerd-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+seccomp"
+
+DEPEND=""
+RDEPEND="app-emulation/runc
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ eapply_user
+}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS= emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}
diff --git a/app-emulation/containerd/metadata.xml b/app-emulation/containerd/metadata.xml
new file mode 100644
index 000000000000..95132700bf73
--- /dev/null
+++ b/app-emulation/containerd/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Containerd is a daemon with an API and a command line client, to manage
+ containers on one machine. It uses runC to run containers according to
+ the OCI specification. Containerd has advanced features such as seccomp
+ and user namespace support as well as checkpoint and restore for cloning
+ and live migration of containers.
+ </longdescription>
+ <maintainer type="person">
+ <email>admwiggin@gmail.com</email>
+ <name>Tianon</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">docker/containerd</remote-id>
+ </upstream>
+</pkgmetadata>