summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2018-05-27 14:29:55 -0400
committerRichard Yao <ryao@gentoo.org>2018-05-27 14:29:55 -0400
commitfda7328e5c3f0d7e8be7cd1693bd3221b1e81338 (patch)
tree3b95706313d9ae6358ba2e9526aeacb631a7e975 /app-emulation/crossover-bin
parentx11-plugins/guifications: remove obsolete || die (diff)
downloadgentoo-fda7328e5c3f0d7e8be7cd1693bd3221b1e81338.tar.gz
gentoo-fda7328e5c3f0d7e8be7cd1693bd3221b1e81338.tar.bz2
gentoo-fda7328e5c3f0d7e8be7cd1693bd3221b1e81338.zip
app-emulation/crossover-bin: Bump to 17.5.0
I am also including 15.3.0, 15.3.1, 16.0.0 and 16.2.5, which are well overdue. They have been queued to be committed for a long time. This also fixes some of repoman's complaints. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation/crossover-bin')
-rw-r--r--app-emulation/crossover-bin/Manifest5
-rw-r--r--app-emulation/crossover-bin/crossover-bin-12.5.0-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-12.5.1-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-13.0.0-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-13.0.1-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-13.1.0-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-13.1.2-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-13.1.3-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-13.2.0-r2.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-14.0.3-r1.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-14.1.4-r1.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-15.0.0.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-15.0.1.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-15.1.0.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild6
-rw-r--r--app-emulation/crossover-bin/crossover-bin-15.3.0.ebuild146
-rw-r--r--app-emulation/crossover-bin/crossover-bin-15.3.1.ebuild146
-rw-r--r--app-emulation/crossover-bin/crossover-bin-16.0.0.ebuild146
-rw-r--r--app-emulation/crossover-bin/crossover-bin-16.2.5.ebuild146
-rw-r--r--app-emulation/crossover-bin/crossover-bin-17.5.0.ebuild145
-rw-r--r--app-emulation/crossover-bin/metadata.xml1
21 files changed, 777 insertions, 42 deletions
diff --git a/app-emulation/crossover-bin/Manifest b/app-emulation/crossover-bin/Manifest
index 5586b1fcfd2c..20040fb6fa24 100644
--- a/app-emulation/crossover-bin/Manifest
+++ b/app-emulation/crossover-bin/Manifest
@@ -12,3 +12,8 @@ DIST install-crossover-15.0.0.bin 80995834 BLAKE2B 63809a9f39e48cd51b9b0b97cdc1c
DIST install-crossover-15.0.1.bin 81027541 BLAKE2B 2cb838aad4363d910897a76cf1d03f031d2a14f494fef3f4db082c303c46f5964fac20096bd1d596285a4bef152af1ba7864b3205a3ee35efc6ff6d5ac7565c7 SHA512 a35188ccebeee8d456e73fdcbb8e8d4f0aff41bb89d92767d2e2e78e7cb25c8e48a150393c1c9abeb9760fbc873314e301c0a364ba27acfe08e0980bb5eedb03
DIST install-crossover-15.1.0.bin 80623685 BLAKE2B 77125ce567c997ee718f546c3b68077a3d59e6a0f5711968bb5cb72cc0b2c7dd22182d7e8c8864c5eef0b6e833159a4534fc81db7234ea8bf757b5a465df1abc SHA512 177e70baff3d99e808834c8e6f626f09d9c262babd6d5a3b51ea79a5a68a157cdfd4fd60ad6939d110f2300670e4973d9fd43a3a132ff9a2367dedb782e5c05c
DIST install-crossover-15.2.0.bin 80734561 BLAKE2B e8b4ee0ab2c5a8463c2757a756a008886071a35114e5ee1b5590907ad42be3c6777bc024cb2c3c41f215e6e29b69d08d46c47dbea0629f542c098b957d124106 SHA512 9633e29b26f8fa99d1c34347b8e1f2e89b84370994a1ab3bba7061b75224f3a907d1c364207312dde1995e5a59180f8699558a96a4c99b157257ab9c21013b2e
+DIST install-crossover-15.3.0.bin 80774063 BLAKE2B 2f0aa184f77120c241656d8d9990c5cfe177ab847061e023f0f08b52d804a1f832a18b1f2e82fddf9dde8313e717d3c92104ab46d95dc50c5935c57f878b6716 SHA512 8e5a6fa40a0af0976d794436ac69edf61f73d4f1f128503a6372c4ae804eb977438a98062bc064f25dbb93015fa0776b9e5d572a98e887980214d3ccb93fd4c7
+DIST install-crossover-15.3.1.bin 80774288 BLAKE2B 3d3fd83ee426a66ead3c88f4ca584408117e9a0f9a1af6d2cfe0623db398caaeb2dc1b285f8edbf9a700c3281bd5bdd81542df9ef0457be036727b756121d99d SHA512 3f4da41a7b255263012e70ed833a134425e464847acc69ba79f73989c0bfc5f98869cf5858c1e2d16422a8220296695157b942f275b861b3ee0dcc2d90f7da7d
+DIST install-crossover-16.0.0.bin 197872657 BLAKE2B d500ed4f6a426154b376ead6c2b50eb21a403303561078dc51982a5147af23261dda9892717c16c6e2f3b2a30ffc84e73070cd330bea70ba89c79180c4933297 SHA512 184533679ddf3918ab5fc00b01452d868c694fbc7ccb5484c88822cc52da067fd1a0be0387e4050e40d9b367052158faec27dc06f6a371a044b5a1782950e780
+DIST install-crossover-16.2.5.bin 198336730 BLAKE2B a11252dab552846fe0a1527cd59cd62907142385062b744591cef6707213d03945879fc5da6bcfaaa315967c51ae15159ad14d8519407542b82f0eb53c5fd02e SHA512 17cb711e7257f094e9ccf939edc1ca6be362f18b86078fe307b7e1337850e182d02fde087789f13ea2bf96ca89736f941c1a7bd93ff1b37a78fe8f846a1d5e22
+DIST install-crossover-17.5.0.bin 198287744 BLAKE2B c594192927874e5a80626ad110f0089f2bf8b7385a16ff7755923d63ebb0559b1aa505ec4e8b6f85253ac13736b7f9af178c64ed042a515d31cd4565295db163 SHA512 8592d2c91c437d62d1fd5fecf6230eeabfe56c38f49ea795bf4d3b51d8ae4399f1b01801d60dcccb94caeb4dd662675c2739f730f39ef178db32dd4f72182197
diff --git a/app-emulation/crossover-bin/crossover-bin-12.5.0-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-12.5.0-r2.ebuild
index 787313abdb5c..0ba8782b3e57 100644
--- a/app-emulation/crossover-bin/crossover-bin-12.5.0-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-12.5.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-12.5.1-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-12.5.1-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-12.5.1-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-12.5.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-13.0.0-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-13.0.0-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-13.0.0-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-13.0.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-13.0.1-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-13.0.1-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-13.0.1-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-13.0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-13.1.0-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-13.1.0-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-13.1.0-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-13.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-13.1.2-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-13.1.2-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-13.1.2-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-13.1.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-13.1.3-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-13.1.3-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-13.1.3-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-13.1.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-13.2.0-r2.ebuild b/app-emulation/crossover-bin/crossover-bin-13.2.0-r2.ebuild
index 9e79f258f113..334ea82257d9 100644
--- a/app-emulation/crossover-bin/crossover-bin-13.2.0-r2.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-13.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -98,7 +98,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-14.0.3-r1.ebuild b/app-emulation/crossover-bin/crossover-bin-14.0.3-r1.ebuild
index ed4550ce9f73..c9f592ef71aa 100644
--- a/app-emulation/crossover-bin/crossover-bin-14.0.3-r1.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-14.0.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -102,7 +102,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-14.1.4-r1.ebuild b/app-emulation/crossover-bin/crossover-bin-14.1.4-r1.ebuild
index b53dbeea6606..96c126f7ce82 100644
--- a/app-emulation/crossover-bin/crossover-bin-14.1.4-r1.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-14.1.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -102,7 +102,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-15.0.0.ebuild b/app-emulation/crossover-bin/crossover-bin-15.0.0.ebuild
index 266145f7f510..d09071799e73 100644
--- a/app-emulation/crossover-bin/crossover-bin-15.0.0.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-15.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -104,7 +104,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-15.0.1.ebuild b/app-emulation/crossover-bin/crossover-bin-15.0.1.ebuild
index 29eee7088d89..e4459d41a376 100644
--- a/app-emulation/crossover-bin/crossover-bin-15.0.1.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-15.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -102,7 +102,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-15.1.0.ebuild b/app-emulation/crossover-bin/crossover-bin-15.1.0.ebuild
index 29eee7088d89..e4459d41a376 100644
--- a/app-emulation/crossover-bin/crossover-bin-15.1.0.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-15.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -102,7 +102,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild b/app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild
index 7f5b2c4eeb67..07af6d9e65cf 100644
--- a/app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild
+++ b/app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -42,7 +42,7 @@ RDEPEND="${DEPEND}
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
- capi? ( net-dialup/capi4k-utils )
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
@@ -102,7 +102,7 @@ src_prepare() {
src_install() {
# Install crossover symlink, bug #476314
- dosym /opt/cxoffice/bin/crossover /opt/bin/crossover
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
# Install documentation
dodoc README changelog.txt
diff --git a/app-emulation/crossover-bin/crossover-bin-15.3.0.ebuild b/app-emulation/crossover-bin/crossover-bin-15.3.0.ebuild
new file mode 100644
index 000000000000..ea5203a1a868
--- /dev/null
+++ b/app-emulation/crossover-bin/crossover-bin-15.3.0.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 unpacker
+
+DESCRIPTION="Commercial version of app-emulation/wine with paid support."
+HOMEPAGE="http://www.codeweavers.com/products/crossover/"
+SRC_URI="https://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-${PV}.bin"
+
+LICENSE="CROSSOVER-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opengl +png +scanner +ssl +v4l"
+RESTRICT="bindist test"
+QA_FLAGS_IGNORED="opt/cxoffice/.*"
+QA_PRESTRIPPED="opt/cxoffice/lib/.*
+ opt/cxoffice/bin/cxburner
+ opt/cxoffice/bin/cxntlm_auth
+ opt/cxoffice/bin/wineserver
+ opt/cxoffice/bin/unrar
+ opt/cxoffice/bin/wine-preloader
+ opt/cxoffice/bin/cxdiag
+ opt/cxoffice/bin/cxgettext
+ opt/cxoffice/bin/wineloader
+ "
+S="${WORKDIR}"
+
+DEPEND="dev-lang/perl
+ app-arch/unzip
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ !prefix? ( sys-libs/glibc )
+ >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ !app-emulation/crossover-office-pro-bin
+ !app-emulation/crossover-office-bin
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
+ cups? ( net-print/cups[abi_x86_32(-)] )
+ gsm? ( media-sound/gsm[abi_x86_32(-)] )
+ jpeg? ( virtual/jpeg[abi_x86_32(-)] )
+ lcms? ( media-libs/lcms:2 )
+ ldap? ( net-nds/openldap[abi_x86_32(-)] )
+ gphoto2? ( media-libs/libgphoto2[abi_x86_32(-)] )
+ mp3? ( >=media-sound/mpg123-1.5.0[abi_x86_32(-)] )
+ nls? ( sys-devel/gettext[abi_x86_32(-)] )
+ openal? ( media-libs/openal[abi_x86_32(-)] )
+ opengl? (
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ png? ( media-libs/libpng:0[abi_x86_32(-)] )
+ scanner? ( media-gfx/sane-backends[abi_x86_32(-)] )
+ ssl? ( dev-libs/openssl:0[abi_x86_32(-)] )
+ v4l? ( media-libs/libv4l[abi_x86_32(-)] )
+ media-libs/alsa-lib[abi_x86_32(-)]
+ >=media-libs/freetype-2.0.0[abi_x86_32(-)]
+ media-libs/mesa[abi_x86_32(-)]
+ sys-apps/util-linux[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libSM[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e "s:xdg_install_icons(:&\"${ED}\".:" \
+ -e "s:\"\(.*\)/applications:\"${ED}\1/applications:" \
+ -e "s:\"\(.*\)/desktop-directories:\"${ED}\1/desktop-directories:" \
+ "${S}/lib/perl/CXMenuXDG.pm"
+
+ # Remove unnecessary files
+ rm -r license.txt guis/ || die "Could not remove files"
+ use doc || rm -r doc/ || die "Could not remove files"
+}
+
+src_install() {
+ # Install crossover symlink, bug #476314
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
+
+ # Install documentation
+ dodoc README changelog.txt
+ rm README changelog.txt || die "Could not remove README and changelog.txt"
+
+ # Install files
+ dodir /opt/cxoffice
+ #cp -r ./* "${ED}opt/cxoffice" \
+ find . | cpio -dumpl "${ED}/opt/cxoffice" 2>/dev/null \
+ || die "Could not install into ${ED}opt/cxoffice"
+
+ # Install configuration file
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+
+ # Install menus
+ # XXX: locate_gui.sh automatically detects *-application-merged directories
+ # This means what we install will vary depending on the contents of
+ # /etc/xdg, which is a QA violation. It is not clear how to resolve this.
+ XDG_DATA_DIRS="/usr/share" XDG_CONFIG_HOME="/etc/xdg" \
+ "${ED}opt/cxoffice/bin/cxmenu" --destdir="${ED}" --crossover --install \
+ || die "Could not install menus"
+
+ rm "${ED}usr/share/applications/"*"Uninstall CrossOver Linux.desktop" \
+ "${ED}opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/Uninstall CrossOver Linux.desktop" \
+ || die "Could not remove uninstall menus"
+ sed -i \
+ -e "s:\"${ED}\".::" \
+ -e "s:${ED}::" \
+ "${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm" \
+ || die "Could not fix paths in ${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm"
+ sed -i -e "s:${ED}:/:" \
+ "${ED}/opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/"*.desktop \
+ "${ED}usr/share/applications/"*"CrossOver.desktop" \
+ || die "Could not fix paths of *.desktop files"
+}
+
+pkg_postinst() {
+ einfo "${P} is open source software with the exception of the GUI."
+ einfo "Source code can be obtained from:"
+ einfo
+ einfo "https://media.codeweavers.com/pub/crossover/source/crossover-sources-${PV}.tar.gz"
+}
diff --git a/app-emulation/crossover-bin/crossover-bin-15.3.1.ebuild b/app-emulation/crossover-bin/crossover-bin-15.3.1.ebuild
new file mode 100644
index 000000000000..ea5203a1a868
--- /dev/null
+++ b/app-emulation/crossover-bin/crossover-bin-15.3.1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 unpacker
+
+DESCRIPTION="Commercial version of app-emulation/wine with paid support."
+HOMEPAGE="http://www.codeweavers.com/products/crossover/"
+SRC_URI="https://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-${PV}.bin"
+
+LICENSE="CROSSOVER-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opengl +png +scanner +ssl +v4l"
+RESTRICT="bindist test"
+QA_FLAGS_IGNORED="opt/cxoffice/.*"
+QA_PRESTRIPPED="opt/cxoffice/lib/.*
+ opt/cxoffice/bin/cxburner
+ opt/cxoffice/bin/cxntlm_auth
+ opt/cxoffice/bin/wineserver
+ opt/cxoffice/bin/unrar
+ opt/cxoffice/bin/wine-preloader
+ opt/cxoffice/bin/cxdiag
+ opt/cxoffice/bin/cxgettext
+ opt/cxoffice/bin/wineloader
+ "
+S="${WORKDIR}"
+
+DEPEND="dev-lang/perl
+ app-arch/unzip
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ !prefix? ( sys-libs/glibc )
+ >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ !app-emulation/crossover-office-pro-bin
+ !app-emulation/crossover-office-bin
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
+ cups? ( net-print/cups[abi_x86_32(-)] )
+ gsm? ( media-sound/gsm[abi_x86_32(-)] )
+ jpeg? ( virtual/jpeg[abi_x86_32(-)] )
+ lcms? ( media-libs/lcms:2 )
+ ldap? ( net-nds/openldap[abi_x86_32(-)] )
+ gphoto2? ( media-libs/libgphoto2[abi_x86_32(-)] )
+ mp3? ( >=media-sound/mpg123-1.5.0[abi_x86_32(-)] )
+ nls? ( sys-devel/gettext[abi_x86_32(-)] )
+ openal? ( media-libs/openal[abi_x86_32(-)] )
+ opengl? (
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ png? ( media-libs/libpng:0[abi_x86_32(-)] )
+ scanner? ( media-gfx/sane-backends[abi_x86_32(-)] )
+ ssl? ( dev-libs/openssl:0[abi_x86_32(-)] )
+ v4l? ( media-libs/libv4l[abi_x86_32(-)] )
+ media-libs/alsa-lib[abi_x86_32(-)]
+ >=media-libs/freetype-2.0.0[abi_x86_32(-)]
+ media-libs/mesa[abi_x86_32(-)]
+ sys-apps/util-linux[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libSM[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e "s:xdg_install_icons(:&\"${ED}\".:" \
+ -e "s:\"\(.*\)/applications:\"${ED}\1/applications:" \
+ -e "s:\"\(.*\)/desktop-directories:\"${ED}\1/desktop-directories:" \
+ "${S}/lib/perl/CXMenuXDG.pm"
+
+ # Remove unnecessary files
+ rm -r license.txt guis/ || die "Could not remove files"
+ use doc || rm -r doc/ || die "Could not remove files"
+}
+
+src_install() {
+ # Install crossover symlink, bug #476314
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
+
+ # Install documentation
+ dodoc README changelog.txt
+ rm README changelog.txt || die "Could not remove README and changelog.txt"
+
+ # Install files
+ dodir /opt/cxoffice
+ #cp -r ./* "${ED}opt/cxoffice" \
+ find . | cpio -dumpl "${ED}/opt/cxoffice" 2>/dev/null \
+ || die "Could not install into ${ED}opt/cxoffice"
+
+ # Install configuration file
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+
+ # Install menus
+ # XXX: locate_gui.sh automatically detects *-application-merged directories
+ # This means what we install will vary depending on the contents of
+ # /etc/xdg, which is a QA violation. It is not clear how to resolve this.
+ XDG_DATA_DIRS="/usr/share" XDG_CONFIG_HOME="/etc/xdg" \
+ "${ED}opt/cxoffice/bin/cxmenu" --destdir="${ED}" --crossover --install \
+ || die "Could not install menus"
+
+ rm "${ED}usr/share/applications/"*"Uninstall CrossOver Linux.desktop" \
+ "${ED}opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/Uninstall CrossOver Linux.desktop" \
+ || die "Could not remove uninstall menus"
+ sed -i \
+ -e "s:\"${ED}\".::" \
+ -e "s:${ED}::" \
+ "${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm" \
+ || die "Could not fix paths in ${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm"
+ sed -i -e "s:${ED}:/:" \
+ "${ED}/opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/"*.desktop \
+ "${ED}usr/share/applications/"*"CrossOver.desktop" \
+ || die "Could not fix paths of *.desktop files"
+}
+
+pkg_postinst() {
+ einfo "${P} is open source software with the exception of the GUI."
+ einfo "Source code can be obtained from:"
+ einfo
+ einfo "https://media.codeweavers.com/pub/crossover/source/crossover-sources-${PV}.tar.gz"
+}
diff --git a/app-emulation/crossover-bin/crossover-bin-16.0.0.ebuild b/app-emulation/crossover-bin/crossover-bin-16.0.0.ebuild
new file mode 100644
index 000000000000..ea5203a1a868
--- /dev/null
+++ b/app-emulation/crossover-bin/crossover-bin-16.0.0.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 unpacker
+
+DESCRIPTION="Commercial version of app-emulation/wine with paid support."
+HOMEPAGE="http://www.codeweavers.com/products/crossover/"
+SRC_URI="https://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-${PV}.bin"
+
+LICENSE="CROSSOVER-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opengl +png +scanner +ssl +v4l"
+RESTRICT="bindist test"
+QA_FLAGS_IGNORED="opt/cxoffice/.*"
+QA_PRESTRIPPED="opt/cxoffice/lib/.*
+ opt/cxoffice/bin/cxburner
+ opt/cxoffice/bin/cxntlm_auth
+ opt/cxoffice/bin/wineserver
+ opt/cxoffice/bin/unrar
+ opt/cxoffice/bin/wine-preloader
+ opt/cxoffice/bin/cxdiag
+ opt/cxoffice/bin/cxgettext
+ opt/cxoffice/bin/wineloader
+ "
+S="${WORKDIR}"
+
+DEPEND="dev-lang/perl
+ app-arch/unzip
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ !prefix? ( sys-libs/glibc )
+ >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ !app-emulation/crossover-office-pro-bin
+ !app-emulation/crossover-office-bin
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
+ cups? ( net-print/cups[abi_x86_32(-)] )
+ gsm? ( media-sound/gsm[abi_x86_32(-)] )
+ jpeg? ( virtual/jpeg[abi_x86_32(-)] )
+ lcms? ( media-libs/lcms:2 )
+ ldap? ( net-nds/openldap[abi_x86_32(-)] )
+ gphoto2? ( media-libs/libgphoto2[abi_x86_32(-)] )
+ mp3? ( >=media-sound/mpg123-1.5.0[abi_x86_32(-)] )
+ nls? ( sys-devel/gettext[abi_x86_32(-)] )
+ openal? ( media-libs/openal[abi_x86_32(-)] )
+ opengl? (
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ png? ( media-libs/libpng:0[abi_x86_32(-)] )
+ scanner? ( media-gfx/sane-backends[abi_x86_32(-)] )
+ ssl? ( dev-libs/openssl:0[abi_x86_32(-)] )
+ v4l? ( media-libs/libv4l[abi_x86_32(-)] )
+ media-libs/alsa-lib[abi_x86_32(-)]
+ >=media-libs/freetype-2.0.0[abi_x86_32(-)]
+ media-libs/mesa[abi_x86_32(-)]
+ sys-apps/util-linux[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libSM[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e "s:xdg_install_icons(:&\"${ED}\".:" \
+ -e "s:\"\(.*\)/applications:\"${ED}\1/applications:" \
+ -e "s:\"\(.*\)/desktop-directories:\"${ED}\1/desktop-directories:" \
+ "${S}/lib/perl/CXMenuXDG.pm"
+
+ # Remove unnecessary files
+ rm -r license.txt guis/ || die "Could not remove files"
+ use doc || rm -r doc/ || die "Could not remove files"
+}
+
+src_install() {
+ # Install crossover symlink, bug #476314
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
+
+ # Install documentation
+ dodoc README changelog.txt
+ rm README changelog.txt || die "Could not remove README and changelog.txt"
+
+ # Install files
+ dodir /opt/cxoffice
+ #cp -r ./* "${ED}opt/cxoffice" \
+ find . | cpio -dumpl "${ED}/opt/cxoffice" 2>/dev/null \
+ || die "Could not install into ${ED}opt/cxoffice"
+
+ # Install configuration file
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+
+ # Install menus
+ # XXX: locate_gui.sh automatically detects *-application-merged directories
+ # This means what we install will vary depending on the contents of
+ # /etc/xdg, which is a QA violation. It is not clear how to resolve this.
+ XDG_DATA_DIRS="/usr/share" XDG_CONFIG_HOME="/etc/xdg" \
+ "${ED}opt/cxoffice/bin/cxmenu" --destdir="${ED}" --crossover --install \
+ || die "Could not install menus"
+
+ rm "${ED}usr/share/applications/"*"Uninstall CrossOver Linux.desktop" \
+ "${ED}opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/Uninstall CrossOver Linux.desktop" \
+ || die "Could not remove uninstall menus"
+ sed -i \
+ -e "s:\"${ED}\".::" \
+ -e "s:${ED}::" \
+ "${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm" \
+ || die "Could not fix paths in ${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm"
+ sed -i -e "s:${ED}:/:" \
+ "${ED}/opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/"*.desktop \
+ "${ED}usr/share/applications/"*"CrossOver.desktop" \
+ || die "Could not fix paths of *.desktop files"
+}
+
+pkg_postinst() {
+ einfo "${P} is open source software with the exception of the GUI."
+ einfo "Source code can be obtained from:"
+ einfo
+ einfo "https://media.codeweavers.com/pub/crossover/source/crossover-sources-${PV}.tar.gz"
+}
diff --git a/app-emulation/crossover-bin/crossover-bin-16.2.5.ebuild b/app-emulation/crossover-bin/crossover-bin-16.2.5.ebuild
new file mode 100644
index 000000000000..ea5203a1a868
--- /dev/null
+++ b/app-emulation/crossover-bin/crossover-bin-16.2.5.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 unpacker
+
+DESCRIPTION="Commercial version of app-emulation/wine with paid support."
+HOMEPAGE="http://www.codeweavers.com/products/crossover/"
+SRC_URI="https://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-${PV}.bin"
+
+LICENSE="CROSSOVER-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opengl +png +scanner +ssl +v4l"
+RESTRICT="bindist test"
+QA_FLAGS_IGNORED="opt/cxoffice/.*"
+QA_PRESTRIPPED="opt/cxoffice/lib/.*
+ opt/cxoffice/bin/cxburner
+ opt/cxoffice/bin/cxntlm_auth
+ opt/cxoffice/bin/wineserver
+ opt/cxoffice/bin/unrar
+ opt/cxoffice/bin/wine-preloader
+ opt/cxoffice/bin/cxdiag
+ opt/cxoffice/bin/cxgettext
+ opt/cxoffice/bin/wineloader
+ "
+S="${WORKDIR}"
+
+DEPEND="dev-lang/perl
+ app-arch/unzip
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ !prefix? ( sys-libs/glibc )
+ >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ !app-emulation/crossover-office-pro-bin
+ !app-emulation/crossover-office-bin
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
+ cups? ( net-print/cups[abi_x86_32(-)] )
+ gsm? ( media-sound/gsm[abi_x86_32(-)] )
+ jpeg? ( virtual/jpeg[abi_x86_32(-)] )
+ lcms? ( media-libs/lcms:2 )
+ ldap? ( net-nds/openldap[abi_x86_32(-)] )
+ gphoto2? ( media-libs/libgphoto2[abi_x86_32(-)] )
+ mp3? ( >=media-sound/mpg123-1.5.0[abi_x86_32(-)] )
+ nls? ( sys-devel/gettext[abi_x86_32(-)] )
+ openal? ( media-libs/openal[abi_x86_32(-)] )
+ opengl? (
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ png? ( media-libs/libpng:0[abi_x86_32(-)] )
+ scanner? ( media-gfx/sane-backends[abi_x86_32(-)] )
+ ssl? ( dev-libs/openssl:0[abi_x86_32(-)] )
+ v4l? ( media-libs/libv4l[abi_x86_32(-)] )
+ media-libs/alsa-lib[abi_x86_32(-)]
+ >=media-libs/freetype-2.0.0[abi_x86_32(-)]
+ media-libs/mesa[abi_x86_32(-)]
+ sys-apps/util-linux[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libSM[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e "s:xdg_install_icons(:&\"${ED}\".:" \
+ -e "s:\"\(.*\)/applications:\"${ED}\1/applications:" \
+ -e "s:\"\(.*\)/desktop-directories:\"${ED}\1/desktop-directories:" \
+ "${S}/lib/perl/CXMenuXDG.pm"
+
+ # Remove unnecessary files
+ rm -r license.txt guis/ || die "Could not remove files"
+ use doc || rm -r doc/ || die "Could not remove files"
+}
+
+src_install() {
+ # Install crossover symlink, bug #476314
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
+
+ # Install documentation
+ dodoc README changelog.txt
+ rm README changelog.txt || die "Could not remove README and changelog.txt"
+
+ # Install files
+ dodir /opt/cxoffice
+ #cp -r ./* "${ED}opt/cxoffice" \
+ find . | cpio -dumpl "${ED}/opt/cxoffice" 2>/dev/null \
+ || die "Could not install into ${ED}opt/cxoffice"
+
+ # Install configuration file
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+
+ # Install menus
+ # XXX: locate_gui.sh automatically detects *-application-merged directories
+ # This means what we install will vary depending on the contents of
+ # /etc/xdg, which is a QA violation. It is not clear how to resolve this.
+ XDG_DATA_DIRS="/usr/share" XDG_CONFIG_HOME="/etc/xdg" \
+ "${ED}opt/cxoffice/bin/cxmenu" --destdir="${ED}" --crossover --install \
+ || die "Could not install menus"
+
+ rm "${ED}usr/share/applications/"*"Uninstall CrossOver Linux.desktop" \
+ "${ED}opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/Uninstall CrossOver Linux.desktop" \
+ || die "Could not remove uninstall menus"
+ sed -i \
+ -e "s:\"${ED}\".::" \
+ -e "s:${ED}::" \
+ "${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm" \
+ || die "Could not fix paths in ${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm"
+ sed -i -e "s:${ED}:/:" \
+ "${ED}/opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/"*.desktop \
+ "${ED}usr/share/applications/"*"CrossOver.desktop" \
+ || die "Could not fix paths of *.desktop files"
+}
+
+pkg_postinst() {
+ einfo "${P} is open source software with the exception of the GUI."
+ einfo "Source code can be obtained from:"
+ einfo
+ einfo "https://media.codeweavers.com/pub/crossover/source/crossover-sources-${PV}.tar.gz"
+}
diff --git a/app-emulation/crossover-bin/crossover-bin-17.5.0.ebuild b/app-emulation/crossover-bin/crossover-bin-17.5.0.ebuild
new file mode 100644
index 000000000000..cf007d6b618d
--- /dev/null
+++ b/app-emulation/crossover-bin/crossover-bin-17.5.0.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 unpacker
+
+DESCRIPTION="Commercial version of app-emulation/wine with paid support."
+HOMEPAGE="http://www.codeweavers.com/products/crossover/"
+SRC_URI="https://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-${PV}.bin"
+
+LICENSE="CROSSOVER-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opencl +opengl +png +scanner +ssl +v4l"
+RESTRICT="bindist test"
+QA_FLAGS_IGNORED="opt/cxoffice/.*"
+QA_PRESTRIPPED="opt/cxoffice/lib/.*
+ opt/cxoffice/bin/cxburner
+ opt/cxoffice/bin/cxntlm_auth
+ opt/cxoffice/bin/wineserver
+ opt/cxoffice/bin/unrar
+ opt/cxoffice/bin/wine-preloader
+ opt/cxoffice/bin/cxdiag
+ opt/cxoffice/bin/cxgettext
+ opt/cxoffice/bin/wineloader
+ "
+S="${WORKDIR}"
+
+DEPEND="dev-lang/perl
+ app-arch/unzip
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ !prefix? ( sys-libs/glibc )
+ >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ !app-emulation/crossover-office-pro-bin
+ !app-emulation/crossover-office-bin
+ capi? ( net-libs/libcapi[abi_x86_32(-)] )
+ cups? ( net-print/cups[abi_x86_32(-)] )
+ gsm? ( media-sound/gsm[abi_x86_32(-)] )
+ jpeg? ( virtual/jpeg[abi_x86_32(-)] )
+ lcms? ( media-libs/lcms:2 )
+ ldap? ( net-nds/openldap[abi_x86_32(-)] )
+ gphoto2? ( media-libs/libgphoto2[abi_x86_32(-)] )
+ mp3? ( >=media-sound/mpg123-1.5.0[abi_x86_32(-)] )
+ nls? ( sys-devel/gettext[abi_x86_32(-)] )
+ openal? ( media-libs/openal[abi_x86_32(-)] )
+ opencl? ( virtual/opencl[abi_x86_32(-)] )
+ opengl? (
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ png? ( media-libs/libpng:0[abi_x86_32(-)] )
+ scanner? ( media-gfx/sane-backends[abi_x86_32(-)] )
+ ssl? ( dev-libs/openssl:0[abi_x86_32(-)] )
+ v4l? ( media-libs/libv4l[abi_x86_32(-)] )
+ media-libs/alsa-lib[abi_x86_32(-)]
+ >=media-libs/freetype-2.0.0[abi_x86_32(-)]
+ media-libs/mesa[abi_x86_32(-)]
+ sys-apps/util-linux[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libSM[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e "s:xdg_install_icons(:&\"${ED}\".:" \
+ -e "s:\"\(.*\)/applications:\"${ED}\1/applications:" \
+ -e "s:\"\(.*\)/desktop-directories:\"${ED}\1/desktop-directories:" \
+ "${S}/lib/perl/CXMenuXDG.pm"
+
+ # Remove unnecessary files
+ rm -r license.txt guis/ || die "Could not remove files"
+ use doc || rm -r doc/ || die "Could not remove files"
+}
+
+src_install() {
+ # Install crossover symlink, bug #476314
+ dosym ../cxoffice/bin/crossover /opt/bin/crossover
+
+ # Install documentation
+ dodoc README changelog.txt
+ rm README changelog.txt || die "Could not remove README and changelog.txt"
+
+ # Install files
+ dodir /opt/cxoffice
+ #cp -r ./* "${ED}opt/cxoffice" \
+ find . | cpio -dumpl "${ED}/opt/cxoffice" 2>/dev/null \
+ || die "Could not install into ${ED}opt/cxoffice"
+
+ # Install configuration file
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+
+ # Install menus
+ # XXX: locate_gui.sh automatically detects *-application-merged directories
+ # This means what we install will vary depending on the contents of
+ # /etc/xdg, which is a QA violation. It is not clear how to resolve this.
+ XDG_DATA_HOME="/usr/share" XDG_CONFIG_HOME="/etc/xdg" \
+ "${ED}opt/cxoffice/bin/cxmenu" --destdir="${ED}" --crossover --install \
+ || die "Could not install menus"
+
+ rm "${ED}usr/share/applications/"*"Uninstall CrossOver Linux.desktop" \
+ || die "Could not remove uninstall menus"
+ sed -i \
+ -e "s:\"${ED}\".::" \
+ -e "s:${ED}::" \
+ "${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm" \
+ || die "Could not fix paths in ${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm"
+ sed -i -e "s:${ED}:/:" \
+ "${ED}usr/share/applications/"*"CrossOver.desktop" \
+ || die "Could not fix paths of *.desktop files"
+}
+
+pkg_postinst() {
+ einfo "${P} is open source software with the exception of the GUI."
+ einfo "Source code can be obtained from:"
+ einfo
+ einfo "https://media.codeweavers.com/pub/crossover/source/crossover-sources-${PV}.tar.gz"
+}
diff --git a/app-emulation/crossover-bin/metadata.xml b/app-emulation/crossover-bin/metadata.xml
index b1e0869e3e4c..fadaa124e17a 100644
--- a/app-emulation/crossover-bin/metadata.xml
+++ b/app-emulation/crossover-bin/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<use>
<flag name="capi">Enable ISDN support via CAPI</flag>
+ <flag name="opencl">Enable OpenCL support</flag>
</use>
</pkgmetadata>