summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-07 01:06:58 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-07 01:07:24 +0200
commitc649db1e6bef4fb2d6f5420dd1f6a52b847cc6bc (patch)
tree7ea92d6292cd77fda291cc1f41e14f4100987fd5 /app-emulation/docker-compose
parentapp-text/libmwaw: Drop old (diff)
downloadgentoo-c649db1e6bef4fb2d6f5420dd1f6a52b847cc6bc.tar.gz
gentoo-c649db1e6bef4fb2d6f5420dd1f6a52b847cc6bc.tar.bz2
gentoo-c649db1e6bef4fb2d6f5420dd1f6a52b847cc6bc.zip
app-emulation/docker-compose: Version bump to 1.12.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.12.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 4e032c7370bd..dffca81ef497 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -2,3 +2,4 @@ DIST docker-compose-1.10.0.tar.gz 165100 SHA256 3ff5179d9b2e39f1fc7216d1184e0304
DIST docker-compose-1.10.1.tar.gz 182052 SHA256 610768fe21bd8606c1fbbde50a4d70604dcb498dc9dfeb8de0c41a4e8db84293 SHA512 20acb31e601687bca06e20f66415ae9a52e186a78a87952a0f9393a64476de9dc3fac01e72269ee50150be76a58187a37728769abe79efe07b2ea830ee557e80 WHIRLPOOL c7ee9b363a96f44a898d7cc8d251a192c33d2dfc555feeb246bae1b7653b66fdb9ece02fc02572d646c7a10f4b681b0ffbb8b2902d0e99f0a689860edfacae9f
DIST docker-compose-1.11.1.tar.gz 185395 SHA256 509eeca9b95518fe9d3767ab0e0ffde5e33312fe02b2fec46e555078e7f07dd9 SHA512 4b1a5c54b28b1ba9546f78fbca153511e598d41b480aded12dde31691ec13e8253936ce5f0c608a726ad000d2ce0fde6a792e59b32013beb65b0f581eb8d4368 WHIRLPOOL 04cb53457fc93ac76a017efdfeb146716829cd9d35249bd93fafded305533b0eb5f60c37556a024b7eced26b4ec67b4a5d62c797ca3b1bed59b90173a1430d47
DIST docker-compose-1.11.2.tar.gz 186465 SHA256 e6cb8862f867d2882a93dd5bdcd3bf21dad5740c1ec1f32132c9a3801506ba54 SHA512 0b7668ee16738d9a898117737c8fb3de298fc0db2127b1a66f29469ab30ada609900498bb2906b63edd0cf2c469dd1db1e71756b1e620c44fd1aece37f60796b WHIRLPOOL 64a3629908185fb278e6dd780438edb27ab463e1b66f801e36c2a7fcf0d3913c23fbf41df775a7a843327e8016dd8e506b9243cd07b811c92f419883d5c6b839
+DIST docker-compose-1.12.0.tar.gz 198453 SHA256 3da6f465eac5704393d8acd95b1923ce0bda3f0312883527c92dfab7de5b313e SHA512 7d454b9a4210e4ec708d9b1b0e0eff58465f68747bac282c4163ee3abeb32f9907f32ac86fde56fbccb6af9927a61b68dd671263b5ded13a78a37e2ac4db2669 WHIRLPOOL e2dff82aadd5b3be56485a8e7743d50b3e6eac7cf1873f392df05354ad6716476cb4606532630cd309a673c0355b7910c93456af70341e153f5df3bf486f4bf6
diff --git a/app-emulation/docker-compose/docker-compose-1.12.0.ebuild b/app-emulation/docker-compose/docker-compose-1.12.0.ebuild
new file mode 100644
index 000000000000..55f1c9c5eb92
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.12.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ <dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.2.1[${PYTHON_USEDEP}]
+ <dev-python/docker-py-3.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}