summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-23 15:56:43 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-23 15:56:43 +0100
commit0b4daaa30907154c4f80875d5bf99604d233882e (patch)
tree123e09ef8c44fb7eccf084c2fe2b9d65a5489e63 /app-emulation/docker-proxy
parentsys-cluster/kubelet: Version bump to 1.9.6 (diff)
downloadgentoo-0b4daaa30907154c4f80875d5bf99604d233882e.tar.gz
gentoo-0b4daaa30907154c4f80875d5bf99604d233882e.tar.bz2
gentoo-0b4daaa30907154c4f80875d5bf99604d233882e.zip
app-emulation/docker-proxy: Update snapshot
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation/docker-proxy')
-rw-r--r--app-emulation/docker-proxy/Manifest1
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20180314.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/Manifest b/app-emulation/docker-proxy/Manifest
index 0849ac8772c2..c155a5bbe7b4 100644
--- a/app-emulation/docker-proxy/Manifest
+++ b/app-emulation/docker-proxy/Manifest
@@ -1,2 +1,3 @@
DIST docker-proxy-0.8.0_p20170917.tar.gz 2177045 BLAKE2B 0fed1328e8216ab83b23e8e1fe1793da6e874eced7ad18d101b0b7757f1de4fa7d321fb78620a349a4ed492abb4d85c3ecbf49311698b6af156a6255dec5740e SHA512 673ea638fa5c560d8238d7c1d88f114430f9d8efe701804bfe30044d0c059a688cbf6b62922be50834e16ee055ef6cf015f6232f76f0d942768f9e84e95496cd
DIST docker-proxy-0.8.0_p20180112.tar.gz 2679651 BLAKE2B aa134607a90029b41f12885876f175e0e4d77de7e23888912e561d2a75056a8b85f8bb31bfc27e5ddcb102d7d113720ecf4796d7c7d6f6a4c5db10c5f4c60915 SHA512 43d7a8259b5ee2f605ae07dfe64e25b90445b9d38b279a19366df64093dc7d16f3820e3cd67c8569292efc548334a278f1fcbcfb13aed3a73ba980309f8115c9
+DIST docker-proxy-0.8.0_p20180314.tar.gz 2692292 BLAKE2B 6d09750277691313f16ff48c14e2b8f706180dad0805b4874bfc7ed228e090ad1e5a1bdfe1555970424dfde78a31de3373c76c7417c6e5cabedf4da551e49934 SHA512 c33005f0281260a3dcc9dd567680068afbdb9ea6036b2847c9cd3d77e72d32e6b7d359178acbd4a2db7cc15cc53d99079a1b544bc32912dbf19f2babc670a2bd
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180314.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180314.ebuild
new file mode 100644
index 000000000000..7bbe3fc24b94
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180314.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="1b91bc94094ecfdae41daa465cc0c8df37dfb3dd"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RDEPEND="!<app-emulation/docker-1.13.0_rc1"
+
+RESTRICT="test" # needs dockerd
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}