summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-12-27 11:46:54 -0800
committerZac Medico <zmedico@gentoo.org>2015-12-27 11:48:13 -0800
commitf9a4febae09669da5bba525d066855a55a73cd5e (patch)
tree2f48782bf95589ac928bdffafc125eaff5f178ff /app-emulation/docker-swarm
parentnet-dns/bind-tools: Version bump. Fixes bug 563648 and bug 568982 (diff)
downloadgentoo-f9a4febae09669da5bba525d066855a55a73cd5e.tar.gz
gentoo-f9a4febae09669da5bba525d066855a55a73cd5e.tar.bz2
gentoo-f9a4febae09669da5bba525d066855a55a73cd5e.zip
app-emulation/docker-swarm: version bump to 1.0.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/docker-swarm')
-rw-r--r--app-emulation/docker-swarm/Manifest1
-rw-r--r--app-emulation/docker-swarm/docker-swarm-1.0.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/docker-swarm/Manifest b/app-emulation/docker-swarm/Manifest
index 8103b975b935..11b40d44caa3 100644
--- a/app-emulation/docker-swarm/Manifest
+++ b/app-emulation/docker-swarm/Manifest
@@ -1 +1,2 @@
DIST docker-swarm-0.4.0.tar.gz 853254 SHA256 c3ee1a34ce86da4d31f652c871dfa120fc78d5cc835e391034d740e83b48f7a3 SHA512 ffaa5560d67cafcc97b091d87b7792d6a0bfed2fb08837854a8313175742d535ee671fe45c4b96eeb69bf613a31e2e37cf92524f93ad20fbfbd54647b956c9c1 WHIRLPOOL 3acb07bfbcf33d70dffbfff4c5028767f36d51bd3500143d50e109d062cfd0107dfdc9f45724d08f874d81e15429089ed18a664fd591c26d7f2ff14ea933f93a
+DIST docker-swarm-1.0.1.tar.gz 1187966 SHA256 33c6566af395affbf9861d1491613c48a70e6c61c532910cef2210be7b1323f7 SHA512 ed5e6a37cd0f5a816367cab451d21ac20183f8ce767a30dc3086f849da8e0d2662c9f9b7e56d826e7e8cf5d4ec3d9f1ee8c159cca294af7ec45c2c1a21eaaf80 WHIRLPOOL e17705a3bef077e5fed552131aa7cd4891934a537dc93bbb8dfe81bf2e82c281d7f74a5150febdde26f492cf5ad4eec8417aac9a7edc6e48812f4af3ed1b624e
diff --git a/app-emulation/docker-swarm/docker-swarm-1.0.1.ebuild b/app-emulation/docker-swarm/docker-swarm-1.0.1.ebuild
new file mode 100644
index 000000000000..bb35aaeb8a82
--- /dev/null
+++ b/app-emulation/docker-swarm/docker-swarm-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_PN=github.com/docker/${PN##*-}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A Docker-native clustering system"
+HOMEPAGE="https://docs.docker.com/${PN##*-}/"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}/${P}/src/${EGO_PN%/*}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:${S}/Godeps/_workspace:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} -o ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md ROADMAP.md
+}