summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/dynamips
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/dynamips')
-rw-r--r--app-emulation/dynamips/Manifest2
-rw-r--r--app-emulation/dynamips/dynamips-0.2.12.ebuild48
-rw-r--r--app-emulation/dynamips/dynamips-0.2.14-r1.ebuild42
-rw-r--r--app-emulation/dynamips/files/0.2.14-docs.patch20
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch11
-rw-r--r--app-emulation/dynamips/metadata.xml15
6 files changed, 138 insertions, 0 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
new file mode 100644
index 000000000000..3c845b4e84a7
--- /dev/null
+++ b/app-emulation/dynamips/Manifest
@@ -0,0 +1,2 @@
+DIST dynamips-0.2.12-source.zip 995877 SHA256 b8a60c2ff577ec3a5c2b892bce654a68cc072c79fbca2b708d36d42bd3e9eb12 SHA512 08f388027e3234a44a75de77f30d6c96f0d881c4db60435a237f6ae6e3804872fda422ab11249f5c7283054f7d2d8466886dcd6056e59fc90802e67fa7cb8c55 WHIRLPOOL 2e627071914fe11ae20b7f00ba7b81b7bde95a008d84a1786e2f57ab07ec2a0d836218e72040b34f8badbefb289fceab2c5f7324bf5d5cfca0d433ed968dc6ae
+DIST dynamips-0.2.14-source.zip 961813 SHA256 ce77cf6e6e784142333d3b9dcc6c70ab7b1f676ff2a40b7d4fb738e14f01e789 SHA512 8c3d85998a61cae1e3e82501a00e886c954686f9a19a44acb7dee8b13911c0155ce2cdfecbdc41ed5d279266abdf77a5c3f2753fde12217b138313ffa46dabf8 WHIRLPOOL d20a78c701cdbb7f38c4e6f6848b5b3b0a80d8bef372cb13cc25c65d52652001e701f54d1e5a805e4279a4cf457f953387e7cbda124e9f4f57c8615296d8fc7e
diff --git a/app-emulation/dynamips/dynamips-0.2.12.ebuild b/app-emulation/dynamips/dynamips-0.2.12.ebuild
new file mode 100644
index 000000000000..f0dfa4d6f7df
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.gns3.net/dynamips/"
+SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ # enable verbose build
+ sed -i \
+ -e 's/@$(CC)/$(CC)/g' \
+ stable/Makefile || die 'sed on stable/Makefile failed'
+ # respect compiler
+ tc-export CC
+
+ epatch_user
+}
+
+src_compile() {
+ if use amd64 || use x86; then
+ emake DYNAMIPS_ARCH="${ARCH}"
+ else
+ emake DYNAMIS_ARCH="nojit"
+ fi
+}
+
+src_install () {
+ newbin dynamips.stable dynamips
+ newbin nvram_export.stable nvram_export
+ doman man/*
+ dodoc README README.hypervisor TODO
+}
diff --git a/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild b/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild
new file mode 100644
index 000000000000..cb86df7010a7
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.14-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.gns3.net/dynamips/"
+SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ipv6"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( ChangeLog README RELEASE-NOTES )
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}/${PV}-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable ipv6 IPV6)
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/dynamips/files/0.2.14-docs.patch b/app-emulation/dynamips/files/0.2.14-docs.patch
new file mode 100644
index 000000000000..1d744062e5b5
--- /dev/null
+++ b/app-emulation/dynamips/files/0.2.14-docs.patch
@@ -0,0 +1,20 @@
+--- CMakeLists-orig.txt 2014-11-28 14:51:14.375913296 +0900
++++ CMakeLists.txt 2014-11-28 14:52:09.579369288 +0900
+@@ -37,16 +37,6 @@
+ add_subdirectory ( stable )
+ add_subdirectory ( unstable )
+
+-install_docs (
+- "ChangeLog"
+- "COPYING"
+- "MAINTAINERS"
+- "README"
+- "README.hypervisor"
+- "RELEASE-NOTES"
+- "TODO"
+- )
+-
+ # uninstall target - leaves behind any directory created during install
+ set ( _templatefile "${CMAKE_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in" )
+ set ( _scriptfile "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake" )
+
diff --git a/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch
new file mode 100644
index 000000000000..431f2df8ac74
--- /dev/null
+++ b/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch
@@ -0,0 +1,11 @@
+--- stable/origMakefile 2014-03-27 18:17:28.000000000 -0400
++++ stable/Makefile 2014-05-30 18:07:28.164255039 -0400
+@@ -19,7 +19,7 @@
+ PPC32_ARCH_INC_FILE=\"ppc32_$(DYNAMIPS_ARCH)_trans.h\"
+ OSNAME=unknown
+
+-CFLAGS+= $(INCLUDE) -Wall -O2 -fomit-frame-pointer \
++CFLAGS+= $(INCLUDE) -Wall \
+ -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
+ -DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
+ -DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \
diff --git a/app-emulation/dynamips/metadata.xml b/app-emulation/dynamips/metadata.xml
new file mode 100644
index 000000000000..c9d9b3355675
--- /dev/null
+++ b/app-emulation/dynamips/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gns-3</remote-id>
+ </upstream>
+</pkgmetadata>