summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-07-22 10:37:35 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2016-07-22 10:37:35 +0200
commitb34ead896b11b268b16d9fae8144596a7cda41c1 (patch)
treef83b788b477c8cf738c03b3dfdc43912d833da0d /app-emulation/free42
parentmask ruby20-only packages for removal (diff)
downloadgentoo-b34ead896b11b268b16d9fae8144596a7cda41c1.tar.gz
gentoo-b34ead896b11b268b16d9fae8144596a7cda41c1.tar.bz2
gentoo-b34ead896b11b268b16d9fae8144596a7cda41c1.zip
app-emulation/free42: Bump to version 1.5.8
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/free42')
-rw-r--r--app-emulation/free42/Manifest1
-rw-r--r--app-emulation/free42/files/free42-1.5.8-fix-makefile.patch29
-rw-r--r--app-emulation/free42/free42-1.5.8.ebuild46
3 files changed, 76 insertions, 0 deletions
diff --git a/app-emulation/free42/Manifest b/app-emulation/free42/Manifest
index a164de1eafcc..99606ea3c735 100644
--- a/app-emulation/free42/Manifest
+++ b/app-emulation/free42/Manifest
@@ -1,2 +1,3 @@
DIST free42-1.5.5.tgz 8160228 SHA256 2c5a16aa470de76185135c307add9b920a712e31269c471dd246b6cf9283e050 SHA512 97833c99a24c2b1f427b237469868d57734b919b6c69521b45de480bd5274f5427caac13b9ccf3b79674d63dabdeda58a8db4c23a184b72b04279acbdf7eff8f WHIRLPOOL d435befbf2d392222d1ef7907c7913e474da5c4997dfb84177be3ea0b3fc1d9c9b0ea41590810e78d38eb082216b28c907fe39613823d866b6a1ab4d531a6af2
DIST free42-1.5.7.tgz 8159655 SHA256 63c868880e0c18374f4b309dc19e2ea36b9463471d2d77563f53036eea645316 SHA512 fb18712643f73388512fc4dc069d55ef3597f5e6a4e1b47bcd12ab05224027c4ec981ade2398fd8c1e4534003ee6c4de2b7402bade66a3dbe90a46299e7132a3 WHIRLPOOL 0504da8589d3dbf9270a914b2cb6ad86982b926f40abee43d6bbe3f8ec997efe8b0ae50b9d61952e5acd3f2a70d34e16cf0e665cec06d555b0c92438c7a32a43
+DIST free42-1.5.8.tgz 45400324 SHA256 f8ffa54a5f77b5061e1a983962e989fc6679f7e128d996a0550922e366855f2f SHA512 1abaeea314b55f456b65eef530fe692534d92dde95876982c6df1715853055632a4a2305774dc691ca0af28632a393d8d9872bd86353c09d57d2dc8a0ef6cfe2 WHIRLPOOL 9b0abef9d548f09e567e8debe15f9a0635038d6ef655a64885ebc02eb241a0f577ca40b4bdc39c881fe8b2c6f4d97e5575c715a05ccc06df37f90bc5d28d16e8
diff --git a/app-emulation/free42/files/free42-1.5.8-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.8-fix-makefile.patch
new file mode 100644
index 000000000000..08742329a337
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.8-fix-makefile.patch
@@ -0,0 +1,29 @@
+diff -Nuar a/gtk/Makefile b/gtk/Makefile
+--- a/gtk/Makefile 2016-04-27 06:04:12.000000000 +0200
++++ b/gtk/Makefile 2016-07-22 10:33:06.730040039 +0200
+@@ -19,7 +19,6 @@
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+- -g \
+ -I/usr/X11R6/include \
+ -fno-exceptions \
+ -fno-rtti \
+@@ -30,13 +29,14 @@
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+-LDFLAGS = -L/usr/X11R6/lib
++LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
+ ifeq "$(shell uname -s)" "Darwin"
+ LIBS := gcc111libbid-mac-x64.a -lXmu $(shell pkg-config --libs gtk+-2.0)
+ else
+-LIBS := gcc111libbid-$(shell uname -m).a -lXmu $(shell pkg-config --libs gtk+-2.0)
++LIBS := gcc111libbid-$(shell uname -m).a -lXmu -lX11 -ldl -lpthread $(shell pkg-config --libs gtk+-2.0)
+ endif
+
+ ifeq "$(shell uname -s)" "Linux"
diff --git a/app-emulation/free42/free42-1.5.8.ebuild b/app-emulation/free42/free42-1.5.8.ebuild
new file mode 100644
index 000000000000..90f4f0ea6737
--- /dev/null
+++ b/app-emulation/free42/free42-1.5.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="http://thomasokken.com/free42/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXmu"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e 's/print_gif_name\[FILENAMELEN\]/print_gif_name\[1000\]/' \
+ "${S}/gtk/shell_main.cc" || die
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
+}
+
+src_install() {
+ dodoc CREDITS HISTORY README TODO
+ dobin gtk/free42dec
+}