summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/libspectrum
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/libspectrum')
-rw-r--r--app-emulation/libspectrum/Manifest2
-rw-r--r--app-emulation/libspectrum/libspectrum-1.0.0.ebuild42
-rw-r--r--app-emulation/libspectrum/libspectrum-1.1.1.ebuild42
-rw-r--r--app-emulation/libspectrum/metadata.xml28
4 files changed, 114 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/Manifest b/app-emulation/libspectrum/Manifest
new file mode 100644
index 000000000000..44fd1be27e99
--- /dev/null
+++ b/app-emulation/libspectrum/Manifest
@@ -0,0 +1,2 @@
+DIST libspectrum-1.0.0.tar.gz 462552 SHA256 cdf8f5006676c0f68939e331eeadeda5d608d777f1234b080b97f677f1dd287c SHA512 1ed3e36e9d62d69b470e959509d2a56e5a3608a9ea9f3f6f0ddd78e4f5f4a75da957e4120a0ffdf6366c3e90e148de9d83954fc711414389687e55bbc91f1bc8 WHIRLPOOL bf245f20181c82bae9e985e230729c3f341134f84239d82133231b2de5d8fe61533a1e11a9004b6d5a0971bdd97622ba453912522c66292b82715a5a937d351b
+DIST libspectrum-1.1.1.tar.gz 502942 SHA256 178d3607af2109b6b8dafac4f91912745b9f3c087319945c3a886bb7fe7989d5 SHA512 61197c8d1d6b4b595b55cf7e8f8c43423935291a9fbc688f1bb06d4c3ef53dbcf391a96f0528443518c2ca2d6fe187ee56d5ed915702f13a16ad44aa16037f49 WHIRLPOOL c89c7c3183f9d960dcedf789c763687e66cdaea1b2c41fdd41c1f1b0484cc9039790415bf8f231ff2bea0914fe2ababfd6d174338141bee13859521bf73caa92
diff --git a/app-emulation/libspectrum/libspectrum-1.0.0.ebuild b/app-emulation/libspectrum/libspectrum-1.0.0.ebuild
new file mode 100644
index 000000000000..a0455acbd775
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="audiofile bzip2 gcrypt zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( >=app-arch/bzip2-1.0 )
+ >=dev-libs/glib-2
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ audiofile? ( >=media-libs/audiofile-0.2.3 )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-glib \
+ $(use_with zlib zlib) \
+ $(use_with bzip2 bzip2) \
+ $(use_with audiofile libaudiofile) \
+ $(use_with gcrypt libgcrypt) \
+ || die "econf failed!"
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Make install failed"
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+ doman doc/libspectrum.3
+}
diff --git a/app-emulation/libspectrum/libspectrum-1.1.1.ebuild b/app-emulation/libspectrum/libspectrum-1.1.1.ebuild
new file mode 100644
index 000000000000..509cc383833a
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-1.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="audiofile bzip2 gcrypt zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( >=app-arch/bzip2-1.0 )
+ >=dev-libs/glib-2
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ audiofile? ( >=media-libs/audiofile-0.2.3 )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-glib \
+ $(use_with zlib zlib) \
+ $(use_with bzip2 bzip2) \
+ $(use_with audiofile libaudiofile) \
+ $(use_with gcrypt libgcrypt) \
+ || die "econf failed!"
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Make install failed"
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+ doman doc/libspectrum.3
+}
diff --git a/app-emulation/libspectrum/metadata.xml b/app-emulation/libspectrum/metadata.xml
new file mode 100644
index 000000000000..1995e4955b86
--- /dev/null
+++ b/app-emulation/libspectrum/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ <description>Proxy Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>jmfo1982@yahoo.es</email>
+ <description>Proxied Maintainer. Please CC on bugs.</description>
+ <name>José Manuel Ferrer Ortiz</name>
+ </maintainer>
+ <longdescription>
+libspectrum is a library designed to make the input and output of some ZX
+Spectrum emulator files slightly easier. It is intended to be usable on Unix
+variants, Win32 and Mac OS X. Currently, it is mainly (only?) used by Fuse,
+but other Spectrum emulator and utility authors are encouraged to use it.
+</longdescription>
+ <use>
+ <flag name="gcrypt">Use <pkg>dev-libs/libgcrypt</pkg> for low-level crypto of some
+ features, including logfiles.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">fuse-emulator</remote-id>
+ </upstream>
+</pkgmetadata>