summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-26 15:51:53 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-26 16:31:28 -0400
commit48462978f96b6a32a1faee1bc5f6a4beaeb46d56 (patch)
tree2c43f7da4087bd6018642da58adeb38101b08c4f /app-emulation/phpvirtualbox
parentapp-vim/omnicppcomplete: bump EAPI (diff)
downloadgentoo-48462978f96b6a32a1faee1bc5f6a4beaeb46d56.tar.gz
gentoo-48462978f96b6a32a1faee1bc5f6a4beaeb46d56.tar.bz2
gentoo-48462978f96b6a32a1faee1bc5f6a4beaeb46d56.zip
app-emulation/phpvirtualbox: drop EAPI=2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation/phpvirtualbox')
-rw-r--r--app-emulation/phpvirtualbox/Manifest1
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/app-emulation/phpvirtualbox/Manifest b/app-emulation/phpvirtualbox/Manifest
index 8b33c5721846..ede7ee5154ad 100644
--- a/app-emulation/phpvirtualbox/Manifest
+++ b/app-emulation/phpvirtualbox/Manifest
@@ -1,4 +1,3 @@
-DIST phpvirtualbox-4.1-11.zip 2763347 BLAKE2B 3132373e012089663cbb6d2142e12e50660b80368beca007394914cf769c6ce58d7412fe449695c3081f26bd552b04b73e3a369d74a525188561908dda108122 SHA512 c5eb1b9fd0bba20e3dda9cbe6985c60d953a340d77b9427f344e8b595a06a5d9805209cf73704fb93de5ee2f412e02cb1434ed0e983b0622cf8a8172d7dff9a5
DIST phpvirtualbox-4.2-7.zip 3425805 BLAKE2B c5e9bb629b346af378ee585b940c2f41cef4025caef66809212bab2f5cfd6621e3980fc2c7e5a9140fb3d16545df81af452d6733f2a3ba8f6f23d1a914472b6f SHA512 a066f127115a83c6061e8c0ff6447464818511f3ab7805c119f75ddc88459efd144d45fb358ce52959301f2f1a4f2609f7f42c2bb24213a5be98f2036085a81b
DIST phpvirtualbox-4.3-0.zip 4231805 BLAKE2B 8f9c995c3c7112b6ec73a49b322f210ae2befcd711ac9459ea0eea9a7216c2e3322489ada69a91940af76a276a8c053384e0632b209250c7b3ca37291a574e57 SHA512 fd49a6a4c79d75f37fd40d74743f295a148548373ab046cf1f31ef7b982008ea6b9d2838cdad2dc37a1d266ed630cd2ddb7f7423ea62af1e0f8f9f76a12c0e9d
DIST phpvirtualbox-5.0-3.zip 4092132 BLAKE2B c781b9d49ed20fb2748a7aa7d8685d5f2c10ba72268e6bbdb53a041873c6390605376a09bc4a7cfd5cca3de9d3045c60a2e515668ba1d5f49b623aee9e5cf568 SHA512 b632ff3be2028bd011ce27b580996638dfc89e09350c459f16bd1c8c5c3eefbab93f42d7facfb99279eb2ee1c6a38854ea999654ca2090a39c7bfa0afa7fe2d5
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
deleted file mode 100644
index de7e19448c92..000000000000
--- a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit versionator eutils webapp
-
-MY_PV="$(replace_version_separator 2 '-')"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Web-based administration for VirtualBox in PHP"
-HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
-SRC_URI="https://${PN}.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-lang/php[session,unicode,soap,gd]
- virtual/httpd-php
-"
-DEPEND="app-arch/unzip"
-
-src_install() {
- webapp_src_preinst
-
- cd ${MY_P}
-
- dodoc CHANGELOG.txt LICENSE.txt README.txt || die
- rm -f CHANGELOG.txt LICENSE.txt README.txt
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
- webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
-
- webapp_src_install
- if has_version app-emulation/virtualbox[vboxwebsrv] || \
- has_version app-emulation/virtualbox-bin[vboxwebsrv]
- then
- newinitd "${FILESDIR}"/vboxinit-initd vboxinit
- fi
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- elog "Local or remote virtualbox hosts must be compiled with"
- elog "'vboxwebsrv' useflag and the respective init script"
- elog "must be running to use this interface"
- elog " /etc/init.d/vboxwebsrv start"
- elog
- elog "To enable the automatic startup mode feature uncomment the"
- elog "following line in the config.php file:"
- elog " var \$startStopConfig = true;"
- elog
- elog "You should also add the /etc/init.d/vboxinit script to the"
- elog "default runlevel on the virtualbox host:"
- elog "\`rc-update add vboxinit default\`"
- elog "If the server is on a remote host, than the script must be"
- elog "copied manually from"
- elog "${FILESDIR}/vboxinit-initd to /etc/init.d/vboxinit"
- elog "on the remote host."
-}