summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/rex-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/rex-client')
-rw-r--r--app-emulation/rex-client/metadata.xml8
-rw-r--r--app-emulation/rex-client/rex-client-9999.ebuild46
2 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/rex-client/metadata.xml b/app-emulation/rex-client/metadata.xml
new file mode 100644
index 000000000000..3b15722d898d
--- /dev/null
+++ b/app-emulation/rex-client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+
diff --git a/app-emulation/rex-client/rex-client-9999.ebuild b/app-emulation/rex-client/rex-client-9999.ebuild
new file mode 100644
index 000000000000..8eea78563fc8
--- /dev/null
+++ b/app-emulation/rex-client/rex-client-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Remote EXexcution agent"
+HOMEPAGE="http://mduft.github.io/rex/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mduft/rex.git"
+else
+ SRC_URI=""
+ KEYWORDS="~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+REX_EXE=(
+ "client/rex-exec.sh"
+ "client/rex-register.sh"
+ "client/rex-paths.sh"
+ "client/rex-remote-pconv.sh"
+ "client/winpath2unix"
+ "client/unixpath2win"
+ )
+
+src_prepare() {
+ for x in ${REX_EXE[@]}; do
+ sed \
+ -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" \
+ -i "${x}" || die
+ done
+}
+
+src_install() {
+ for x in ${REX_EXE[@]}; do
+ dobin "${S}"/${x}
+ done
+
+ insinto /etc
+ newins client/rex-config.sh rex.conf
+}