summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai-Chieh Ku <kjackie@gmail.com>2016-09-30 14:13:17 +0800
committerZac Medico <zmedico@gentoo.org>2016-10-01 16:54:00 -0700
commit85c21c5a864d61a8f9fe8b4be77eb1a32eb5e78c (patch)
treef82a75e4da30ae2e3b2a91b0956372758117a78e /app-emulation/rkt/rkt-1.15.0.ebuild
parentdev-lang/php: remove old versions php-5.6.2[345]. (diff)
downloadgentoo-85c21c5a864d61a8f9fe8b4be77eb1a32eb5e78c.tar.gz
gentoo-85c21c5a864d61a8f9fe8b4be77eb1a32eb5e78c.tar.bz2
gentoo-85c21c5a864d61a8f9fe8b4be77eb1a32eb5e78c.zip
app-emulation/rkt: install bash-completion
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/rkt/rkt-1.15.0.ebuild')
-rw-r--r--app-emulation/rkt/rkt-1.15.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/rkt/rkt-1.15.0.ebuild b/app-emulation/rkt/rkt-1.15.0.ebuild
index 268d8080889a..62861b0d55ce 100644
--- a/app-emulation/rkt/rkt-1.15.0.ebuild
+++ b/app-emulation/rkt/rkt-1.15.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit autotools flag-o-matic systemd toolchain-funcs user
+inherit bash-completion-r1 autotools flag-o-matic systemd toolchain-funcs user
KEYWORDS="~amd64"
@@ -197,6 +197,7 @@ src_compile() {
amd64) arch=x86_64;;
esac
ARCH=${arch} emake
+ ARCH=${arch} emake bash-completion
}
src_install() {
@@ -230,6 +231,8 @@ src_install() {
systemd_dounit "${S}"/dist/init/systemd/${PN}-metadata.service
systemd_dounit "${S}"/dist/init/systemd/${PN}-metadata.socket
+ newbashcomp "${S}"/dist/bash_completion/rkt.bash rkt
+
keepdir /etc/${PN}
fowners :rkt-admin /etc/${PN}
fperms 2775 /etc/${PN}