summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-02-10 18:19:31 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-02-10 18:19:41 +0000
commit61c8f46603cf3cbfd570f58d9d4ffdc2ae0b49f3 (patch)
tree0e15044ef7b6bc04dd6acb748a599bd830ee6534 /app-emulation/ski/ski-1.3.2-r2.ebuild
parentsys-cluster/teleport: remove unused patch (diff)
downloadgentoo-61c8f46603cf3cbfd570f58d9d4ffdc2ae0b49f3.tar.gz
gentoo-61c8f46603cf3cbfd570f58d9d4ffdc2ae0b49f3.tar.bz2
gentoo-61c8f46603cf3cbfd570f58d9d4ffdc2ae0b49f3.zip
app-emulation/ski: drop USE=gtk support, bug #644316
Closes: https://bugs.gentoo.org/644316 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation/ski/ski-1.3.2-r2.ebuild')
-rw-r--r--app-emulation/ski/ski-1.3.2-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/ski/ski-1.3.2-r2.ebuild b/app-emulation/ski/ski-1.3.2-r2.ebuild
new file mode 100644
index 000000000000..389d021a5d24
--- /dev/null
+++ b/app-emulation/ski/ski-1.3.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="ia64 instruction set simulator"
+HOMEPAGE="http://ski.sourceforge.net/ http://www.gelato.unsw.edu.au/IA64wiki/SkiSimulator"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="motif"
+
+RDEPEND="dev-libs/libltdl:0=
+ sys-libs/ncurses:0=
+ virtual/libelf
+ motif? ( x11-libs/motif:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ dev-util/gperf"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-syscall-linux-includes.patch
+ "${FILESDIR}"/${P}-remove-hayes.patch
+ "${FILESDIR}"/${P}-no-local-ltdl.patch
+ "${FILESDIR}"/${P}-AC_C_BIGENDIAN.patch
+ "${FILESDIR}"/${P}-configure-withval.patch
+ "${FILESDIR}"/${P}-binutils.patch
+ "${FILESDIR}"/${P}-uselib.patch #592226
+ "${FILESDIR}"/${P}-ncurses-config.patch
+ "${FILESDIR}"/${P}-prototypes.patch
+)
+
+src_prepare() {
+ default
+
+ rm -rf libltdl src/ltdl.[ch] macros/ltdl.m4
+
+ AT_M4DIR="macros" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-included-ltdl \
+ --without-gtk \
+ $(use_with motif x11)
+}