summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-09-09 18:58:17 +0200
committerAmy Liffey <amynka@gentoo.org>2017-09-21 16:50:07 +0200
commit1411589ad05f44a6ec3fd7748c4a58769e7db364 (patch)
tree492508a9c628fcd45060b2445728b1e7cdc82254 /app-emulation/vagrant
parentmedia-sound/qtgain: remove bogus dependency (diff)
downloadgentoo-1411589ad05f44a6ec3fd7748c4a58769e7db364.tar.gz
gentoo-1411589ad05f44a6ec3fd7748c4a58769e7db364.tar.bz2
gentoo-1411589ad05f44a6ec3fd7748c4a58769e7db364.zip
app-emulation/vagrant: add version bump 2.0.0
Closes:#5673 Closes: https://bugs.gentoo.org/630498 Gentoo-Bug: 630498
Diffstat (limited to 'app-emulation/vagrant')
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.0.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 32e8cdd095b0..34dfc7b94127 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,2 +1,3 @@
DIST vagrant-1.9.7.tar.gz 1119024 SHA256 194de72442a2d08f6e04fbed8698a99d190a0e7203d35b49e80d4ddfcb71fb1b SHA512 062921070ace7ce93145981b5b768dc9dc447559fc12c52c8da323d1e3523fbff2a8e7afca0e2f751e232aae822c969b5d166b3b0f01a0744ca20c4e4e33567f WHIRLPOOL ef0331781cf6a71dca9eb485943c459a5360f55b1db45b4f23b413b848eeac1700afe3ea51b6dd2e0da1a7c1ba6ad456bd9fcb7a7b3532145e95a38fc997dd99
DIST vagrant-1.9.8.tar.gz 1127560 SHA256 59c1d50437d2f50eeae219bc03c90d397fe8d8c974cce7c51b017b8ceeaefb54 SHA512 d22cc0a6800aa5ef84085c750f5ec8729f7b3adefd9a5df1a1fcaf60d1219e781869ede4f57ce4fdeb269224603dfc3a8024545a0250ebd9e144745ce9aa670b WHIRLPOOL d9c199322798e792a895aef03f729b4db8bb5eb3eaab960092d5aa2831032106a9f55ac3957b43378cceea2d27cf53f8ecf6ff38ff54ff2f8c4451c0238029ee
+DIST vagrant-2.0.0.tar.gz 1142850 SHA256 c25d3a5f18abdf349047f4d80bb74e6cb526959536e4bef5aa771de9d39cb260 SHA512 ee9059dfd205253d6f978fd225d85eef5a281532a1992bc9382eb713c95a0280d4b6518460106227237ae4e93cf5e2eaf670bd378627c3e9696b0fe9a2427ac1 WHIRLPOOL 8337800f6c5cc88081dc6f8630de60ecba8c851687d14143f34dc41b62cbd67b1e463f7351ecc0e1c764742004fdba389bc33c0bb2a5c043d1fbf6dde352171c
diff --git a/app-emulation/vagrant/vagrant-2.0.0.ebuild b/app-emulation/vagrant/vagrant-2.0.0.ebuild
new file mode 100644
index 000000000000..5b4b6f8b77d5
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.0.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/erubis-2.7.0
+ <dev-ruby/i18n-0.8.0:*
+ >=dev-ruby/listen-3.1.5
+ >=dev-ruby/hashicorp-checkpoint-0.1.1
+ >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
+ >=dev-ruby/net-ssh-4.1.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
+ >=dev-ruby/nokogiri-1.7.1
+ <dev-ruby/mime-types-3:*
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-12.0.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ # disable embedded CA certs and use system ones
+ eapply "${FILESDIR}/${PN}-1.8.1-disable-embedded-cacert.patch"
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ newbashcomp contrib/bash/completion.sh ${PN}
+ all_fakegem_install
+
+ # provide executable similar to upstream:
+ # https://github.com/mitchellh/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ dodir /var/lib/vagrant
+}