summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-15 21:50:55 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-29 21:28:21 -0800
commitca761d4a7e63b3b15a48ee541e3d15c9cef3463a (patch)
tree39190b529f493a1378932585a735e89226511130 /app-emulation/vagrant
parentdev-ruby/vagrant_cloud: new package (diff)
downloadgentoo-ca761d4a7e63b3b15a48ee541e3d15c9cef3463a.tar.gz
gentoo-ca761d4a7e63b3b15a48ee541e3d15c9cef3463a.tar.bz2
gentoo-ca761d4a7e63b3b15a48ee541e3d15c9cef3463a.zip
app-emulation/vagrant: version bump to 2.2.2
Closes: https://github.com/gentoo/gentoo/pull/10429 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation/vagrant')
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.2.2.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 45ea3ce1c326..03a22b8ca6d5 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,3 +1,4 @@
DIST vagrant-2.1.1.tar.gz 1204711 BLAKE2B 88a6254091104eed702e07a4203a264b883869fb028b8d30fd51ddfc2053aec363683a2e73d1454ce92b705440920d5c80c0f967e4dc110bf425ce17973efccd SHA512 6cc82b4c33b196fce2bc460447afd152e53c3c17b45db5d80958ff631f6747c386b625ff26e3d8830a88b2feca82d550ad1de32e7c7607dffb25960af43092f5
DIST vagrant-2.1.2.tar.gz 1218801 BLAKE2B 742f27ca6c28c9738c09ef61c742be07121b5a804fa401115520633e5840c62c8e879fae078c5532704f6f6f7d7a9081d48e3f7570cfe6e6dd84f8df244a34ae SHA512 d9a2612697842885d23d1a9a452ef9d8b03defa4e6f7a808725ac7c3a87300affcfdd89ee3a42334259601e19f1e56bfd86a5aa7b404eac26bc22dcfd4a57751
DIST vagrant-2.1.5.tar.gz 1238788 BLAKE2B 8e3dfeb4d830fde1984c08b16422c99b51ce455fcc63e1fad0eca7860efccbf2e77edc13537bfa495345e585b559fe5462ae872decce036b45c1f54c453983ea SHA512 544216eb25c06a1ebddbadcc9d2d6a6dd9932e33d2554e3d51dba0e24a339b9afe0b85d1322bdb67c5de3d070aa4c854f1ccc931b23ea80f0625eb4d1f120238
+DIST vagrant-2.2.2.tar.gz 1223645 BLAKE2B 595d26a11f27a23a9e66386820dec7c23fbafe079e9e9750e7cbc928cac2e965782abbb062f6b04efd367b56297d040af2b4f4f56d6df06e604f018110e10329 SHA512 70c83fcd896ae3b84fac22c539eb85db9bf08c8f75108d5f2b86841821cf7a885b72565814519b6f2ef3422d84d2f67fc402b983b1a15c1edfd0dc78196cd957
diff --git a/app-emulation/vagrant/vagrant-2.2.2.ebuild b/app-emulation/vagrant/vagrant-2.2.2.ebuild
new file mode 100644
index 000000000000..ebed665ac9a0
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.2.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.0.0
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/ed25519-1.2.4
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.1.1:*
+ >=dev-ruby/listen-3.1.5
+ >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
+ <dev-ruby/mime-types-3:*
+ >=dev-ruby/net-ssh-5.0.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
+ >=dev-ruby/rubyzip-1.2.2
+ >=dev-ruby/vagrant_cloud-2.0.0
+"
+
+# upstream specifies rake>=12 but it apparently doesn't need something this
+# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
+# is tricky, we specify a lower dependency requirement here. This way, we'll be
+# able to stabilize vagrant sooner.
+ruby_add_bdepend "
+ >=dev-ruby/rake-10.5.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+}