summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-18 20:27:46 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-18 20:27:46 -0700
commitff3405ff6ce995c680819e26126d6718e8e1e3eb (patch)
treeeded11b6122d07fe1d27e3efedf7c8b26e914b23 /app-emulation/vagrant
parentapp-emulation/vagrant: bump to 2.2.9 (diff)
downloadgentoo-ff3405ff6ce995c680819e26126d6718e8e1e3eb.tar.gz
gentoo-ff3405ff6ce995c680819e26126d6718e8e1e3eb.tar.bz2
gentoo-ff3405ff6ce995c680819e26126d6718e8e1e3eb.zip
app-emulation/vagrant: drop 2.2.6
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation/vagrant')
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/files/support-vbox-6.1.patch75
-rw-r--r--app-emulation/vagrant/vagrant-2.2.6-r1.ebuild92
3 files changed, 0 insertions, 168 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 826fa92c6526..d686f4587be4 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,3 +1,2 @@
-DIST vagrant-2.2.6.tar.gz 1285530 BLAKE2B 802537b56429366ab0dab08d5490f2a5c1ec3810e9c04573ccd11f27078fc375f092ed70b27a7846813cbde5fdce0aa90399eba07e19a9d6ae7e11cb47204efe SHA512 6d8b5b1d4e5cc482404cf4c59e1b7cf9502a9819569b5098e44874733cee706f26adb4ac7994abe7e3307ca69d3003e2604dc859ce460c53d766d78b8d9fe22a
DIST vagrant-2.2.7.tar.gz 2173893 BLAKE2B bf905cb25a905e4fb79ce9c1fb59ad5520b5176d5681dfdc22855ca0a7520535346d2aebffe47162a1f8ca008083c94426e9de92b6d92de4373c654784605c7e SHA512 3455b74c8a867ab37ca9873187a98cdb80feb22a400c4e9f2266897da815815aaefbe0c166172b1c1dbd66aa49ccb1201dcbf904fd883ad34218d694e20d7f87
DIST vagrant-2.2.9.tar.gz 2215868 BLAKE2B 6d40827c91c86f6b11865d9949e5313c419456c573686944ecd0d1874323aa81d6f26178d5b7a16fee701c513a98b3483dbea0531d9d77dee7b7e284004e17b3 SHA512 15e230bcf336615f0d49a2c40db36f7f26a9f0f6fd42d2ce801f28afc663aadded4fa373e33f9102b21ee70d98563fc68e2b24ffa6c3eec321f58b2c42b0d260
diff --git a/app-emulation/vagrant/files/support-vbox-6.1.patch b/app-emulation/vagrant/files/support-vbox-6.1.patch
deleted file mode 100644
index 59a546302799..000000000000
--- a/app-emulation/vagrant/files/support-vbox-6.1.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From fb4e6985e142da56bad143d70600cd3695c91757 Mon Sep 17 00:00:00 2001
-From: Brian Cain <bcain@hashicorp.com>
-Date: Wed, 11 Dec 2019 13:25:11 -0800
-Subject: [PATCH] Fixes #11249: Add VirtualBox provider support for version
- 6.1.x
-
-This commit adds support for VirtualBox version 6.1.x. It simply
-inherits from the base 6.0.x provider class.
----
- plugins/providers/virtualbox/driver/meta.rb | 1 +
- .../providers/virtualbox/driver/version_6_1.rb | 16 ++++++++++++++++
- plugins/providers/virtualbox/plugin.rb | 1 +
- website/source/docs/virtualbox/index.html.md | 2 +-
- 4 files changed, 19 insertions(+), 1 deletion(-)
- create mode 100644 plugins/providers/virtualbox/driver/version_6_1.rb
-
-diff --git a/plugins/providers/virtualbox/driver/meta.rb b/plugins/providers/virtualbox/driver/meta.rb
-index 24547b4044..ed013737b0 100644
---- a/plugins/providers/virtualbox/driver/meta.rb
-+++ b/plugins/providers/virtualbox/driver/meta.rb
-@@ -64,6 +64,7 @@ def initialize(uuid=nil)
- "5.1" => Version_5_1,
- "5.2" => Version_5_2,
- "6.0" => Version_6_0,
-+ "6.1" => Version_6_1,
- }
-
- if @@version.start_with?("4.2.14")
-diff --git a/plugins/providers/virtualbox/driver/version_6_1.rb b/plugins/providers/virtualbox/driver/version_6_1.rb
-new file mode 100644
-index 0000000000..ebe417eb91
---- /dev/null
-+++ b/plugins/providers/virtualbox/driver/version_6_1.rb
-@@ -0,0 +1,16 @@
-+require File.expand_path("../version_6_0", __FILE__)
-+
-+module VagrantPlugins
-+ module ProviderVirtualBox
-+ module Driver
-+ # Driver for VirtualBox 6.1.x
-+ class Version_6_1 < Version_6_0
-+ def initialize(uuid)
-+ super
-+
-+ @logger = Log4r::Logger.new("vagrant::provider::virtualbox_6_1")
-+ end
-+ end
-+ end
-+ end
-+end
-diff --git a/plugins/providers/virtualbox/plugin.rb b/plugins/providers/virtualbox/plugin.rb
-index e058ec65ad..f2fbf47e55 100644
---- a/plugins/providers/virtualbox/plugin.rb
-+++ b/plugins/providers/virtualbox/plugin.rb
-@@ -59,6 +59,7 @@ module Driver
- autoload :Version_5_1, File.expand_path("../driver/version_5_1", __FILE__)
- autoload :Version_5_2, File.expand_path("../driver/version_5_2", __FILE__)
- autoload :Version_6_0, File.expand_path("../driver/version_6_0", __FILE__)
-+ autoload :Version_6_1, File.expand_path("../driver/version_6_1", __FILE__)
- end
-
- module Model
-diff --git a/website/source/docs/virtualbox/index.html.md b/website/source/docs/virtualbox/index.html.md
-index 558ef5f5d8..e9c1e79aad 100644
---- a/website/source/docs/virtualbox/index.html.md
-+++ b/website/source/docs/virtualbox/index.html.md
-@@ -13,7 +13,7 @@ Vagrant comes with support out of the box for [VirtualBox](https://www.virtualbo
- a free, cross-platform consumer virtualization product.
-
- The VirtualBox provider is compatible with VirtualBox versions 4.0.x, 4.1.x,
--4.2.x, 4.3.x, 5.0.x, 5.1.x, 5.2.x, and 6.0.x. Other versions are unsupported and the provider
-+4.2.x, 4.3.x, 5.0.x, 5.1.x, 5.2.x, 6.0.x, and 6.1.x. Other versions are unsupported and the provider
- will display an error message. Please note that beta and pre-release versions
- of VirtualBox are not supported and may not be well-behaved.
-
diff --git a/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
deleted file mode 100644
index c7b3242780a4..000000000000
--- a/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/bcrypt_pbkdf-1.0.0
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/ed25519-1.2.4
- >=dev-ruby/erubis-2.7.0
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/i18n-1.1.1:1
- >=dev-ruby/listen-3.1.5
- <dev-ruby/log4r-1.1.11
- <dev-ruby/mime-types-3:*
- >=dev-ruby/net-ssh-5.1.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- dev-ruby/rest-client:2
- >=dev-ruby/rubyzip-1.2.2:*
- >=dev-ruby/vagrant_cloud-2.0.3
-"
-
-# upstream specifies rake>=12 but it apparently doesn't need something this
-# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
-# is tricky, we specify a lower dependency requirement here. This way, we'll be
-# able to stabilize vagrant sooner.
-ruby_add_bdepend "
- >=dev-ruby/rake-10.5.0
-"
-
-PATCHES="${FILESDIR}/support-vbox-6.1.patch"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp contrib/bash/completion.sh ${PN}
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-
- insinto /usr/share/vim/vimfiles/syntax/
- doins contrib/vim/vagrantfile.vim
-}