summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-02 10:47:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-02 11:07:52 +0200
commit462fbeff85629420d28b62ef19f6179fd542db96 (patch)
tree057e247c04eb9444ba5bb53638af8f282704ac68 /app-emulation/virtualbox-modules
parentmedia-sound/mpg123: Removed old. (diff)
downloadgentoo-462fbeff85629420d28b62ef19f6179fd542db96.tar.gz
gentoo-462fbeff85629420d28b62ef19f6179fd542db96.tar.bz2
gentoo-462fbeff85629420d28b62ef19f6179fd542db96.zip
virtualbox packages: Bump to version 5.1.28 (bug #631332).
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'app-emulation/virtualbox-modules')
-rw-r--r--app-emulation/virtualbox-modules/Manifest1
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-5.1.28.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index be6e7669d49e..bee6439c7696 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -2,3 +2,4 @@ DIST vbox-kernel-module-src-5.0.16.tar.xz 593944 SHA256 8905e174069a6caf0200808f
DIST vbox-kernel-module-src-5.0.40.tar.xz 601604 SHA256 fb5dd2a62e1a53266f32c35523fa5ccc1d7928d4867c92637ef7368686acb70d SHA512 1236b16f2138872233a1a4f8933ec8803c7a15370cfadc148d338c803da572480d978d6be4b2512c3c80f7ee77cfef3d0a939b876ba9c53afbd267b24e2bfa65 WHIRLPOOL 59916e48536e1711cf0d98fecd3fe3ea0cce4b2eec622d34e5e52f20b05adb45dc627f4de5e55cfc92e2669b0fe71d4e1ba361d911d51da5bad3d80c42a66d24
DIST vbox-kernel-module-src-5.1.24.tar.xz 625508 SHA256 279e8ac5d5342896c63fd94dfe04d2462f759318b1dfc9eb3a617fbf8cc5e683 SHA512 2a2de8b4b328234470ed5f2209d792efef0c81251c20e45c13b923865fe5855d76512f17f8727daa17c10b09306748f70c1ec588a027c31645f7c676f96fca4c WHIRLPOOL eeaea483c46e0533053aff80af1f990fbaaeb073c7fbe535ec8425be6e73840c332dc3f22ccb0b6cd3b0f05a24fd206beb50dcdf8edf0245f4fa5be957bbb8d7
DIST vbox-kernel-module-src-5.1.26.tar.xz 625384 SHA256 5ba4f728c5b62c3d93828d99c5b54b8fb24a16bc8674e704714c4f71eb95ddc4 SHA512 c77e0d8dfade2abac95162e7e7a424be4875e44d43bcf2a13e0e50caa69f5fd0d21c77f03bb2cd4cbd5df4ab31e9fbd49ecd9220a49af8cd10081b960e014010 WHIRLPOOL 519246aeae6637cb8eb4b841552dc5e63f9a3d761fa6bcec43601c8a3194264457e4e78d200e975e31266af2944aa81f7487cf389f43d93db08f60a700a7758e
+DIST vbox-kernel-module-src-5.1.28.tar.xz 625464 SHA256 d6f3b7afa98d2b526d8da3c8906addc307eea069db371d012ebbffc1ccdf9dd2 SHA512 c8ae6c065ad42e57eee9a54f288ba60fd9b32efe18cb74c8a035d547b30e7d857c9091307485a8dfc77eec45de29d3217c6871140e167e2438759c314c47680a WHIRLPOOL c6508d63cacfcd3ac901f276cd793dc83c595bc73965518baa544b5cf5157ea52363b759f03586f743d6c2e0fda7252b98136c96cef28ecfb31f6915d4ce5709
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-5.1.28.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-5.1.28.ebuild
new file mode 100644
index 000000000000..6600e4fb53b0
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-5.1.28.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from virtualbox-bin
+
+EAPI=6
+
+inherit eutils linux-mod user
+
+MY_P=vbox-kernel-module-src-${PV}
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+
+RDEPEND="!=app-emulation/virtualbox-9999"
+
+S=${WORKDIR}
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
+
+pkg_setup() {
+ enewgroup vboxusers
+
+ CONFIG_CHECK="!TRIM_UNUSED_KSYMS"
+ ERROR_TRIM_UNUSED_KSYMS="The kernel option CONFIG_TRIM_UNUSED_KSYMS removed kernel symbols that are needed by ${PN} to load correctly."
+
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KERN_DIR=${KV_DIR} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}
+
+src_prepare() {
+ if kernel_is -ge 2 6 33 ; then
+ # evil patch for new kernels - header moved
+ grep -lR linux/autoconf.h * | xargs sed -i -e 's:<linux/autoconf.h>:<generated/autoconf.h>:'
+ fi
+
+ if use pax_kernel && kernel_is -ge 3 0 0 ; then
+ epatch "${FILESDIR}"/${PN}-4.1.4-pax-const.patch
+ fi
+
+ default
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ doins "${FILESDIR}"/virtualbox.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog "If you are using sys-apps/openrc, please add \"vboxdrv\", \"vboxnetflt\","
+ elog "\"vboxnetadp\" and \"vboxpci\" to:"
+ elog " /etc/conf.d/modules"
+}