summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-05-28 11:57:06 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-05-28 11:57:06 -0400
commit47c706f3f2bdf23a4d4de728ea804613dcef0fe2 (patch)
treed40524ba5acfa2a4ad3d0bff446a43f91f6e4c76 /app-emulation/vkd3d
parentprofiles/arch/amd64: Unmask app-emulation/wine-*[vkd3d] on amd64 (diff)
downloadgentoo-47c706f3f2bdf23a4d4de728ea804613dcef0fe2.tar.gz
gentoo-47c706f3f2bdf23a4d4de728ea804613dcef0fe2.tar.bz2
gentoo-47c706f3f2bdf23a4d4de728ea804613dcef0fe2.zip
app-emulation/vkd3d: Sync with ::wine
Initial version of vkd3d Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest1
-rw-r--r--app-emulation/vkd3d/metadata.xml15
-rw-r--r--app-emulation/vkd3d/vkd3d-1.0.ebuild40
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild40
4 files changed, 96 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
new file mode 100644
index 000000000000..a91ba6a42e09
--- /dev/null
+++ b/app-emulation/vkd3d/Manifest
@@ -0,0 +1 @@
+DIST vkd3d-1.0.tar.xz 219856 BLAKE2B ebf4f7d95a4ed97e4a8f652850d1af563b1c8a6d2b78f157f3e729387da5e70f1b099d1fcedb075cdb1d521d3e3e5669401c9080fb4079be22c9f73a6de34c2e SHA512 766eed31d4cb307d4575cc8f31495808c930cfd0be866ebecd5205112b0491a98dfe8b3818493774908ff551039baeac46c7b69c2b58e3df3963c22ad032ef6e
diff --git a/app-emulation/vkd3d/metadata.xml b/app-emulation/vkd3d/metadata.xml
new file mode 100644
index 000000000000..f83e30bbd199
--- /dev/null
+++ b/app-emulation/vkd3d/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ <description>
+ This package must be kept in sync with repo/proj/wine repository.
+ Any changes need to be run past the maintainer to ensure the two repositories are kept in sync.
+ </description>
+ </maintainer>
+ <use>
+ <flag name="spirv-tools">Enable better SPIRV support using <pkg>dev-util/spirv-tools</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/app-emulation/vkd3d/vkd3d-1.0.ebuild b/app-emulation/vkd3d/vkd3d-1.0.ebuild
new file mode 100644
index 000000000000..88db9b6937ff
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://dev.gentoo.org/~sarnex/distfiles/vkd3d-${PV}.tar.xz"
+ S="${WORKDIR}/${PN}"
+fi
+
+IUSE="spirv-tools"
+RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
+ x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_with spirv-tools)
+ )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
new file mode 100644
index 000000000000..88db9b6937ff
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://dev.gentoo.org/~sarnex/distfiles/vkd3d-${PV}.tar.xz"
+ S="${WORKDIR}/${PN}"
+fi
+
+IUSE="spirv-tools"
+RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
+ x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_with spirv-tools)
+ )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}