summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/vmware-vix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/vmware-vix')
-rw-r--r--app-emulation/vmware-vix/Manifest2
-rw-r--r--app-emulation/vmware-vix/metadata.xml14
-rw-r--r--app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild124
3 files changed, 140 insertions, 0 deletions
diff --git a/app-emulation/vmware-vix/Manifest b/app-emulation/vmware-vix/Manifest
new file mode 100644
index 000000000000..f36e161757ee
--- /dev/null
+++ b/app-emulation/vmware-vix/Manifest
@@ -0,0 +1,2 @@
+DIST VMware-VIX-1.11.4-744019.i386.bundle 76259648 SHA256 0e866bbdcc7f9ed7511af012a8645092a29d7d7b6cedd9d82d08560a9e3bde03 SHA512 2a7dca59e03abb3ed2a64b75bec51fd67e42350a26b106bc855fe99f7c842737d4ae89f7aa3c2f76e131451be4a9977054335527098672dc80eae34b13d70e80 WHIRLPOOL 5120209529429bbbb8ca1006bd9796881e9fbd5f5597a19076d527fec99cb5d2a55d10e14e9b6c96b8ad9daddd6250e5d7eb386d439acbca40f3d41d95f5b192
+DIST VMware-VIX-1.11.4-744019.x86_64.bundle 79518116 SHA256 0a77d6254963d15f9238c3054d98aa3597bdca7e7df69a55a6a74debdb2784be SHA512 318622143b3686802c86f649eeb60d33ecf0d5974c701c52d3081c6ab7074977c9cb3cfe5399b081a7313282215888c6d3fb64c016e5d31cc30e60239c4cc761 WHIRLPOOL c8af9f68b9828c71a363a09ce9384f6ba6bc874b4dd911ceac7991881e22e4f46c2656f58c4f561000f6e31142a3d525c5a6c6091f689554de16d309f17eb913
diff --git a/app-emulation/vmware-vix/metadata.xml b/app-emulation/vmware-vix/metadata.xml
new file mode 100644
index 000000000000..bf1b34bea29b
--- /dev/null
+++ b/app-emulation/vmware-vix/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vmware</herd>
+ <longdescription>
+ The VIX API allows you to write programs and scripts that automate
+ virtual machine operations, as well as the guests within virtual
+ machines. This API is high-level, easy to use, and practical for both
+ script writers and application programmers. It runs on both Windows and
+ Linux and supports management of VMware Server, Workstation, and Virtual
+ Infrastructure (both ESX and vCenter). Bindings are provided for C,
+ Perl, and COM (Visual Basic, VBscript, C#).
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild b/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild
new file mode 100644
index 000000000000..f7d635d21525
--- /dev/null
+++ b/app-emulation/vmware-vix/vmware-vix-1.11.4.744019.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils versionator vmware-bundle
+
+MY_PN="VMware-VIX"
+MY_PV="$(replace_version_separator 3 - $PV)"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="VMware VIX API for Linux"
+HOMEPAGE="http://www.vmware.com/support/developer/vix-api/"
+SRC_URI="
+ x86? ( ${MY_P}.i386.bundle )
+ amd64? ( ${MY_P}.x86_64.bundle )
+ "
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="doc"
+RESTRICT="fetch mirror strip"
+
+# vmware-workstation should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ =dev-libs/openssl-0.9.8*
+ net-misc/curl
+ sys-libs/glibc
+ sys-libs/zlib
+ !app-emulation/vmware-workstation"
+
+S=${WORKDIR}
+VM_INSTALL_DIR="/opt/vmware"
+
+pkg_nofetch() {
+ local bundle
+
+ if use x86; then
+ bundle="${MY_P}.i386.bundle"
+ elif use amd64; then
+ bundle="${MY_P}.x86_64.bundle"
+ fi
+
+ einfo "Please download ${bundle}"
+ einfo "from ${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ local component; for component in \
+ vmware-vix \
+ vmware-vix-core \
+ vmware-vix-lib-Workstation800andvSphere500
+ #vmware-vix-legacy \
+ do
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" "${component}" "${S}"
+ done
+}
+
+src_install() {
+ # install the binary
+ into "${VM_INSTALL_DIR}"
+ dobin bin/*
+
+ # install the libraries
+ insinto "${VM_INSTALL_DIR}"/lib/vmware-vix
+ doins -r lib/*
+
+ dosym vmware-vix/libvixAllProducts.so "${VM_INSTALL_DIR}"/lib/libbvixAllProducts.so
+
+ # install headers
+ insinto /usr/include/vmware-vix
+ doins include/*
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+
+ # fix permissions
+ fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware-vix/setup/vmware-config
+
+ # create the environment
+ local envd="${T}/90${PN}"
+ cat > "${envd}" <<-EOF
+ PATH='${VM_INSTALL_DIR}/bin'
+ ROOTPATH='${VM_INSTALL_DIR}/bin'
+ EOF
+ doenvd "${envd}"
+
+ # create the configuration
+ dodir /etc/vmware
+
+ local vmconfig="${T}/config"
+ if [[ -e ${ROOT}/etc/vmware/config ]]
+ then
+ cp -a "${ROOT}"/etc/vmware/config "${vmconfig}"
+ sed -i -e "/vmware.fullpath/d" "${vmconfig}"
+ sed -i -e "/vix.libdir/d" "${vmconfig}"
+ sed -i -e "/vix.config.version/d" "${vmconfig}"
+ fi
+
+ cat >> "${vmconfig}" <<-EOF
+ vmware.fullpath = "${VM_INSTALL_DIR}/bin/vmware"
+ vix.libdir = "${VM_INSTALL_DIR}/lib/vmware-vix"
+ vix.config.version = "1"
+ EOF
+
+ insinto /etc/vmware/
+ doins "${vmconfig}"
+}
+
+pkg_postinst() {
+ ewarn "/etc/env.d was updated. Please run:"
+ ewarn "env-update && source /etc/profile"
+}
+
+pkg_prerm() {
+ sed -i -e "/vix.libdir/d" "${ROOT}"/etc/vmware/config
+}