summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2018-03-01 21:12:21 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2018-03-01 21:13:56 -0500
commit3326f27a81471061c20692daa09355a7ed1bf801 (patch)
tree5f5c207d4de4f116be732c34e9ea6396fea7b926 /app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
parentapp-emulation/wine-staging: Sync from ::wine (diff)
downloadgentoo-3326f27a81471061c20692daa09355a7ed1bf801.tar.gz
gentoo-3326f27a81471061c20692daa09355a7ed1bf801.tar.bz2
gentoo-3326f27a81471061c20692daa09355a7ed1bf801.zip
app-emulation/wine-d3d9: Sync from ::wine
Add GSSAPI and Vulkan support Closes: https://bugs.gentoo.org/649132 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation/wine-d3d9/wine-d3d9-9999.ebuild')
-rw-r--r--app-emulation/wine-d3d9/wine-d3d9-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild b/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
index ddbc7bcc947c..9025029236ad 100644
--- a/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
+++ b/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
@@ -44,7 +44,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap +png prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype udev +udisks v4l +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap +png prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype udev +udisks v4l vulkan +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -76,6 +76,7 @@ COMMON_DEPEND="
fontconfig? ( media-libs/fontconfig:=[${MULTILIB_USEDEP}] )
gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
gsm? ( media-sound/gsm:=[${MULTILIB_USEDEP}] )
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
gstreamer? (
media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
media-plugins/gst-plugins-meta:1.0[${MULTILIB_USEDEP}]
@@ -105,6 +106,7 @@ COMMON_DEPEND="
udev? ( virtual/libudev:=[${MULTILIB_USEDEP}] )
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
+ vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )
xcomposite? ( x11-libs/libXcomposite[${MULTILIB_USEDEP}] )
xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
xml? (
@@ -172,7 +174,6 @@ PATCHES=(
"${PATCHDIR}/patches/${MY_PN}-1.9.5-multilib-portage.patch" #395615
"${PATCHDIR}/patches/${MY_PN}-1.6-memset-O3.patch" #480508
"${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch" #310611
- "${PATCHDIR}/patches/${MY_PN}-2.0-rearrange-manpages.patch" #469418 #617864
)
PATCHES_BIN=()
@@ -371,7 +372,6 @@ src_prepare() {
l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
# Fix manpage generation for locales #469418 and abi_x86_64 #617864
- # Requires wine-2.0-rearrange-manpages.patch
# Duplicate manpages input files for wine64
local f
@@ -429,6 +429,7 @@ multilib_src_configure() {
$(use_enable gecko mshtml)
$(use_with gphoto2 gphoto)
$(use_with gsm)
+ $(use_with gssapi)
$(use_with gstreamer)
--without-hal
$(use_with jpeg)
@@ -452,6 +453,7 @@ multilib_src_configure() {
$(use_with truetype freetype)
$(use_with udev)
$(use_with v4l)
+ $(use_with vulkan)
$(use_with X x)
$(use_with X xfixes)
$(use_with xcomposite)