summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-17 10:38:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-17 10:39:11 -0500
commit4d3360e5ac7567aa9d470c73d64179645858191f (patch)
tree80c18b94873e778a2eb351a108e6389f2ec1b22d /app-emulation
parentdev-python/oslo-cache: 1.33.3 bump (diff)
downloadgentoo-4d3360e5ac7567aa9d470c73d64179645858191f.tar.gz
gentoo-4d3360e5ac7567aa9d470c73d64179645858191f.tar.bz2
gentoo-4d3360e5ac7567aa9d470c73d64179645858191f.zip
app-emulation/diskimage-builder: 2.23.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.23.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 719fd58edcc8..40e975e03409 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-2.21.0.tar.gz 409367 BLAKE2B 25c8a819be8674eee38a97e822151527dd77d3f5e85016ebc1a7fa5bf907f64bdac47012eb748b69273b519580c6ea4ca845abd7800ddb4e3f60dd81da546a73 SHA512 51a871a772fd4ae35d0a8ea51f7c01502c374805f5de5ab37c2f18ea868a829c7085ecaa6a62690e8d6e85afe225cbab7ed86266eb5fc3e8741a8ff968cb35f9
DIST diskimage-builder-2.22.0.tar.gz 410939 BLAKE2B ff5b3ce0f128001091e4621170def71cb6ef46cc278aee5a877caba0a3df054ac5e7027640a70ffdd8b8329764774ef801b0c0ad427babaec09a7123552edb50 SHA512 e051b668a86a4b386c2ec079a8f28bb5ab54ee6dbd1f39d7889075efa6abd4dff7063be24b817e05057f85036202f6193438df1a112009a1b954eaa4bb1b6e44
+DIST diskimage-builder-2.23.0.tar.gz 403817 BLAKE2B 14b67dc456bd9dab13a534f0f6df27b8a74514966ad965b401d33274d37ee2f201fa1dcd64b2c04a7503ab1f6a893dc40b5145c9559a7be74a029e2da226758a SHA512 89b2ee7eda56c610b9c343edd51276d54eb129ce319cf7f0fdebbccd1bba52903d16a71f1558bb76d2011d5267ffbc62bde94f5d7fd5aabdab2bc82abf10c685
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.23.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.23.0.ebuild
new file mode 100644
index 000000000000..bda4c2798bb7
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.23.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"