summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya <98194153+ThamognyaKodi@users.noreply.github.com>2022-03-19 14:33:46 +0000
committerJoonas Niilola <juippis@gentoo.org>2022-06-12 11:03:47 +0300
commitaf09b34456a840e5dc0eaa5b867fdd5da2b67b18 (patch)
tree5f14a514064784afd65b5fccd08df309e2159d48 /app-emulation
parentdev-ml/graphics: add missing DEPEND to 5.1.2 (diff)
downloadgentoo-af09b34456a840e5dc0eaa5b867fdd5da2b67b18.tar.gz
gentoo-af09b34456a840e5dc0eaa5b867fdd5da2b67b18.tar.bz2
gentoo-af09b34456a840e5dc0eaa5b867fdd5da2b67b18.zip
app-emulation/spice-vdagent:Bump to version 0.22.1
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/24664 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice-vdagent/Manifest1
-rw-r--r--app-emulation/spice-vdagent/spice-vdagent-0.22.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-emulation/spice-vdagent/Manifest b/app-emulation/spice-vdagent/Manifest
index 75945c04abed..1ef47e9cd14d 100644
--- a/app-emulation/spice-vdagent/Manifest
+++ b/app-emulation/spice-vdagent/Manifest
@@ -1,2 +1,3 @@
DIST spice-vdagent-0.19.0.tar.bz2 151356 BLAKE2B b7a99a7205d955b27edfe483746e3f267a6e0b7885c4b8146ba42d99b581cf4e1748b503a37a3d6b66623ef2515b42756f2e6a5a4775d56def7aa396bd0dfb4f SHA512 f5056dfe66df3ee8205549be22bbc8c17d2196c8448eda97f01659ff30c34d9929f330767d7fafec557dc5f7fb9b65eaf85973193b38df774042de9b72d6e60d
DIST spice-vdagent-0.21.0.tar.bz2 164103 BLAKE2B 298122b334f880ffb8d77d3a7d822b70debce56d62bc3004bbac37445f10236a47706d23501ee3f82520c45b65deec12c9578cf4a8b9ac138df8b1c0b8cdb784 SHA512 1ff1a89e75301b1c2c89f26ba4bce8d4df29bbff6387ade128ce847ca30162a2bc731c70c10a8d129518e64bbca6b8271fd11ff3e340899182a65a5295051bff
+DIST spice-vdagent-0.22.1.tar.bz2 165560 BLAKE2B 4fd4318592d20d305d515c65d7491b90ac79bcc7f5bdfafd9df7858bdce24aa57c79f2121bbf9cbadec8e6297890f4b8598b9abcadcce5a9f39712b96deaa396 SHA512 5a4d2661145f33a0583880a128d925b15ca5aec05df83271c80f8baa0fcdd28fab0242301bc38443ccddf70fbdcfd76b5d30bb5a6b4b7c895c3cea0eb38bdf92
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.22.1.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.22.1.ebuild
new file mode 100644
index 000000000000..b2d7e17450a7
--- /dev/null
+++ b/app-emulation/spice-vdagent/spice-vdagent-0.22.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info tmpfiles
+
+DESCRIPTION="SPICE VD Linux Guest Agent"
+HOMEPAGE="https://www.spice-space.org/"
+SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk selinux systemd"
+
+DEPEND="
+ dev-libs/glib:2
+ >=app-emulation/spice-protocol-0.14.0
+ media-libs/alsa-lib
+ sys-apps/dbus
+ x11-libs/libdrm
+ >=x11-libs/libpciaccess-0.10
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXinerama
+ gtk? ( x11-libs/gtk+:3 )
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-vdagent )"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
+ERROR_INPUT_UINPUT="User level input support (INPUT_UINPUT) is required"
+ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support (VIRTIO_CONSOLE) is required"
+
+src_configure() {
+ local opt=()
+ if use systemd; then
+ opt+=( --with-session-info=systemd )
+ else
+ opt+=( --with-session-info=none )
+ fi
+
+ econf \
+ --with-init-script=systemd \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_with gtk) \
+ "${opt[@]}"
+}
+
+src_install() {
+ default
+
+ rmdir "${ED}"/var/run/spice-vdagentd || die
+
+ keepdir /var/log/spice-vdagentd
+
+ newinitd "${FILESDIR}/${PN}.initd-4" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
+}
+
+pkg_postinst() {
+ tmpfiles_process spice-vdagentd.conf
+}