summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-12 13:54:07 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-12 13:55:52 +0200
commite3de3fd14f6e4f1aae1a06c8149a342eed438bb6 (patch)
tree11c5bf7f19348594ce355172816fc4715dcb2538 /app-emulation
parentapp-emulation/reg: Version bump to 0.13.3 (diff)
downloadgentoo-e3de3fd14f6e4f1aae1a06c8149a342eed438bb6.tar.gz
gentoo-e3de3fd14f6e4f1aae1a06c8149a342eed438bb6.tar.bz2
gentoo-e3de3fd14f6e4f1aae1a06c8149a342eed438bb6.zip
app-emulation/img: Version bump to 0.4.5
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.4.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index abf96aef2413..e849d2db121d 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1 +1,2 @@
DIST img-0.4.4.tar.gz 5626989 BLAKE2B ba67acb795cb4e1da412773fe37be5c64fe0743d527e2565fe03fabad0cf45cbb3c2abba24da9346b5aa25842be69150d9d195e4ceb737a6ac5a47f372da9816 SHA512 718ced82f7df555c8c3f35c7e466842129190d422fc36a82feae4837045d65f86ba2e162c590369dcc758f3f3ddab21f758b03131796f41daab186df06e96697
+DIST img-0.4.5.tar.gz 5635062 BLAKE2B 7161225494c8db0f6a91cda186d9c5804eff9f5fec5645dd1b61ac5f76de10ad8d63f2723030b9e3e886f292ce2c4a8d1e325c0adff759893b6455dc2c540e51 SHA512 ca427127b716f69d474912fad1e8a24008d671c3da266560466a1ff54690439fc3bc04b736f3ae3e12534a708ad4f6b9a6c910334dfc68ce2e1f63ecb1a5cac5
diff --git a/app-emulation/img/img-0.4.5.ebuild b/app-emulation/img/img-0.4.5.ebuild
new file mode 100644
index 000000000000..dc566ad24047
--- /dev/null
+++ b/app-emulation/img/img-0.4.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="64f47e3c5a9bdd2a8d4189aa981d4a7e2de862ae"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}