summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/fcitx-anthy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/fcitx-anthy')
-rw-r--r--app-i18n/fcitx-anthy/Manifest2
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-0.1.1.ebuild29
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-0.2.1.ebuild29
-rw-r--r--app-i18n/fcitx-anthy/metadata.xml5
4 files changed, 65 insertions, 0 deletions
diff --git a/app-i18n/fcitx-anthy/Manifest b/app-i18n/fcitx-anthy/Manifest
new file mode 100644
index 000000000000..f9552c2b0522
--- /dev/null
+++ b/app-i18n/fcitx-anthy/Manifest
@@ -0,0 +1,2 @@
+DIST fcitx-anthy-0.1.1.tar.xz 68604 SHA256 c508068c7c9a56c26ea44b8e6ddb90a2ea75860031f89e171dcda8ec4cd08955 SHA512 e2c4bb20f0b0a370e5f28bff14312c2c14210695418438ebe697b94570fe502be8c96dc8fbf813fd3aa6e352283a7d31808a1f12266d4a8050646a8ae86de9d9 WHIRLPOOL 48f674ef23d62f2dc1286712cbb252d709d9e3890921d1f9296ff89f85c5ae211daa887841fc01f267fe44764275e8b6de4aef859d9f1456cb24f00023b262ce
+DIST fcitx-anthy-0.2.1.tar.xz 72196 SHA256 fd208474666f09f1c189c10c2c0fa9cfda33948b704410e02878fdd92174d78d SHA512 18599251d6ebda96a23f81f63d91e9a9d469d2ea534975c2f4ddbc80584d70646ac6d157d0571f9d48565c0cfd1bb111e2907cae2c00b750014b9f39a7bcf961 WHIRLPOOL 99632911a7831ce24c7535b0e0a249cbbc48b24ec44682f6a09e3dc0a61d7eb74363642098158cc409c3390fb141d03591f1e1b1b3683164d4d6002fe9c92769
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-0.1.1.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-0.1.1.ebuild
new file mode 100644
index 000000000000..089b8be39480
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Japanese Anthy module for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.5
+ app-i18n/anthy"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/libintl"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-0.2.1.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-0.2.1.ebuild
new file mode 100644
index 000000000000..a0bc0e741514
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Japanese Anthy module for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ app-i18n/anthy"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/libintl"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-anthy/metadata.xml b/app-i18n/fcitx-anthy/metadata.xml
new file mode 100644
index 000000000000..cb36a2fd8c76
--- /dev/null
+++ b/app-i18n/fcitx-anthy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+</pkgmetadata>