summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-14 23:45:07 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-14 23:45:07 +0900
commit92ddd1e3ded7a9fed5f7b5ea2b3bbc0fa910b886 (patch)
treec5f90c71ba41953bf6cf758c0953bb2283200ec5 /app-i18n/ibus/ibus-1.5.12.ebuild
parentapp-i18n/atokx3: update to EAPI 6 (diff)
downloadgentoo-92ddd1e3ded7a9fed5f7b5ea2b3bbc0fa910b886.tar.gz
gentoo-92ddd1e3ded7a9fed5f7b5ea2b3bbc0fa910b886.tar.bz2
gentoo-92ddd1e3ded7a9fed5f7b5ea2b3bbc0fa910b886.zip
app-i18n/ibus: add missing REQUIRED_USE
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/ibus/ibus-1.5.12.ebuild')
-rw-r--r--app-i18n/ibus/ibus-1.5.12.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-i18n/ibus/ibus-1.5.12.ebuild b/app-i18n/ibus/ibus-1.5.12.ebuild
index ebad2ff67aaa..a8413c59fff3 100644
--- a/app-i18n/ibus/ibus-1.5.12.ebuild
+++ b/app-i18n/ibus/ibus-1.5.12.ebuild
@@ -14,8 +14,9 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="gconf +gtk +gtk2 +introspection +libnotify nls +python test vala wayland +X"
-REQUIRED_USE="libnotify? ( gtk )
+IUSE="+X gconf +gtk +gtk2 +introspection +libnotify nls +python test vala wayland"
+REQUIRED_USE="gtk2? ( gtk )
+ libnotify? ( gtk )
python? (
${PYTHON_REQUIRED_USE}
gtk
@@ -29,6 +30,10 @@ CDEPEND="app-text/iso-codes
gnome-base/dconf
gnome-base/librsvg:2
sys-apps/dbus[X?]
+ X? (
+ x11-libs/libX11
+ !gtk? ( x11-libs/gtk+:2 )
+ )
gconf? ( gnome-base/gconf:2 )
gtk? (
x11-libs/gtk+:3
@@ -46,13 +51,6 @@ CDEPEND="app-text/iso-codes
wayland? (
dev-libs/wayland
x11-libs/libxkbcommon
- )
- X? (
- || (
- x11-libs/gtk+:3
- x11-libs/gtk+:2
- )
- x11-libs/libX11
)"
RDEPEND="${CDEPEND}
python? (
@@ -104,6 +102,7 @@ src_configure() {
fi
econf \
+ $(use_enable X xim) \
$(use_enable gconf) \
$(use_enable gtk gtk3) \
$(use_enable gtk ui) \
@@ -114,7 +113,6 @@ src_configure() {
$(use_enable test tests) \
$(use_enable vala) \
$(use_enable wayland) \
- $(use_enable X xim) \
"${python_conf[@]}"
}