summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-03-23 23:52:41 +0100
committerMike Gilbert <floppym@gentoo.org>2016-03-24 10:42:46 -0400
commitea249af7ff21ac44a57c214a44f636a9077800d9 (patch)
tree2ff5fd049d9f24be3bede17e75c02a83a507cfa7 /app-i18n/kcm-fcitx
parentapp-i18n/kcm-fcitx: Version bump (0.5.3). (diff)
downloadgentoo-ea249af7ff21ac44a57c214a44f636a9077800d9.tar.gz
gentoo-ea249af7ff21ac44a57c214a44f636a9077800d9.tar.bz2
gentoo-ea249af7ff21ac44a57c214a44f636a9077800d9.zip
app-i18n/kcm-fcitx: Add live ebuilds.
Diffstat (limited to 'app-i18n/kcm-fcitx')
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.4.9999.ebuild48
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-9999.ebuild61
2 files changed, 109 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.4.9999.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.4.9999.ebuild
new file mode 100644
index 000000000000..27997fbf0af6
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.4.9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils xdg
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+ EGIT_BRANCH="kde4"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE="minimal"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8[dbus,qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ kde-base/kdelibs:4
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}
+ dev-util/automoc
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ if use minimal; then
+ cmake_comment_add_subdirectory po
+ fi
+
+ cmake-utils_src_prepare
+}
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-9999.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-9999.ebuild
new file mode 100644
index 000000000000..a3c393ecbca9
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8[dbus]
+ app-i18n/fcitx-qt5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kcmutils:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kitemviews:5
+ kde-frameworks/knewstuff:5
+ kde-frameworks/kwidgetsaddons:5
+ virtual/libintl
+ !${CATEGORY}/${PN}:4[-minimal(-)]"
+DEPEND="${RDEPEND}
+ kde-frameworks/extra-cmake-modules:5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # x11-libs/libxkbfile only used by kbd-layout-viewer not ported to Qt 5 / KDE 5.
+ sed -e "/find_package(XkbFile REQUIRED)/d" -i CMakeLists.txt
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ )
+
+ cmake-utils_src_configure
+}