summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-19 00:47:32 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-19 00:47:32 +0900
commit844ad57d33a92b08bfc5ea5611ebfb4d31b0d162 (patch)
tree736943619768ea52e401627fe70284289b3f84fe /app-i18n/kimera
parentapp-i18n/kimera: update HOMEPAGE (diff)
downloadgentoo-844ad57d33a92b08bfc5ea5611ebfb4d31b0d162.tar.gz
gentoo-844ad57d33a92b08bfc5ea5611ebfb4d31b0d162.tar.bz2
gentoo-844ad57d33a92b08bfc5ea5611ebfb4d31b0d162.zip
app-i18n/kimera: update to EAPI 6
Gentoo-Bug: 621944 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/kimera')
-rw-r--r--app-i18n/kimera/kimera-2.11-r1.ebuild29
-rw-r--r--app-i18n/kimera/metadata.xml8
2 files changed, 21 insertions, 16 deletions
diff --git a/app-i18n/kimera/kimera-2.11-r1.ebuild b/app-i18n/kimera/kimera-2.11-r1.ebuild
index 74936958a425..289f4b79a7b5 100644
--- a/app-i18n/kimera/kimera-2.11-r1.ebuild
+++ b/app-i18n/kimera/kimera-2.11-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
-inherit qt4-r2 eutils multilib
+EAPI="6"
+
+inherit qmake-utils
DESCRIPTION="A Japanese input method which supports the XIM protocol"
HOMEPAGE="http://kimera.osdn.jp/"
@@ -13,21 +14,25 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="+anthy"
-DEPEND="dev-qt/qtcore:4
+RDEPEND="dev-qt/qt3support:4
+ dev-qt/qtcore:4
dev-qt/qtgui:4
- dev-qt/qt3support:4
anthy? ( app-i18n/anthy )
!anthy? ( app-i18n/canna )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
-DOCS="AUTHORS README*"
+PATCHES=( "${FILESDIR}"/${PN}-underlinking.patch )
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-underlinking.patch
+src_configure() {
+ local myconf=(
+ script.path="${EPREFIX}"/usr/bin
+ target.path="${EPREFIX}"/usr/$(get_libdir)/${P}
+ no_anthy=$(usex anthy 1 0)
+ )
+ eqmake4 ${PN}.pro "${myconf[@]}"
}
-src_configure() {
- local myconf="target.path=/usr/$(get_libdir)/${P}"
- use anthy || myconf="${myconf} no_anthy=1"
- eqmake4 kimera.pro ${myconf}
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
}
diff --git a/app-i18n/kimera/metadata.xml b/app-i18n/kimera/metadata.xml
index d9263b15bbe6..6a876a223eb9 100644
--- a/app-i18n/kimera/metadata.xml
+++ b/app-i18n/kimera/metadata.xml
@@ -6,11 +6,11 @@
<name>Cjk</name>
</maintainer>
<longdescription>
-Kimera is a Qt-based Japanese input method bridge.
-Currently it supports Canna and Anthy.
-</longdescription>
+ Kimera is a Qt-based Japanese input method bridge.
+ Currently it supports Canna and Anthy.
+ </longdescription>
<use>
- <flag name="anthy">Support for Anthy input method</flag>
+ <flag name="anthy">Enable support for <pkg>app-i18n/anthy</pkg></flag>
</use>
<upstream>
<remote-id type="sourceforge-jp">kimera</remote-id>