summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-09-04 21:40:07 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-09-04 21:40:07 +0900
commitdfed50c573bdb238170ccad8f8fa313b3d37f502 (patch)
tree4cd79f0119bdc14b6b3cee49f660b8d2adc418c5 /app-i18n
parentdev-python/cangjie: new upstream release (diff)
downloadgentoo-dfed50c573bdb238170ccad8f8fa313b3d37f502.tar.gz
gentoo-dfed50c573bdb238170ccad8f8fa313b3d37f502.tar.bz2
gentoo-dfed50c573bdb238170ccad8f8fa313b3d37f502.zip
app-i18n/ibus-cangjie: update to EAPI 6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild46
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild49
-rw-r--r--app-i18n/ibus-cangjie/metadata.xml14
3 files changed, 53 insertions, 56 deletions
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
new file mode 100644
index 000000000000..f7446f6ad8ae
--- /dev/null
+++ b/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="Chinese Cangjie and Quick engines for IBus"
+HOMEPAGE="http://cangjians.github.io/"
+SRC_URI="https://github.com/Cangjians/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ python_foreach_impl default
+}
+
+src_compile() {
+ python_foreach_impl default
+}
+
+src_install() {
+ python_foreach_impl default
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild
deleted file mode 100644
index 766065c32132..000000000000
--- a/app-i18n/ibus-cangjie/ibus-cangjie-2.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit autotools-utils gnome2-utils python-r1 eutils
-
-DESCRIPTION="The IBus engine for users of the Cangjie and Quick input methods"
-HOMEPAGE="http://cangjians.github.io"
-SRC_URI="https://github.com/Cangjians/ibus-cangjie/releases/download/v${PV}/ibus-cangjie-${PV}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=app-i18n/ibus-1.4.1
- app-i18n/libcangjie
- dev-python/cangjie[${PYTHON_USEDEP}]
- dev-util/intltool
- sys-devel/gettext"
-
-RDEPEND=">=app-i18n/ibus-1.4.1
- app-i18n/libcangjie
- dev-python/cangjie[${PYTHON_USEDEP}]
- virtual/libintl
- ${PYTHON_DEPS}"
-
-src_configure() {
- python_foreach_impl autotools-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl autotools-utils_src_compile
-}
-
-src_install() {
- python_foreach_impl autotools-utils_src_install
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
diff --git a/app-i18n/ibus-cangjie/metadata.xml b/app-i18n/ibus-cangjie/metadata.xml
index 9468326e6f9a..83985854d52a 100644
--- a/app-i18n/ibus-cangjie/metadata.xml
+++ b/app-i18n/ibus-cangjie/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
- <upstream>
- <remote-id type="github">Cangjians/ibus-cangjie</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Cangjians/ibus-cangjie</remote-id>
+ </upstream>
</pkgmetadata>