summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-05-06 13:15:29 +0200
committerDavid Seifert <soap@gentoo.org>2016-05-06 13:15:44 +0200
commit348c3c06fbcc4d6c84bdec267e0929030dba7230 (patch)
treef3e73a57d95a22b0b27326fd4606f7af77bea589 /app-leechcraft
parentapp-editors/kakoune: new ebuild (diff)
downloadgentoo-348c3c06fbcc4d6c84bdec267e0929030dba7230.tar.gz
gentoo-348c3c06fbcc4d6c84bdec267e0929030dba7230.tar.bz2
gentoo-348c3c06fbcc4d6c84bdec267e0929030dba7230.zip
app-leechcraft/lc-core: Require USE="threads" for dev-libs/boost
Gentoo-Bug: 574030, 580850 * Also fix C++11 direct initialization bug Package-Manager: portage-2.2.28
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-core/files/lc-core-0.6.70-c++11-direct-list-initialization.patch35
-rw-r--r--app-leechcraft/lc-core/lc-core-0.6.70.ebuild8
2 files changed, 41 insertions, 2 deletions
diff --git a/app-leechcraft/lc-core/files/lc-core-0.6.70-c++11-direct-list-initialization.patch b/app-leechcraft/lc-core/files/lc-core-0.6.70-c++11-direct-list-initialization.patch
new file mode 100644
index 000000000000..b5b670060117
--- /dev/null
+++ b/app-leechcraft/lc-core/files/lc-core-0.6.70-c++11-direct-list-initialization.patch
@@ -0,0 +1,35 @@
+GCC 5.1 and upwards are more strict with direct initialization:
+* /var/tmp/portage/app-leechcraft/lc-core-0.6.70/work/leechcraft-0.6.70/src/util/network/addresses.cpp:46:3: error: direct-list-* initialization of ‘auto’ requires exactly one element [-fpermissive]
+* };
+See also:
+https://bugs.gentoo.org/show_bug.cgi?id=574030
+
+--- leechcraft-0.6.70/src/util/network/addresses.cpp
++++ leechcraft-0.6.70/src/util/network/addresses.cpp
+@@ -38,7 +38,7 @@
+ AddrList_t GetLocalAddresses (int defaultPort)
+ {
+ AddrList_t defaultAddrs;
+- const auto locals
++ const auto locals =
+ {
+ QHostAddress::parseSubnet ("10.0.0.0/8"),
+ QHostAddress::parseSubnet ("172.16.0.0/12"),
+--- leechcraft-0.6.70/src/util/xdg/xdg.cpp
++++ leechcraft-0.6.70/src/util/xdg/xdg.cpp
+@@ -44,13 +44,13 @@
+
+ QPixmap GetAppPixmap (const QString& name)
+ {
+- const auto prefixes
++ const auto prefixes =
+ {
+ "/usr/share/pixmaps/",
+ "/usr/local/share/pixmaps/"
+ };
+
+- const auto sizes { "192", "128", "96", "72", "64", "48", "36", "32" };
++ const auto sizes = { "192", "128", "96", "72", "64", "48", "36", "32" };
+ const QStringList themes
+ {
+ "/usr/local/share/icons/hicolor/",
diff --git a/app-leechcraft/lc-core/lc-core-0.6.70.ebuild b/app-leechcraft/lc-core/lc-core-0.6.70.ebuild
index f7ca3c9a465b..2f10caeec088 100644
--- a/app-leechcraft/lc-core/lc-core-0.6.70.ebuild
+++ b/app-leechcraft/lc-core/lc-core-0.6.70.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS=" amd64 ~x86"
IUSE="debug doc +sqlite postgres +qwt"
-COMMON_DEPEND=">=dev-libs/boost-1.46
+COMMON_DEPEND=">=dev-libs/boost-1.46:=[threads]
dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtdeclarative:4
@@ -36,6 +36,10 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="|| ( postgres sqlite )"
+PATCHES=(
+ "${FILESDIR}/${P}-c++11-direct-list-initialization.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False