summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-04-17 20:24:05 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-06 14:50:51 +0300
commitbe121cb6d8767b435b2a178547598b8cce6ffad7 (patch)
treed5772954974bbb14dc0c6efa7f5e49521eaa5521 /app-leechcraft
parentapp-leechcraft/lc-mellonetray: bump EAPI, fix deps (diff)
downloadgentoo-be121cb6d8767b435b2a178547598b8cce6ffad7.tar.gz
gentoo-be121cb6d8767b435b2a178547598b8cce6ffad7.tar.bz2
gentoo-be121cb6d8767b435b2a178547598b8cce6ffad7.zip
app-leechcraft/lc-musiczombie: EAPI bump, subslot deps
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
index 362f8279c933..9a98bff590d8 100644
--- a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
+++ b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit leechcraft
@@ -9,20 +9,18 @@ DESCRIPTION="MusicBrainz client plugin for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug acoustid"
+IUSE="acoustid debug"
DEPEND="~app-leechcraft/lc-core-${PV}
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
dev-qt/qtconcurrent:5
dev-qt/qtnetwork:5
dev-qt/qtxml:5
- acoustid? ( media-libs/chromaprint )"
+ acoustid? ( media-libs/chromaprint:= )"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DWITH_MUSICZOMBIE_CHROMAPRINT=$(usex acoustid)
)
- cmake-utils_src_configure
+ cmake_src_configure
}