summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-03-29 13:50:20 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-03-29 13:50:20 +0100
commit8123659fede7101d47d1533673cc28a520030351 (patch)
tree2622fdbc5de4512ce0acc2ab4dc6a83f0c736280 /app-metrics
parentdev-ruby/activesupport: update i18n to only consider ruby26 versions (diff)
downloadgentoo-8123659fede7101d47d1533673cc28a520030351.tar.gz
gentoo-8123659fede7101d47d1533673cc28a520030351.tar.bz2
gentoo-8123659fede7101d47d1533673cc28a520030351.zip
app-metrics/prometheus: Version bump to 2.8.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.8.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 470ac1e74cdd..e687741cce38 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -2,3 +2,4 @@ DIST prometheus-2.4.3.tar.gz 6095284 BLAKE2B 9b9d54cf8ed61453d63e4b93cd81cd1c08a
DIST prometheus-2.6.1.tar.gz 6612143 BLAKE2B 33dc64406dd45f494720a1ff5f6d09ed4b45b3880b15626ab7455909258addc5d1549d3edbf8af9a374516930b297c5bdb6ef51a78cac3cb338357896c0d71ae SHA512 80bf6afa00b60aa4245a53e275a2b9579a7936609aba4ffacbbe478f34e530208e0498d8c5ea53dd3a940726e05bd6fac19fed3d6d9dd209af565d5368b2340f
DIST prometheus-2.7.2.tar.gz 7276689 BLAKE2B 4fa1325b0f68bd33f4db45d3ea0fcac24bc1319284086d3ee0d3aa65c1a4ab4c37a1a67fd6e1de74e851dd90d50b566f5a1fa5b68b11c3defefd2506f5b4ce98 SHA512 3dc46069581c457005de0eefe777e93ae72b73c624d7c728973f3c64c34d68628da13d76e3527e3825309d543fd81ef7446c776e0772c1f6bf58e5ebad805973
DIST prometheus-2.8.0.tar.gz 11097030 BLAKE2B 5c56e5d31048bc35e5c02aed4736590adc2e8a6364b926ed8181aceeaccbd6b86b1a63f59176b6efca9a9adbe3855f8dfb3d20713093d4f38a3c5c3f52061ef5 SHA512 9b0b0679768a9426547b232a87a3109008c28a59ef74b9376f192209c4005c7f18d622601ebef14516786378c5f014f6734a4e1a7929ffc0b9b7c369d28030eb
+DIST prometheus-2.8.1.tar.gz 11097954 BLAKE2B 90add9b1daff278b8ec185eee1af5e00e26abaa6ab1f99383dd7de8ce2b99cc0612957681c36640b7a822d3b8d05e5ecb015b00409d67292d6176a058233932e SHA512 7a93d7c6e1f9fc1a57d11e6a17e6d0b3375b2e1babac0a89b8deac0834eac29b3ed7c4131c8992e4cdfd76f7d9eea0162e880fd9e44432f537e070eda647cef2
diff --git a/app-metrics/prometheus/prometheus-2.8.1.ebuild b/app-metrics/prometheus/prometheus-2.8.1.ebuild
new file mode 100644
index 000000000000..66c9dce364b3
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.8.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=v${PV/_rc/-rc.}
+PROMETHEUS_COMMIT="4d60eb3"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://${EGO_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.11
+ >=dev-util/promu-0.3.0"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GO111MODULE=on GOPATH="${S}" GOCACHE="${T}/go-cache" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}