summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/binclock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/binclock')
-rw-r--r--app-misc/binclock/Manifest1
-rw-r--r--app-misc/binclock/binclock-1.5.ebuild33
-rw-r--r--app-misc/binclock/metadata.xml6
3 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/binclock/Manifest b/app-misc/binclock/Manifest
new file mode 100644
index 000000000000..170ad9c66852
--- /dev/null
+++ b/app-misc/binclock/Manifest
@@ -0,0 +1 @@
+DIST binclock-1.5.tar.gz 12301 SHA256 3b34033aef01771235e87848ddc92ef23dc2c989902f2ea1cb652b91e43f3df5 SHA512 f3650c8befb999a7e6261bc72ee4f81be670fe95899efc742112102c4107ebbbb25d015d57a702630ce2104cf8c738953c7fe70f24814514d8a2705240000e75 WHIRLPOOL 73b8ccdf94177e8959a83da9b0a3d9745e85c5672e2a4e3ef4d64a7394252697fc648040cf8486e519efb73c769be858ab5ae76445da3ea3bb2a370dccd1e3bd
diff --git a/app-misc/binclock/binclock-1.5.ebuild b/app-misc/binclock/binclock-1.5.ebuild
new file mode 100644
index 000000000000..b1e84c5cd8d3
--- /dev/null
+++ b/app-misc/binclock/binclock-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a binary clock in your terminal"
+HOMEPAGE="http://www.ngolde.de/binclock/"
+SRC_URI="http://www.ngolde.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ sed -i -e s/strip/true/ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin binclock || die "dobin failed"
+ doman doc/binclock.1 || die "doman failed"
+ dodoc CHANGELOG README binclockrc || die "dodoc failed"
+}
diff --git a/app-misc/binclock/metadata.xml b/app-misc/binclock/metadata.xml
new file mode 100644
index 000000000000..dbf8947073ac
--- /dev/null
+++ b/app-misc/binclock/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <longdescription>binclock displays a binary clock in your terminal.</longdescription>
+</pkgmetadata>