summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/carbon-c-relay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/carbon-c-relay')
-rw-r--r--app-misc/carbon-c-relay/Manifest3
-rw-r--r--app-misc/carbon-c-relay/carbon-c-relay-0.39-r1.ebuild37
-rw-r--r--app-misc/carbon-c-relay/carbon-c-relay-0.40.ebuild38
-rw-r--r--app-misc/carbon-c-relay/carbon-c-relay-0.43.ebuild37
-rw-r--r--app-misc/carbon-c-relay/files/carbon-c-relay.confd16
-rw-r--r--app-misc/carbon-c-relay/files/carbon-c-relay.initd71
-rw-r--r--app-misc/carbon-c-relay/metadata.xml10
7 files changed, 212 insertions, 0 deletions
diff --git a/app-misc/carbon-c-relay/Manifest b/app-misc/carbon-c-relay/Manifest
new file mode 100644
index 000000000000..277e8f4b7ffa
--- /dev/null
+++ b/app-misc/carbon-c-relay/Manifest
@@ -0,0 +1,3 @@
+DIST carbon-c-relay-0.39.tar.gz 55308 SHA256 694cfb291981fda58930af09bd1563a20ca8e40839d8bdbda5b8403774cf391d SHA512 b7797f969bf3431f883a5e8288b748494a9c9d8448c7bcde6642b538e20c6fe99acc296ba7bc940739c53619ee672a46ff787c66d75900f45a057f2660da0e5f WHIRLPOOL 8e1b8646b720f2db3f1a556f57975c9556e4a0d3b36479b6ad58607abe0d9f2629ef7275def4ef6a9dc4b73268376fa07c78b8dac3bd5b8bd90ff70dd706f4cf
+DIST carbon-c-relay-0.40.tar.gz 57697 SHA256 38e3b93f4a46e72f11c30f84bd0a0a77862d8d3cd1904447678eabfce89a0468 SHA512 6d77d521eba6dfa576810f3e850f091431a76282f5c7c85a72af300cff18b0dec8738dd00d9555933fbf486ce9656ea4f06332644bfccc634078c90937705aaa WHIRLPOOL ddaf8d02168a10f1e0e2dd8701cd430aefe7346164016a41e25850b2871d541f9002c93063d0836d40caf6db2ff380183d8a4e145df89324be33ef22386bec39
+DIST carbon-c-relay-0.43.tar.gz 63005 SHA256 de55c2af2392910f28a28dab96faa24a394bf1038f4cc045d4db5f8a0180603e SHA512 9c81011131c242b96c198a299fb26661cceb4a6b66c387f4201fe156cc025ec5ccc9962573eec11f3f98a808ba38638a18dd6b2c535dea61c9eec009e22c0e44 WHIRLPOOL 895b31b54a0b7d28c80cfbe16b0ae0012a87adea738f49f503966c159ea0c536aeb6a6cbf424ed325811b85b1fe376a0aab969abd66d08c553dd300c6707a02c
diff --git a/app-misc/carbon-c-relay/carbon-c-relay-0.39-r1.ebuild b/app-misc/carbon-c-relay/carbon-c-relay-0.39-r1.ebuild
new file mode 100644
index 000000000000..043c4667d003
--- /dev/null
+++ b/app-misc/carbon-c-relay/carbon-c-relay-0.39-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs user
+
+DESCRIPTION="Enhanced C version of Carbon relay, aggregator and rewriter"
+HOMEPAGE="https://github.com/grobian/carbon-c-relay"
+SRC_URI="https://github.com/grobian/carbon-c-relay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ enewgroup carbon
+ enewuser carbon -1 -1 -1 carbon
+}
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ newbin relay ${PN}
+ dodoc README.md
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/app-misc/carbon-c-relay/carbon-c-relay-0.40.ebuild b/app-misc/carbon-c-relay/carbon-c-relay-0.40.ebuild
new file mode 100644
index 000000000000..9789bc255125
--- /dev/null
+++ b/app-misc/carbon-c-relay/carbon-c-relay-0.40.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs user
+
+DESCRIPTION="Enhanced C version of Carbon relay, aggregator and rewriter"
+HOMEPAGE="https://github.com/grobian/carbon-c-relay"
+SRC_URI="https://github.com/grobian/carbon-c-relay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ enewgroup carbon
+ enewuser carbon -1 -1 -1 carbon
+}
+
+src_prepare() {
+ tc-export CC
+ tc-has-openmp || sed -i -e '/-fopenmp/s/^/#/' Makefile
+}
+
+src_install() {
+ newbin relay ${PN}
+ dodoc README.md
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/app-misc/carbon-c-relay/carbon-c-relay-0.43.ebuild b/app-misc/carbon-c-relay/carbon-c-relay-0.43.ebuild
new file mode 100644
index 000000000000..e20b1c5dec80
--- /dev/null
+++ b/app-misc/carbon-c-relay/carbon-c-relay-0.43.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs user
+
+DESCRIPTION="Enhanced C version of Carbon relay, aggregator and rewriter"
+HOMEPAGE="https://github.com/grobian/carbon-c-relay"
+SRC_URI="https://github.com/grobian/carbon-c-relay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ enewgroup carbon
+ enewuser carbon -1 -1 -1 carbon
+}
+
+src_prepare() {
+ tc-export CC
+ tc-has-openmp || export OPENMP_FLAGS=
+}
+
+src_install() {
+ newbin relay ${PN}
+ dodoc README.md
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/app-misc/carbon-c-relay/files/carbon-c-relay.confd b/app-misc/carbon-c-relay/files/carbon-c-relay.confd
new file mode 100644
index 000000000000..b07846c933e7
--- /dev/null
+++ b/app-misc/carbon-c-relay/files/carbon-c-relay.confd
@@ -0,0 +1,16 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# routing file to read
+#ROUTES_FILE=/etc/carbon-c-relay.conf
+
+# where to store the PID-file
+#PIDFILE=/run/carbon-c-relay.pid
+
+# user and group to run carbon-c-relay as
+#USER=carbon
+#GROUP=carbon
+
+# any options to use when starting the relay
+#EXTRA_OPTS=
diff --git a/app-misc/carbon-c-relay/files/carbon-c-relay.initd b/app-misc/carbon-c-relay/files/carbon-c-relay.initd
new file mode 100644
index 000000000000..40efa5286a6b
--- /dev/null
+++ b/app-misc/carbon-c-relay/files/carbon-c-relay.initd
@@ -0,0 +1,71 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_commands="configtest"
+extra_started_commands="reload"
+
+description="Lightweight graphite metrics router and aggregator."
+description_configtest="Run carbon-c-relay's internal config check."
+description_reload="Reload the carbon-c-relay configuration without losing connections."
+
+routes_config=${ROUTES_FILE:-/etc/${SVCNAME}.conf}
+
+command="/usr/bin/carbon-c-relay"
+command_args="-f ${routes_config} ${EXTRA_OPTS}"
+pidfile=${PIDFILE:-/run/${SVCNAME}.pid}
+user=${USER:-carbon}
+group=${GROUP:-carbon}
+
+depend() {
+ need net
+ use dns
+}
+
+start_pre() {
+ if [ "${RC_CMD}" != "restart" ]; then
+ configtest || return 1
+ fi
+ touch /var/log/${SVCNAME}.log
+ chown ${user}:${group} /var/log/${SVCNAME}.log
+}
+
+stop_pre() {
+ if [ "${RC_CMD}" = "restart" ]; then
+ configtest || return 1
+ fi
+}
+
+stop_post() {
+ rm -f ${pidfile}
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --background --make-pidfile --pidfile ${pidfile} \
+ --stdout /var/log/${SVCNAME}.log \
+ --stderr /var/log/${SVCNAME}.log \
+ --user ${user} --group ${group} \
+ --exec ${command} -- ${command_args}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec ${command} --pidfile ${pidfile}
+ eend $?
+}
+
+reload() {
+ configtest || return 1
+ ebegin "Refreshing ${SVCNAME}'s configuration"
+ kill -HUP $(< ${pidfile}) &>/dev/null
+ eend $? "Failed to reload ${SVCNAME}"
+}
+
+configtest() {
+ ebegin "Checking ${SVCNAME}'s configuration"
+ ${command} -f "${routes_config}" -t < /dev/null > /dev/null
+ eend $? "failed, please correct errors above"
+}
diff --git a/app-misc/carbon-c-relay/metadata.xml b/app-misc/carbon-c-relay/metadata.xml
new file mode 100644
index 000000000000..0b5431e071ab
--- /dev/null
+++ b/app-misc/carbon-c-relay/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">grobian/carbon-c-relay</remote-id>
+ </upstream>
+</pkgmetadata>