summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/fsniper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/fsniper')
-rw-r--r--app-misc/fsniper/Manifest1
-rw-r--r--app-misc/fsniper/files/fsniper-1.3.1-format-security.patch26
-rw-r--r--app-misc/fsniper/files/fsniper-1.3.1-umask.patch18
-rw-r--r--app-misc/fsniper/fsniper-1.3.1-r1.ebuild26
-rw-r--r--app-misc/fsniper/metadata.xml8
5 files changed, 79 insertions, 0 deletions
diff --git a/app-misc/fsniper/Manifest b/app-misc/fsniper/Manifest
new file mode 100644
index 000000000000..1e6bde51d0f5
--- /dev/null
+++ b/app-misc/fsniper/Manifest
@@ -0,0 +1 @@
+DIST fsniper-1.3.1.tar.gz 282700 SHA256 e65a34221fc05eb7ececcd2fb783e3418de032f89082e09be3a8f75f6b056e6b SHA512 285b56ca239fb9c2c0319c8c5d24e368cda89d547bae25f69b528167c6fa5ebaab31f7fa178cb6b02735168043150605724ac14cc65e7347c6e49e2dc1e5ba87 WHIRLPOOL 8eb15c409baa1166e5b12fca29cc7a4b2e131d56664ef9966cf51574647eed2203386da9118cc65a678f1004e579422d4c23c155021284fec4d7e921ab3f717d
diff --git a/app-misc/fsniper/files/fsniper-1.3.1-format-security.patch b/app-misc/fsniper/files/fsniper-1.3.1-format-security.patch
new file mode 100644
index 000000000000..70c9460f97d2
--- /dev/null
+++ b/app-misc/fsniper/files/fsniper-1.3.1-format-security.patch
@@ -0,0 +1,26 @@
+From d15abeb19d1692698e0ec8a9f4a764a210e57a2b Mon Sep 17 00:00:00 2001
+From: Jakub Hrozek <jhrozek@redhat.com>
+Date: Tue, 3 Dec 2013 10:50:29 +0100
+Subject: [PATCH] Fix an error message
+
+This patch fixes https://bugzilla.redhat.com/show_bug.cgi?id=1037073
+---
+ src/handle_event.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/handle_event.c b/src/handle_event.c
+index 22f35f10ea3a6083c2ef933f794b529b8879a1ed..cac004b76917c192ad9bf8801062d701e4dc18c6 100644
+--- a/src/handle_event.c
++++ b/src/handle_event.c
+@@ -313,7 +313,7 @@ void handle_event(struct inotify_event* event, int writefd)
+ if (sysret == 127)
+ {
+ temp = malloc(27 + strlen(handler->value) + 20 + 1);
+- sprintf("Could not execute handler \"%s\", trying next one.\n", handler->value);
++ sprintf(temp, "Could not execute handler \"%s\", trying next one.\n", handler->value);
+ write_out(writefd, temp);
+
+ free(temp);
+--
+1.8.4.2
+
diff --git a/app-misc/fsniper/files/fsniper-1.3.1-umask.patch b/app-misc/fsniper/files/fsniper-1.3.1-umask.patch
new file mode 100644
index 000000000000..39aecaa3e0d1
--- /dev/null
+++ b/app-misc/fsniper/files/fsniper-1.3.1-umask.patch
@@ -0,0 +1,18 @@
+X-Git-Url: http://code.l3ib.org/?p=fsniper.git;a=blobdiff_plain;f=src%2Fmain.c;fp=src%2Fmain.c;h=cd49dffebe4b4c728b62c28c1381c4fb6f5ad87d;hp=03a8d701d6f9802ba346b591429e58741ca53479;hb=82cb0b46c48485fd4f6231ce3169c7be87d1ea07;hpb=2bbeb5d6e6b55bb9692c043fcdbeab15d9723c9e
+
+diff --git a/src/main.c b/src/main.c
+index 03a8d70..cd49dff 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -153,7 +153,10 @@ char *get_pid_filename()
+ void write_pid_file(char *pidfilename)
+ {
+ FILE *pidfile;
++ mode_t umask_old;
++ umask_old = umask(0177);
+ pidfile = fopen(pidfilename, "w");
++ umask(umask_old);
+ fprintf(pidfile, "%d", getpid());
+ fclose(pidfile);
+ }
+
diff --git a/app-misc/fsniper/fsniper-1.3.1-r1.ebuild b/app-misc/fsniper/fsniper-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..2494522dd6ed
--- /dev/null
+++ b/app-misc/fsniper/fsniper-1.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Tool that monitors a given set of directories for new files"
+HOMEPAGE="https://github.com/l3ib/fsniper/"
+SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libpcre
+ sys-apps/file"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-umask.patch
+)
diff --git a/app-misc/fsniper/metadata.xml b/app-misc/fsniper/metadata.xml
new file mode 100644
index 000000000000..12e19ee50e91
--- /dev/null
+++ b/app-misc/fsniper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <upstream>
+ <remote-id type="github">l3ib/fsniper</remote-id>
+ </upstream>
+</pkgmetadata>