summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/note
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/note')
-rw-r--r--app-misc/note/Manifest1
-rw-r--r--app-misc/note/metadata.xml12
-rw-r--r--app-misc/note/note-1.3.3-r1.ebuild56
3 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/note/Manifest b/app-misc/note/Manifest
new file mode 100644
index 000000000000..4d7860e8d05d
--- /dev/null
+++ b/app-misc/note/Manifest
@@ -0,0 +1 @@
+DIST note-1.3.3.tar.gz 42691 SHA256 5287906338554a1ea06105048b5b6c5457076e44475a58e43433be775c108365 SHA512 99744394084eec3bf84ecef10b2bc294375f18f6ce41614316c4f4bc02a73297f4b3a956f48fb424bb0b0f100ea23debea49c1029887ca52043dd733de0fcfad WHIRLPOOL 67fece1ca8b63685e3bd587c8831cdf021c771e498eaeb690423dfafe2d6d5a25940f2f0f047ec681320dd9610f7b9e24f42587b7d99819ecf1f2390fb3d42bf
diff --git a/app-misc/note/metadata.xml b/app-misc/note/metadata.xml
new file mode 100644
index 000000000000..622e71e1aee3
--- /dev/null
+++ b/app-misc/note/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+</maintainer>
+<use>
+ <flag name='general'>Add support for ascii flatfile backend</flag>
+ <flag name='text'>Add support for text backend</flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/note/note-1.3.3-r1.ebuild b/app-misc/note/note-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..33575e76e8e7
--- /dev/null
+++ b/app-misc/note/note-1.3.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A note taking perl program"
+HOMEPAGE="http://www.daemon.de/NOTE"
+SRC_URI="http://www.daemon.de/files/mirror/ftp.daemon.de/scip/Apps/note/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="crypt dbm general mysql text"
+
+DEPEND="dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Perl
+ virtual/perl-Storable
+ dev-perl/Config-General
+ crypt? ( dev-perl/crypt-cbc
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-DES )
+ mysql? ( virtual/mysql
+ dev-perl/DBD-mysql )"
+RDEPEND=""
+
+src_install() {
+ perl-module_src_install
+
+ # Adding some basic utitily for testing note
+ dodir /usr/share/${PN}
+ cp "${S}/bin/stresstest.sh" "${D}/usr/share/${PN}"
+
+ # Adding some help for mysql backend driver
+ if use mysql; then
+ dodir /usr/share/${PN}/mysql
+ cp -r "${S}/mysql" "${D}/usr/share/${PN}"
+ fi
+
+ # Adding a sample configuration file
+ dodir /etc
+ cp "${S}/config/noterc" "${D}/etc"
+
+ # Supressing file not needed
+ for v in mysql text dbm general; do
+ if ! use ${v}; then
+ for u in `find "${D}" -type f -name *${v}.*pm`; do
+ rm "${u}"
+ done
+ fi
+ done
+
+ dodoc UPGRADE VERSION
+}