summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-12 17:01:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-15 10:01:12 +0200
commit711de458638bfbed9626b775b8f34e7fdb527191 (patch)
treefd1b0cbe75ab69e03246937d7c54c226bee2fe26 /app-misc/screenfetch
parentruby-ng-gnome2.eclass: add proper EAPI guard (diff)
downloadgentoo-711de458638bfbed9626b775b8f34e7fdb527191.tar.gz
gentoo-711de458638bfbed9626b775b8f34e7fdb527191.tar.bz2
gentoo-711de458638bfbed9626b775b8f34e7fdb527191.zip
app-misc/screenfetch: add ~arm keyword.
Bug: https://bugs.gentoo.org/621342 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9203
Diffstat (limited to 'app-misc/screenfetch')
-rw-r--r--app-misc/screenfetch/metadata.xml28
-rw-r--r--app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild35
2 files changed, 49 insertions, 14 deletions
diff --git a/app-misc/screenfetch/metadata.xml b/app-misc/screenfetch/metadata.xml
index a91c788aff05..63bb6250ef47 100644
--- a/app-misc/screenfetch/metadata.xml
+++ b/app-misc/screenfetch/metadata.xml
@@ -1,18 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>hwoarang@gentoo.org</email>
- <name>Markos Chandras</name>
- </maintainer>
- <maintainer type="person">
- <email>johu@gentoo.org</email>
- <name>Johannes Huber</name>
- </maintainer>
- <use>
- <flag name="X">Use the <pkg>media-gfx/scrot</pkg> package to take screenshots</flag>
- </use>
- <upstream>
- <remote-id type="github">KittyKatt/screenFetch</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <use>
+ <flag name="X">Use the <pkg>media-gfx/scrot</pkg> package to take screenshots</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">KittyKatt/screenFetch</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild b/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild
new file mode 100644
index 000000000000..673c98a4a09f
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/f/F}"
+
+DESCRIPTION="Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="curl X"
+
+DEPEND=""
+RDEPEND="
+ curl? ( net-misc/curl )
+ X? (
+ media-gfx/scrot
+ x11-apps/xdpyinfo
+ )"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+ SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ einstalldocs
+}