summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2017-06-16 01:18:02 -0700
committerMichał Górny <mgorny@gentoo.org>2017-06-18 22:57:01 +0200
commit4fbd7aae1abf3bedaf8c1c2eb71e72ae5f83a057 (patch)
tree4886de65b5c8ca8ba9774bbc37269abb53ebaf68 /app-misc
parentdev-lua/lutok: ia64 keyworded, bug #617758 (diff)
downloadgentoo-4fbd7aae1abf3bedaf8c1c2eb71e72ae5f83a057.tar.gz
gentoo-4fbd7aae1abf3bedaf8c1c2eb71e72ae5f83a057.tar.bz2
gentoo-4fbd7aae1abf3bedaf8c1c2eb71e72ae5f83a057.zip
app-misc/pwsafe: support libressl
Gentoo-Bug: https://bugs.gentoo.org/620784 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pwsafe/pwsafe-0.2.0-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/pwsafe/pwsafe-0.2.0-r4.ebuild b/app-misc/pwsafe/pwsafe-0.2.0-r4.ebuild
new file mode 100644
index 000000000000..d789863bdfd1
--- /dev/null
+++ b/app-misc/pwsafe/pwsafe-0.2.0-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Password Safe compatible command-line password manager"
+HOMEPAGE="http://nsd.dyndns.org/pwsafe/"
+SRC_URI="http://nsd.dyndns.org/pwsafe/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X libressl readline"
+
+DEPEND="sys-libs/ncurses:0=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ readline? ( sys-libs/readline:0= )
+ X? ( x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${P}-cvs-1.57.patch"
+ eapply -p0 "${FILESDIR}/${P}-printf.patch"
+ eapply -p0 "${FILESDIR}/${P}-fake-readline.patch"
+ eapply -p0 "${FILESDIR}/${P}-man-page-option-syntax.patch"
+ eapply -p0 "${FILESDIR}/${P}-XChangeProperty.patch"
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with X x) $(use_with readline)
+}
+
+src_install() {
+ doman pwsafe.1
+ dobin pwsafe
+ dodoc README NEWS
+}