summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 16:02:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 20:40:09 +0100
commit634a047520c11151ac1316bd382327fd1efcbfb9 (patch)
treeff1b9258825c2036d2803bcf1028b19dd09a7caa /app-office/calligra
parentapp-office/calligra: Split out plan, fix build with >=poppler-0.71 (diff)
downloadgentoo-634a047520c11151ac1316bd382327fd1efcbfb9.tar.gz
gentoo-634a047520c11151ac1316bd382327fd1efcbfb9.tar.bz2
gentoo-634a047520c11151ac1316bd382327fd1efcbfb9.zip
app-office/calligra: Drop bogus Qt5WebKit dependency
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/calligra')
-rw-r--r--app-office/calligra/calligra-3.1.0-r3.ebuild7
-rw-r--r--app-office/calligra/files/calligra-3.1.0-no-webkit.patch70
2 files changed, 71 insertions, 6 deletions
diff --git a/app-office/calligra/calligra-3.1.0-r3.ebuild b/app-office/calligra/calligra-3.1.0-r3.ebuild
index 46e011852b1e..0fe2f8fc9595 100644
--- a/app-office/calligra/calligra-3.1.0-r3.ebuild
+++ b/app-office/calligra/calligra-3.1.0-r3.ebuild
@@ -95,7 +95,6 @@ COMMON_DEPEND="
x11-libs/libX11
)
calligra_experimental_features_stage? (
- $(add_qt_dep qtwebkit)
okular? ( $(add_kdeapps_dep okular) )
)
calligra_features_sheets? ( dev-cpp/eigen:3 )
@@ -124,6 +123,7 @@ PATCHES=(
"${FILESDIR}"/${P}-stage-qt-5.11.patch
"${FILESDIR}"/${P}-poppler-0.69.patch
"${FILESDIR}"/${P}-poppler-0.71.patch
+ "${FILESDIR}"/${P}-no-webkit.patch
)
pkg_pretend() {
@@ -147,11 +147,6 @@ src_prepare() {
punt_bogus_dep Qt5 Declarative
punt_bogus_dep Qt5 OpenGL
- if ! use calligra_experimental_features_stage; then
- punt_bogus_dep Qt5 WebKitWidgets
- punt_bogus_dep Qt5 WebKit
- fi
-
# Hack around the excessive use of CMake macros
if use okular && ! use calligra_features_words; then
sed -i -e "/add_subdirectory( *okularodtgenerator *)/ s/^/#DONT/" \
diff --git a/app-office/calligra/files/calligra-3.1.0-no-webkit.patch b/app-office/calligra/files/calligra-3.1.0-no-webkit.patch
new file mode 100644
index 000000000000..f126e2e51386
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.1.0-no-webkit.patch
@@ -0,0 +1,70 @@
+From 9817c4c2ee1e11ae1d2eacb31b8a2a65d6ea6e8d Mon Sep 17 00:00:00 2001
+From: Dag Andersen <danders@get2net.dk>
+Date: Mon, 22 Oct 2018 09:41:53 +0200
+Subject: Stage does not use WebKit, so remove
+
+---
+ CMakeLists.txt | 21 +--------------------
+ stage/part/CMakeLists.txt | 1 -
+ 2 files changed, 1 insertion(+), 21 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8b148c0..1e29140 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -272,14 +272,7 @@ find_package(Qt5 ${REQUIRED_QT_VERSION} QUIET
+ Quick
+ QuickWidgets
+ Sql
+- WebKit
+-# WebKitWidgets
+-)
+-message("**********************************************************************************************************************")
+-message("**********************************************************************************************************************")
+-message("Qt WebKitWidgets is required for Stage's html export preview. This will need porting, as that module no longer exists.")
+-message("**********************************************************************************************************************")
+-message("**********************************************************************************************************************")
++)
+
+ # Qt5Declarative was removed in Qt 5.6.0 so search for it in a separate call
+ # Including it in a collected find_package(Qt5 ...) call can lead to a fatal not-found error:
+@@ -313,14 +306,6 @@ set_package_properties(Qt5WebKit PROPERTIES
+ PURPOSE "Required for Braindump's Web shape"
+ TYPE OPTIONAL
+ )
+-set_package_properties(Qt5WebKitWidget PROPERTIES
+- PURPOSE "Required for Stage"
+- TYPE RECOMMENDED
+-)
+-
+-if(Qt5WebKit_FOUND)
+- add_definitions( -DCAN_USE_QTWEBKIT )
+-endif()
+
+ set(HAVE_OPENGL ${Qt5OpenGL_FOUND})
+
+@@ -983,10 +968,6 @@ calligra_drop_product_on_bad_condition( FEATURE_RDF
+ Soprano_FOUND "Soprano not found"
+ )
+
+-# calligra_drop_product_on_bad_condition( PART_STAGE
+-# Qt5WebKitWidgets_FOUND "Qt5WebKitWidgets devel not found"
+-# )
+-
+ calligra_drop_product_on_bad_condition( PART_SHEETS
+ EIGEN3_FOUND "Eigen devel not found"
+ )
+diff --git a/stage/part/CMakeLists.txt b/stage/part/CMakeLists.txt
+index d6000a1..9bdc840 100644
+--- a/stage/part/CMakeLists.txt
++++ b/stage/part/CMakeLists.txt
+@@ -165,7 +165,6 @@ target_link_libraries(calligrastageprivate
+ KF5::IconThemes
+ KF5::Completion
+ Qt5::Svg
+-# Qt5::WebKitWidgets
+ )
+ if(HAVE_OPENGL)
+ target_link_libraries(calligrastageprivate PRIVATE Qt5::OpenGL)
+--
+cgit v1.1