summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/glabels
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/glabels')
-rw-r--r--app-office/glabels/Manifest2
-rw-r--r--app-office/glabels/glabels-3.2.0.ebuild43
-rw-r--r--app-office/glabels/glabels-3.2.1.ebuild43
-rw-r--r--app-office/glabels/metadata.xml14
4 files changed, 102 insertions, 0 deletions
diff --git a/app-office/glabels/Manifest b/app-office/glabels/Manifest
new file mode 100644
index 000000000000..d1c53762c71f
--- /dev/null
+++ b/app-office/glabels/Manifest
@@ -0,0 +1,2 @@
+DIST glabels-3.2.0.tar.xz 3359392 SHA256 c4c5b2c911be7b6513ee5cfeda6cd78434623c24dd741bd29cc3573f90b374c9 SHA512 67faab8eb9f4128b532bce55a9fab34462c008d0990ba87e4d555359bec1bb162489d4bdf5efbb86c4fcfc708c92da4d88a91dd2a85f0989c9133af6b011c3ff WHIRLPOOL f79e3d15ba32041133654fd67c7e05c4bba9e8d899344c52b503c1232ddc5cce8efcec20937c2d21d4f7fa3164a6d4c5ff8f1d9a770dea59c24fcc524b460673
+DIST glabels-3.2.1.tar.xz 3368052 SHA256 db615f653b6e78ef1209814b5e6d8d3af4f8d3444a259ddbcc0dfb279c7df855 SHA512 d68fab2697cc596d45fe19c0a4c02a7bceffcb12ff72d71aaff565c62e95afeab6c2cc5b0eb00581c992b576b7ffe81d7b7a0763be2044186ba07929de78a266 WHIRLPOOL 3c0c9d1fba0548442d19a3271f466c1cf84db361d527da4b6c00d231c56a6fb7c1c61b4015d640e805878b7774ba89920c3c4ebc19b2f3fb1049d9bef12bbbc7
diff --git a/app-office/glabels/glabels-3.2.0.ebuild b/app-office/glabels/glabels-3.2.0.ebuild
new file mode 100644
index 000000000000..49a2fa7f6b11
--- /dev/null
+++ b/app-office/glabels/glabels-3.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Program for creating labels and business cards"
+HOMEPAGE="http://www.glabels.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="barcode eds"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.2:2
+ >=x11-libs/gtk+-3.0.9:3
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-base/librsvg-2.32.0:2
+ >=x11-libs/cairo-1.10.0
+ >=x11-libs/pango-1.28.1
+ barcode? (
+ >=app-text/barcode-0.98
+ >=media-gfx/qrencode-3.1 )
+ eds? ( >=gnome-extra/evolution-data-server-2.30.3 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.28
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with eds libebook) \
+ --disable-static
+}
diff --git a/app-office/glabels/glabels-3.2.1.ebuild b/app-office/glabels/glabels-3.2.1.ebuild
new file mode 100644
index 000000000000..8d3a9b48a82c
--- /dev/null
+++ b/app-office/glabels/glabels-3.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Program for creating labels and business cards"
+HOMEPAGE="http://www.glabels.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="barcode eds"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.2:2
+ >=x11-libs/gtk+-3.0.9:3
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-base/librsvg-2.32.0:2
+ >=x11-libs/cairo-1.10.0
+ >=x11-libs/pango-1.28.1
+ barcode? (
+ >=app-text/barcode-0.98
+ >=media-gfx/qrencode-3.1 )
+ eds? ( >=gnome-extra/evolution-data-server-2.30.3:= )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.28
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with eds libebook) \
+ --disable-static
+}
diff --git a/app-office/glabels/metadata.xml b/app-office/glabels/metadata.xml
new file mode 100644
index 000000000000..6cab71eddf79
--- /dev/null
+++ b/app-office/glabels/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-office</herd>
+<longdescription>
+ gLabels is a program for creating labels and business cards for
+ the GNOME desktop environment. It is designed to work with various
+ laser/ink-jet peel-off label and business card sheets that you'll
+ find at most office supply stores.
+</longdescription>
+<use>
+ <flag name="barcode">Enable barcode support through external libraries.</flag>
+</use>
+</pkgmetadata>