summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-02-07 23:45:48 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-02-08 00:20:09 +0100
commitae05fbc5f5d9e46372a23a9d8efaca469099c1c3 (patch)
tree3f98bad8e198f41f6f912094701ad3bf05fadf9b /app-office/gnumeric
parentx11-libs/goffice: version 0.10.35 → 0.10.38 (diff)
downloadgentoo-ae05fbc5f5d9e46372a23a9d8efaca469099c1c3.tar.gz
gentoo-ae05fbc5f5d9e46372a23a9d8efaca469099c1c3.tar.bz2
gentoo-ae05fbc5f5d9e46372a23a9d8efaca469099c1c3.zip
app-office/gnumeric: version bump 1.12.35 → 1.12.38
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.38.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 36594c87831e..d371282a2df4 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.35.tar.xz 20019316 BLAKE2B 45e0097c37c05dc6295994434b9d181f447a1edca2080f699f5bd73112e794014449fe863890389f6d17370f834e9a79c1f3a1e094d3556de09956a712b63088 SHA512 0781c0d003342653a7cb57d2f23d1222903f18fdce15f4276250aae66239fc5f0da6472d900a59d29b511fbf55b529f7923a68f346752cd242775d52f99aba11
+DIST gnumeric-1.12.38.tar.xz 19807364 BLAKE2B 5b250991d2a635334d1799b421733a50cbe5dc92c3b792f0c8f3635a37bb72601f62e444ed7cb705ae7456b804fd16e8ab7c1b6567db27a9f12b4b5407b30e1b SHA512 71cf29355b865a3c0f966482ef0cbc90553326fcdc10103762d6c35c1f932371b5dffa3d3d89cd575d3f202ba041e4caaf987db08051b700757ea165508ea217
diff --git a/app-office/gnumeric/gnumeric-1.12.38.ebuild b/app-office/gnumeric/gnumeric-1.12.38.ebuild
new file mode 100644
index 000000000000..4c5b03f89eb7
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.38.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.38:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ app-text/yelp-tools
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}