summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-20 00:10:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-20 00:56:00 +0100
commit6b6a048bc18c3c4532aa4ba3c9e8326108224018 (patch)
treee94b244bc98c87e8bd4057cf920143a1c3367253 /app-office/kexi
parentdev-java/tomcat-servlet-api: stable 8.5.23 for ppc64, bug #637656 (diff)
downloadgentoo-6b6a048bc18c3c4532aa4ba3c9e8326108224018.tar.gz
gentoo-6b6a048bc18c3c4532aa4ba3c9e8326108224018.tar.bz2
gentoo-6b6a048bc18c3c4532aa4ba3c9e8326108224018.zip
app-office/kexi: Fix build with Qt 5.11
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-office/kexi')
-rw-r--r--app-office/kexi/files/kexi-3.1.0-qt-5.11.patch24
-rw-r--r--app-office/kexi/kexi-3.1.0.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/app-office/kexi/files/kexi-3.1.0-qt-5.11.patch b/app-office/kexi/files/kexi-3.1.0-qt-5.11.patch
new file mode 100644
index 000000000000..a879b2a46045
--- /dev/null
+++ b/app-office/kexi/files/kexi-3.1.0-qt-5.11.patch
@@ -0,0 +1,24 @@
+From c7b9215e7ae30a052fa11aa4199e7adea517c7e2 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Tue, 20 Mar 2018 00:06:46 +0100
+Subject: [PATCH] Fix build with Qt 5.11 (missing headers)
+
+---
+ src/main/startup/KexiNewProjectAssistant.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/main/startup/KexiNewProjectAssistant.cpp b/src/main/startup/KexiNewProjectAssistant.cpp
+index 59e819acc..6568f1b5c 100644
+--- a/src/main/startup/KexiNewProjectAssistant.cpp
++++ b/src/main/startup/KexiNewProjectAssistant.cpp
+@@ -48,6 +48,7 @@
+ #include <KIconLoader>
+ #include <KStandardGuiItem>
+
++#include <QAction>
+ #include <QDebug>
+ #include <QLayout>
+ #include <QCheckBox>
+--
+2.16.2
+
diff --git a/app-office/kexi/kexi-3.1.0.ebuild b/app-office/kexi/kexi-3.1.0.ebuild
index fa15f9b5f72d..8ceeaf7b7c77 100644
--- a/app-office/kexi/kexi-3.1.0.ebuild
+++ b/app-office/kexi/kexi-3.1.0.ebuild
@@ -62,6 +62,8 @@ RDEPEND="${COMMON_DEPEND}
!app-office/calligra-l10n:4[calligra_features_kexi(+)]
"
+PATCHES=( "${FILESDIR}"/${P}-qt-5.11.patch )
+
src_prepare() {
if ! use webkit; then
punt_bogus_dep Qt5 WebKit