summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/orage
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/Manifest2
-rw-r--r--app-office/orage/metadata.xml8
-rw-r--r--app-office/orage/orage-4.10.0.ebuild53
-rw-r--r--app-office/orage/orage-4.12.1.ebuild54
4 files changed, 117 insertions, 0 deletions
diff --git a/app-office/orage/Manifest b/app-office/orage/Manifest
new file mode 100644
index 000000000000..de16eb73e20d
--- /dev/null
+++ b/app-office/orage/Manifest
@@ -0,0 +1,2 @@
+DIST orage-4.10.0.tar.bz2 2513559 SHA256 6cb854f3437e31bab23abfce97bd10afa1636a9a1480d80e14e26c85d06be7c0 SHA512 860d26ecf32e4efd9bd39dde206aac5c60bd10f1154ec7d348d2ec8e5516cc3dd98314e56d496f153a89764f2c46b2ed7cec49b6edd8d05a62265558721c9889 WHIRLPOOL 0ad86bb0d2a6afeba39957159757b9094faf0711207f6c9dacfacdd02a2a565ab2d44fb164a194550343daee81a0394138e3c981e9e5b562793d09b5851724ec
+DIST orage-4.12.1.tar.bz2 2590788 SHA256 3cf9aa441ae83c8688865f82217025cdf3ebaa152cce4571777b8c2aa8dd9062 SHA512 3fec0201171140586cdc9bcf151450a7086515e18b5815afe4fe4c4726ba554c50582b0479e52985b330140c51b7233ef81f678f986f848afbeee74c66b2d196 WHIRLPOOL 59a91665477f0e2a97629bf46abe8397229eb82d932fd4111baa41e5a38a23c9a7cfb9722ae672b5f101b6543fd998ad0f695e1db9a50895b35ced2eaa7e60fe
diff --git a/app-office/orage/metadata.xml b/app-office/orage/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/app-office/orage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/orage/orage-4.10.0.ebuild b/app-office/orage/orage-4.10.0.ebuild
new file mode 100644
index 000000000000..6dc5d6cd0178
--- /dev/null
+++ b/app-office/orage/orage-4.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
+
+RDEPEND=">=dev-libs/libical-0.48:=
+ dev-libs/popt:=
+ >=x11-libs/gtk+-2.10:2
+ berkdb? ( >=sys-libs/db-4:= )
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.10 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable xfce_plugins_clock libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ # PM doesn't let directory to be replaced by a symlink, see src_install()
+ rm -rf "${EROOT}"/usr/share/${PN}/doc
+}
+
+src_install() {
+ xfconf_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ imagesdir="${EPREFIX}"/usr/share/doc/${PF}/html/images
+
+ # Create compability symlink for retarded path hardcoding in src/{mainbox,parameters}.c
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc/C
+}
diff --git a/app-office/orage/orage-4.12.1.ebuild b/app-office/orage/orage-4.12.1.ebuild
new file mode 100644
index 000000000000..27364ad07007
--- /dev/null
+++ b/app-office/orage/orage-4.12.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
+
+RDEPEND=">=dev-libs/libical-0.48:=
+ dev-libs/popt:=
+ >=x11-libs/gtk+-2.10:2=
+ berkdb? ( >=sys-libs/db-4:= )
+ dbus? ( >=dev-libs/dbus-glib-0.100:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.10:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable xfce_plugins_clock libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ # PM doesn't let directory to be replaced by a symlink, see src_install()
+ rm -rf "${EROOT}"/usr/share/${PN}/doc
+}
+
+src_install() {
+ xfconf_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ imagesdir="${EPREFIX}"/usr/share/doc/${PF}/html/images
+
+ # Create compability symlink for retarded path hardcoding in src/{mainbox,parameters}.c
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc/C
+}