summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/planner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/Manifest1
-rw-r--r--app-office/planner/metadata.xml5
-rw-r--r--app-office/planner/planner-0.14.6_p20130520.ebuild73
3 files changed, 79 insertions, 0 deletions
diff --git a/app-office/planner/Manifest b/app-office/planner/Manifest
new file mode 100644
index 000000000000..e084edf4fdfd
--- /dev/null
+++ b/app-office/planner/Manifest
@@ -0,0 +1 @@
+DIST planner-0.14.6_p20130520.tar.xz 4200624 SHA256 06b94c7145bbf1f61b6b4ddb847cd2db79f322ee6f89637340ece139eedf8569 SHA512 d658b68c96742340a06a9e96d7910f70fb296cb7a19cc335afdcbec01b36326b1574522155cf19fec012363e1e4d4120c35e1319c699613833be2eb0fa999024 WHIRLPOOL f44941557e2b9af7ab3bebbac59e4d53ac60af7943e5ad03edb249a19ecadc37cfe6530e8295420c84f13b2b2f962a8d9c58bb2345eb4701abfa3dd462f209db
diff --git a/app-office/planner/metadata.xml b/app-office/planner/metadata.xml
new file mode 100644
index 000000000000..20d13ee7e217
--- /dev/null
+++ b/app-office/planner/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-office</herd>
+</pkgmetadata>
diff --git a/app-office/planner/planner-0.14.6_p20130520.ebuild b/app-office/planner/planner-0.14.6_p20130520.ebuild
new file mode 100644
index 000000000000..69891ffd1c88
--- /dev/null
+++ b/app-office/planner/planner-0.14.6_p20130520.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="http://live.gnome.org/Planner/"
+SRC_URI="http://dev.gentoo.org/~eva/distfiles/${PN}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE="eds examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.14:2
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4:2.0
+ >=gnome-base/gconf-2.6:2
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.6:2[${PYTHON_USEDEP}] )
+ eds? (
+ >=gnome-extra/evolution-data-server-3.6:=
+ >=mail-client/evolution-3.6 )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.5
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-0.14.6"
+
+src_configure() {
+ # FIXME: disable eds backend for now, it fails, upstream bug #654005
+ # We need to set compile-warnings to a different value as it doesn't use
+ # standard macro: https://bugzilla.gnome.org/703067
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable python python-plugin) \
+ $(use_enable eds) \
+ --disable-eds-backend \
+ --with-database=no \
+ --disable-update-mimedb \
+ --enable-compile-warnings=yes
+ #$(use_enable eds eds-backend)
+}
+
+src_install() {
+ # error: relink `libstorage-mrproject-1.la' with the above command before installing it
+ # Try to drop workaround on next snapshot or bump
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}