summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Turco <fturco@fastmail.fm>2017-09-07 22:26:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-28 18:51:36 +0200
commit90863b09bea41eb793557549ec84c8d9ca144df4 (patch)
treeee14388b06ef60e2d934157888d988ca0ddc7e57 /app-office
parentapp-text/master-pdf-editor: new ebuild. (diff)
downloadgentoo-90863b09bea41eb793557549ec84c8d9ca144df4.tar.gz
gentoo-90863b09bea41eb793557549ec84c8d9ca144df4.tar.bz2
gentoo-90863b09bea41eb793557549ec84c8d9ca144df4.zip
app-office/ledger: Fix build with >=dev-libs/boost-1.61
Gentoo-bug: 609108 Closes: https://github.com/gentoo/gentoo/pull/5655
Diffstat (limited to 'app-office')
-rw-r--r--app-office/ledger/files/ledger-3.1.1-boost.patch22
-rw-r--r--app-office/ledger/ledger-3.1.1.ebuild2
2 files changed, 24 insertions, 0 deletions
diff --git a/app-office/ledger/files/ledger-3.1.1-boost.patch b/app-office/ledger/files/ledger-3.1.1-boost.patch
new file mode 100644
index 000000000000..b69a42a50113
--- /dev/null
+++ b/app-office/ledger/files/ledger-3.1.1-boost.patch
@@ -0,0 +1,22 @@
+From 1856b8c4902498843f4da37a7aaeb2ce85acc1d3 Mon Sep 17 00:00:00 2001
+From: Denis <dkasak@users.noreply.github.com>
+Date: Mon, 12 Sep 2016 12:49:40 +0200
+Subject: [PATCH] Fix compilation error with boost 1.61
+
+---
+ src/item.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/item.h b/src/item.h
+index ca16d87b3..4dc6df7e6 100644
+--- a/src/item.h
++++ b/src/item.h
+@@ -92,7 +92,7 @@ class item_t : public supports_flags<uint_least16_t>, public scope_t
+
+ typedef std::pair<optional<value_t>, bool> tag_data_t;
+ typedef std::map<string, tag_data_t,
+- function<bool(string, string)> > string_map;
++ std::function<bool(string, string)> > string_map;
+
+ state_t _state;
+ optional<date_t> _date;
diff --git a/app-office/ledger/ledger-3.1.1.ebuild b/app-office/ledger/ledger-3.1.1.ebuild
index f32cda9c830f..31ed49d068b1 100644
--- a/app-office/ledger/ledger-3.1.1.ebuild
+++ b/app-office/ledger/ledger-3.1.1.ebuild
@@ -42,6 +42,8 @@ DEPEND="
)
"
+PATCHES=( "${FILESDIR}/${P}-boost.patch" ) # bug 609108
+
# Building with python integration seems to fail without 8G available
# RAM(!) Since the memory check in check-reqs doesn't count swap, it
# may be unfair to fail the build entirely on the memory test alone.