summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-13 20:05:40 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-13 20:07:15 +0100
commitcc67a115f00b8332aa93791656b5827eaa22cde4 (patch)
treec20e2bfd332a9906c9be956eb83518055bd9f181 /app-pda
parentmedia-libs/libomxil-bellagio: Fix build with GCC-5 (diff)
downloadgentoo-cc67a115f00b8332aa93791656b5827eaa22cde4.tar.gz
gentoo-cc67a115f00b8332aa93791656b5827eaa22cde4.tar.bz2
gentoo-cc67a115f00b8332aa93791656b5827eaa22cde4.zip
app-pda/jpilot: Version bump to 1.8.2
Gentoo-bug: 570074 * EAPI=6 * Fix filesystem layout * Remove .la files unconditionally Package-Manager: portage-2.3.3
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/jpilot/Manifest1
-rw-r--r--app-pda/jpilot/files/jpilot-1.8.2-fix-paths.patch119
-rw-r--r--app-pda/jpilot/files/jpilot-1.8.2-qa-desktop-file.patch13
-rw-r--r--app-pda/jpilot/jpilot-1.8.2.ebuild50
4 files changed, 183 insertions, 0 deletions
diff --git a/app-pda/jpilot/Manifest b/app-pda/jpilot/Manifest
index da223612b7d7..dd3a6541ebdf 100644
--- a/app-pda/jpilot/Manifest
+++ b/app-pda/jpilot/Manifest
@@ -1,2 +1,3 @@
DIST jpilot-1.8.0.tar.gz 1604468 SHA256 b00f6b5d2d013572a8e2a6014b247eda855bbd5fef77e59e49dbefb314c57dde SHA512 3ee49248daec4871d6b45497730efbb666481a9ab440ea410a0d793ae4e3894fa47f717941b18c2b9865024a755df2ee0b41449ebb32a70ef5f4142278a3591e WHIRLPOOL bb745942854e8001975744927eae153e284b99cc7f49095332345b834856e912ade7e2be14f30cc47eb1f5d5cecf153379678cdf6cb4c465147166de491b6e5b
DIST jpilot-1.8.1.tar.gz 1582869 SHA256 682838e8f9634102e5721e779fa0f00ec4be747776a575794137f1ce9420291f SHA512 b0415ffeb7284cfc2fb15faf87d14eba29ac15d3a9ca05ad60ed05d8ee6ee4cf89c60a24dbf4095564120d0155100a110969aa44d2ce7e98e05f11332698d052 WHIRLPOOL b297e2797b2ab405e837e40fc4071a8fd9df70fad62ded2287379180282f02450ba3eb713ba1519c2d2618fc5c1af704a959f72e403333662284dfe2d05b1273
+DIST jpilot-1.8.2.tar.gz 1740735 SHA256 2c28ed7acea27ae3d541036f2e2ca5ed7e0121badf477e3cfa5ec8d282337e23 SHA512 733dd51a2acc60760bb1ffaa0d7b4433584a571793d5e4f857492349bae8d032625baf9f0060e619d760628ddda3559bf4be057f45f4dc17ddf1af1ca795c024 WHIRLPOOL 51c834e48b137160d0f313f41a83837428d1a23b0a8955ce8f87fef6dd02051c1705a4f702a543e338cad825303ae4ef89a9f20a3db88875b409404487af622c
diff --git a/app-pda/jpilot/files/jpilot-1.8.2-fix-paths.patch b/app-pda/jpilot/files/jpilot-1.8.2-fix-paths.patch
new file mode 100644
index 000000000000..e378d5699d00
--- /dev/null
+++ b/app-pda/jpilot/files/jpilot-1.8.2-fix-paths.patch
@@ -0,0 +1,119 @@
+* Modify Makefile.am's to be compliant with GNU and Gentoo filesystem conventions
+* Use redefinable variables instead of hard-replacing @VAR@-style variables
+* Replace abuse of 'libdir' install path variables
+
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
+@@ -3,19 +3,17 @@
+ man_MANS = jpilot.1 jpilot-dial.1 jpilot-sync.1 jpilot-dump.1 jpilot-merge.1
+
+ # Install the standard GNU doc files
+-miscdir = $(datadir)/doc/$(PACKAGE)
++miscdir = $(docdir)
+ misc_DATA = \
+ ../BUGS \
+ ../ChangeLog \
+- ../COPYING \
+ ../AUTHORS \
+- ../INSTALL \
+ ../README \
+ ../TODO
+
+ # Install the manual docs
+-docdir = $(miscdir)/manual
+-doc_DATA = \
++manualdir = $(htmldir)
++manual_DATA = \
+ manual.html \
+ plugin.html \
+ jpilot-address.png \
+--- a/Expense/Makefile.am
++++ b/Expense/Makefile.am
+@@ -1,11 +1,11 @@
+-libdir = @libdir@/@PACKAGE@/plugins
++pluginsdir = $(libdir)/$(PACKAGE)/plugins
+
+ if MAKE_EXPENSE
+
+-lib_LTLIBRARIES = libexpense.la
++plugins_LTLIBRARIES = libexpense.la
+ libexpense_la_SOURCES = expense.c
+-libexpense_la_CFLAGS = @PILOT_FLAGS@ @GTK_CFLAGS@ -I$(top_srcdir)
++libexpense_la_CFLAGS = $(PILOT_FLAGS) $(GTK_CFLAGS) -I$(top_srcdir)
+ libexpense_la_LDFLAGS = -module -avoid-version
+-libexpense_la_LIBADD = @GTK_LIBS@
++libexpense_la_LIBADD = $(GTK_LIBS)
+
+ endif
+--- a/icons/Makefile.am
++++ b/icons/Makefile.am
+@@ -1,4 +1,4 @@
+-icondir = $(datadir)/doc/$(PACKAGE)/icons
++icondir = $(docdir)/icons
+ icon_DATA = \
+ jpilot-icon1.xpm \
+ jpilot-icon2.xpm \
+--- a/KeyRing/Makefile.am
++++ b/KeyRing/Makefile.am
+@@ -1,13 +1,13 @@
+-libdir = @libdir@/@PACKAGE@/plugins
++pluginsdir = $(libdir)/$(PACKAGE)/plugins
+
+ EXTRA_DIST = README
+
+ if MAKE_KEYRING
+
+-lib_LTLIBRARIES = libkeyring.la
++plugins_LTLIBRARIES = libkeyring.la
+ libkeyring_la_SOURCES = keyring.c
+-libkeyring_la_CFLAGS = @PILOT_FLAGS@ @GTK_CFLAGS@ @LIBGCRYPT_CFLAGS@ -I$(top_srcdir)
++libkeyring_la_CFLAGS = $(PILOT_FLAGS) $(GTK_CFLAGS) $(LIBGCRYPT_CFLAGS) -I$(top_srcdir)
+ libkeyring_la_LDFLAGS = -module -avoid-version
+-libkeyring_la_LIBADD = @OPENSSL_LIBS@ @GTK_LIBS@ @LIBGCRYPT_LIBS@
++libkeyring_la_LIBADD = $(OPENSSL_LIBS) $(GTK_LIBS) $(LIBGCRYPT_LIBS)
+
+ endif
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -161,18 +161,17 @@
+ ACLOCAL_AMFLAGS = -I m4
+
+ # Add i18n support
+-localedir = $(datadir)/locale
+ I18NDEFS = -DLOCALEDIR=\"$(localedir)\"
+
+-AM_CFLAGS= @PILOT_FLAGS@ @GTK_CFLAGS@ ${I18NDEFS}
++AM_CFLAGS= $(PILOT_FLAGS) $(GTK_CFLAGS) $(I18NDEFS)
+
+ # Add linkflags
+ jpilot_LDFLAGS = -export-dynamic
+-jpilot_LDADD=@LIBS@ @PILOT_LIBS@ @GTK_LIBS@
+-jpilot_dump_LDADD=@LIBS@ @PILOT_LIBS@ @GTK_LIBS@
++jpilot_LDADD=$(LIBS) $(PILOT_LIBS) $(GTK_LIBS)
++jpilot_dump_LDADD=$(LIBS) $(PILOT_LIBS) $(GTK_LIBS)
+ jpilot_sync_LDFLAGS = -export-dynamic
+-jpilot_sync_LDADD=@LIBS@ @PILOT_LIBS@ @GTK_LIBS@
+-jpilot_merge_LDADD=@LIBS@ @PILOT_LIBS@ @GTK_LIBS@
++jpilot_sync_LDADD=$(LIBS) $(PILOT_LIBS) $(GTK_LIBS)
++jpilot_merge_LDADD=$(LIBS) $(PILOT_LIBS) $(GTK_LIBS)
+
+ ################################################################################
+ ## The rest of the file is copied over to the Makefile with only variable
+--- a/SyncTime/Makefile.am
++++ b/SyncTime/Makefile.am
+@@ -1,11 +1,11 @@
+-libdir = @libdir@/@PACKAGE@/plugins
++pluginsdir = $(libdir)/$(PACKAGE)/plugins
+
+ if MAKE_SYNCTIME
+
+-lib_LTLIBRARIES = libsynctime.la
++plugins_LTLIBRARIES = libsynctime.la
+ libsynctime_la_SOURCES = synctime.c
+-libsynctime_la_CFLAGS = @PILOT_FLAGS@ @GTK_CFLAGS@ -I$(top_srcdir)
++libsynctime_la_CFLAGS = $(PILOT_FLAGS) $(GTK_CFLAGS) -I$(top_srcdir)
+ libsynctime_la_LDFLAGS = -module -avoid-version
+-libsynctime_la_LIBADD = @GTK_LIBS@
++libsynctime_la_LIBADD = $(GTK_LIBS)
+
+ endif
diff --git a/app-pda/jpilot/files/jpilot-1.8.2-qa-desktop-file.patch b/app-pda/jpilot/files/jpilot-1.8.2-qa-desktop-file.patch
new file mode 100644
index 000000000000..c4624e1e94e8
--- /dev/null
+++ b/app-pda/jpilot/files/jpilot-1.8.2-qa-desktop-file.patch
@@ -0,0 +1,13 @@
+* The 'Icon=' property should not have a suffix
+
+--- a/jpilot.desktop
++++ b/jpilot.desktop
+@@ -2,7 +2,7 @@
+ Name=J-Pilot
+ Comment=Desktop organizer application for the Palm Pilot
+ Exec=jpilot
+-Icon=jpilot.xpm
++Icon=jpilot
+ Terminal=false
+ Type=Application
+ Categories=Office;PDA;
diff --git a/app-pda/jpilot/jpilot-1.8.2.ebuild b/app-pda/jpilot/jpilot-1.8.2.ebuild
new file mode 100644
index 000000000000..07cbcc3866af
--- /dev/null
+++ b/app-pda/jpilot/jpilot-1.8.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+HOMEPAGE="http://www.jpilot.org/"
+SRC_URI="http://jpilot.org/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-pda/pilot-link
+ dev-libs/libgcrypt:0=
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-qa-desktop-file.patch
+ "${FILESDIR}"/${PN}-1.8.2-fix-paths.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ docompress -x /usr/share/doc/${PF}/icons
+
+ # .la files for plugins are useless
+ find "${D}" -name '*.la' -delete || die
+}