summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/conf-update
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/conf-update')
-rw-r--r--app-portage/conf-update/Manifest1
-rw-r--r--app-portage/conf-update/conf-update-1.0.2.ebuild41
-rw-r--r--app-portage/conf-update/metadata.xml20
3 files changed, 62 insertions, 0 deletions
diff --git a/app-portage/conf-update/Manifest b/app-portage/conf-update/Manifest
new file mode 100644
index 000000000000..76130464779e
--- /dev/null
+++ b/app-portage/conf-update/Manifest
@@ -0,0 +1 @@
+DIST conf-update-1.0.2.tar.bz2 18243 SHA256 1246b83d8927e4333cfcb535217e5f055bc9aa0290f617c2ab1bb97dbeb3de9c SHA512 8611b30e58a9222a024e19d67e957a63d9c44627067a241e4ee5e761f1950ae7f1aa1491f055ba267be65f813ee7da1a8703028736b65dfd2c4ef79ace906f49 WHIRLPOOL 139e07105eed7d8ee5246c24833ecc110c92a5361892a5ee98ea2eee5d30199cbee788f47497d5d32c95c387bbf2df16589faa79c2dbf00b5ca5d347d7483c9e
diff --git a/app-portage/conf-update/conf-update-1.0.2.ebuild b/app-portage/conf-update/conf-update-1.0.2.ebuild
new file mode 100644
index 000000000000..ad496c5527d5
--- /dev/null
+++ b/app-portage/conf-update/conf-update-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="${PN} is a ncurses-based config management utility"
+HOMEPAGE="http://dev.gentoo.org/~nimiux/app-portage/${PN}"
+SRC_URI="http://dev.gentoo.org/~nimiux/app-portage/${PN}/distfiles/${PF}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="colordiff"
+
+RDEPEND=">=dev-libs/glib-2.6
+ sys-libs/ncurses
+ dev-libs/openssl
+ colordiff? ( app-misc/colordiff )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/\$Rev:.*\\$/${PVR}/" "${S}"/"${PN}".h || \
+ die 'version-sed failed'
+
+ if use colordiff ; then
+ sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf || \
+ die 'colordiff-sed failed'
+ fi
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
diff --git a/app-portage/conf-update/metadata.xml b/app-portage/conf-update/metadata.xml
new file mode 100644
index 000000000000..637068688174
--- /dev/null
+++ b/app-portage/conf-update/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>nimiux@gentoo.org</email>
+ <name>Chema Alonso</name>
+</maintainer>
+<longdescription lang="en">
+conf-update is a curses based tool for the Gentoo Linux portage
+system
+</longdescription>
+<longdescription lang="es">
+conf-update es una herramienta basada en curses para el sistema
+portage de Gentoo Linux
+</longdescription>
+<use>
+ <flag name='colordiff'>Use colors when displaying diffs
+ (<pkg>app-misc/colordiff</pkg>)</flag>
+</use>
+</pkgmetadata>